[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • Yes, I know.

    I don´t understand why so much users want to play netflix on amlogic box

    They can use the TV to play netflix up to UHD resolution.

    Do You think it´s possible to enable netflix hardware decoding(amlogic) in the future :?:

    The simple answer is because we WANT to to watch Netflix within LibrELEC. Here is my video showing Netflix playing on 3 different devices connected to my Samsung Smart TV. I don't show Netflix running on my LibreELEC, but guess I should have compared it also.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • Unfortunately to cut your post short the decoders used for Netflix are not hardware accelerated so the maximum resolution you can goto is 720p, this may change in the future as Leia is only at an Alpha stage.

    There is nothing I can do about this, a quick search on the forums would have shown you this as well and saved you a lot of trouble and a pointless upgrade to the UHD package, sorry to be the bearer of bad news.

    Thanks for your reply adamg and sorry I missed finding the info in my search. Normally I am pretty good at finding out the info I want maybe as I was short of time and hurrying too much I missed it. Appreciate your help and now understand why I can not get better than 720 res though most in SD sadly. Sure, I fully accept Leia is still young so will not unfairly judge it for now. As I said I am always here to test now I have broken the ice with a Leia boot up SD card so will follow the progress with interest.

    As to running Netflix directly on my Smart TV well sadly I cannot get a NetFlix Samsung app for my TV model maybe because it is a 6 years old Samsung Series 7, though still gives a truly superb FHD picture as everyone who visits comments. Anyway I just cannot afford to upgrade my TV for some time yet and want to make it well worth it with hopefully an LG OLED 65" once the price comes down. Anyhow I am watching Netflix okay on my Apple TV 3 at what seems like FHD so I got it covered and adamg the upgrade was free anyway as I am on a one month free trial with any package I want to try, so IF I keep the Netflix package I will revert to the middle package for up to FHD.

  • Of course those two ways work, but the new third way on the home screen does not. Didn't realize this was a skin bug instead.


  • I also had trouble with TVHeadend at the start. Seems that it was not able to find services from the given muxes provided during the inital setup. I ran the setup on a system with TVHeadend 4.2 (change remoteip to this system's ip address) and copied the files over using this command and all worked well.

    Also, for anyone having trouble using tv_grab_file for EPG xmltv, run the following command so that it will run using the proper settings.xml file.

    sed -i -e 's/service.tvheadend42/service.tvheadend42/g' ~/.kodi/addons/service.tvheadend44/bin/tv_grab_file

    Edited once, last by Kick4U (February 3, 2018 at 4:52 AM).

  • I have been following the thread since a long time.

    I have recently acquired a s912 box, namely edal T95Z Plus which seems to be exact same hardware as Sunvell T95Z.

    I have revised the thread to figure out the right dtb to use to enable the LCD to no avail.

    I am currently using 8.90.3 version with gxm_q200_2g.dtb and except from LCD everything seems to be functional.

    Can someone point me in the right direction?

    I have read the post with script to check LCD segments, but need to have it enabled first. Have already installed FD628 service.

    Thank you.

  • I'm not sure if one has been created for that box, msg The Coolest for help as he is the new resident expert on all things VFD :)

  • Gaudi

    Please boot up Android, and use Root Explorer to copy the contents (make sure the files aren't empty) of /proc/device-tree/fd628_dev, and post here. I'll create a DTB for you to try on your box to get the display working.

  • i discovered the emulators a few days ago.

    just unlock "games" with a combination of keys.

    (up up down down left right left right b a) and install the zack morris addon

    gameboy games are going great! i love it!

    with nes or snes my ps4 controller will not work.

    the games can be started with the retroplayer but the controller does not react.

    i also tried to configure the ps4 controller but without success.

    What should I do ?

    8.90.3 / KI Pro

  • I've got a couple of boxes - a S905 and a S905x, on both of which I've been running libreelec for some some time without any issues.

    I've updated them both from 8.2 releases to 8.90.3, with mixed success - the S905x is working absolutely fine, but I'm having problems with the remote on the S905.

    I use CEC on the S905x, but can't on the S905 (it's connected via an av-amp that seems to kill CEC even when configured to pass it through), so use a usb MCE receiver - which has always just worked.

    I'm afraid I'm not sure what the important note in the first post is saying - I'm using gxbb_p200_2G1Gbit.dtb - how can I tell whether it has LIRC support?

    I've tried following the infrared_remote page in the wiki, but I don't think my receiver is being detected properly. This is from dmesg:

    [ 39.220466@3] usb 1-1.3: New USB device found, idVendor=0609, idProduct=031d

    [ 39.220472@3] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3

    [ 39.220476@3] usb 1-1.3: Product: eHome Infrared Transceiver

    [ 39.220480@3] usb 1-1.3: Manufacturer: SMK

    [ 39.220484@3] usb 1-1.3: SerialNumber: SM006Ygj

    I'm getting no other remote-related messages, and

    kodi-m18:~ # ir-keytable

    /sys/class/rc/: No such file or directory

    I can modprobe rc_rc6_mce (which doesn't get loaded automatically), but it doesn't make any difference: nothing else printed in dmesg, no change to the ir-keytable output.

    Any pointers?




    I've gotten rid of the usb mce ir-receiver and have paired my harmony hub via bluetooth instead - a much better solution.

    Edited once, last by timd: Resolved (February 8, 2018 at 1:13 PM).

  • Gaudi

    Ok, try this DTB.

    If it doesn't work correctly, PM me, and we'll take it off the main thread.

    Thank you!!

    Updated the dtb file with the one you have provided and box is now displaying icons on LCD: Ethernet, Wi-Fi, time, play and pause.

    Just one question, is it possible to control the led light (change color, turn off) on this unit. It is the hexagon shaped box with a thin light line surrounding the border on the top part of the unit.

    Thanks again for your fast and useful response!!