[] LibreELEC 8.2 for S905/S905X

  • DISCONTINUED: These builds will no longer be updated but you are welcome to use them!

    LibreELEC 8.2 for Amlogic S905/S905D/S905X devices.

    Read this first: [HOWTO + FAQ] Install community builds on S905/S905X/S912 device

    Important notes:

    • These are unofficial, community supported builds so please post all bugs/issues in this forum area only.
    • Bug reports will no longer be looked into as the build is discontinued.
    • I work on these builds in my free time. I also don't know a lot of things so please be kind and patient if you encounter any bugs.
    • Bugs? Read this first: [READ FIRST] Reporting bugs
    • I'd like to thank johngalt for lots of work on improving Nougat kernel to a very usable state!

    Note on downloads:

    • for Odroid-C2 download image with -C2 suffix
    • for LePotato download image with -LePotato suffix
    • for every other device use image without suffix...
    • ..unless you are experiencing freezing: then use -temp_sensor_disabled version
    • If upgrading from 7.0/8.0 builds remember to update the device tree!

    If you forgot to use a new device tree or used wrong one and your device doesn't boot:

    • don't panic!
    • if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB
    • if booting from internal:
      1. Boot this build from SD card or USB with correct device tree.
      2. Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k
      3. Power off, remove SD/USB, boot from internal. (2018-01-22)

    Downloads: Index of /s905/8.2/

    If you don't know which file to download, get this one: LibreELEC-S905.arm-8.2-
    Device trees: Index of /s905/8.2/device_trees/


    • LibreELEC 8.2.3
    • add fd628-aml driver (thanks GDPR-2)

    Known issues and important notes:

    • SAMBA/SMB/Shared folder issues? Read this blog post first
    • Manual updates in LibreELEC Settings don't work
    • Built-in DVB tuners are supported only for "K" series devices and WeTek Play 2. For "K" series I use driver from afl1 with some modifications, please do not report issues with the driver to him! If you want support, please use builds from afl1.
    • 9082xs driver is now included but because it doesn't come with source code, there is absolutely no support for it!
    • 4K support is experimental.
    • 3D and HDR are not supported, i.e. they might work but I don't provide support.
    • CEC might not work when your box has incompatible u-boot or your TV is not that well supported by Amlogic low-level CEC driver.
    • External DVB tuner support is experimental via media_build drivers from CrazyCat69.
  • Please report any regressions from 8.0 builds. I was able to do only some basic testing, things are looking good so far. Detailed reports and PRs welcome.

  • I have a Tanix TX5 Pro 2GB/16GB with 8.0.2e Libreelec and after the 8.1.0 update box does not boot. It stays at Amlogic logo...

  • I think you should carefully read the OP, most importantly a note that you have to update device tree.

  • kszaq, awesome work, thank you! I broke the forced rgb output support with the following commit, and recommend a revert for now: aml/video_dev: updates for nougat: · kszaq/[email protected] · GitHub

    With this reverted, you can set echo 'rgb,8bit' > /sys/class/amhdmitx/amhdmitx0/attr in autostart.sh to recreate the force_rgb behavior.

    I also recommend merging PR15 of your LibreELEC.tv repo into libreelec-8.2 so colorspace can get passed if mode is the same.

    Note: for users who want 10 bit output, you may set the following in your autostart.sh:echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

  • Hello Kszaq,

    I have a wetek play to running raybuntu's krypton 64bit kernel 32bit libs.

    How do i upgrade to your build on my WP2?

    I tried to upgrade but i get compatibility error

    Is your build for WP2 full 64bit?


  • I was testing it just to see if John Galt's Netflix addon would work with this nought build, but it did not work.

  • This is more related to this thread Moonlight Addon Amlogic but when i install the addon with this build i get this

  • I'm still getting samba issues with this build. Now it's saying "operation not permitted" when trying to access samba shares on a Windows machine. I'm just waiting now to see if it will fix itself like it did in previous builds.

    edit1: Still no luck, the error message it's spitting out is:


    09:30:54.634 T:4014990240 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://BADGER/Video/Television'

    unix_err:'1' error : 'Operation not permitted'

    09:30:56.055 T:4102062192 ERROR: GetDirectory - Error getting smb://BADGER/Video/Television/

    09:30:56.057 T:4102062192 ERROR: CGUIMediaWindow::GetDirectory(smb://BADGER/Video/Television/) failed

    edit2: flashed back to 8.0.2e and it connects again.

    Devices: Mecool KI Pro S905D & Beelink MiniMX III 2G/16G S905.

    Edited 2 times, last by Hans Gruber ().