[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Hi I've flashed a s905 (minimx) with LE following the quide however the WiFi is unstable keeps cutting in and out can you advise ?

  • 8.0.2d still MM kernel right?

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • I just updated to LE 8.0.1d. Nice work. There is one catch: The System Information claims it is a built of Kodi-17.4, but the splash screen during boot shows it is a Krypton 17.3. I reckon Kodi devs goofed.

  • Network traffic activity?

    not sure, it's not really consistent. It seems to do so at boot and for about an hour after boot. After that it's just permanently on for several hours until it starts blinking again for a couple of minutes. Streaming something from my NAS doesn't seem to make it blink. To check if the LED is perhaps dying I've booted the box into stock android where the LED stayed permanently on.

    I've checked in /proc if there's anything related to it but I'm not really sure what to look for as it's one big mess with subdirectories.

  • uploaded 8.0.2d 64bit build with some more addons to LE – Google Drive

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • kszaq

    I just would like to give a short feedback for your newest release which is running since several hours on my boxes now.

    My K1Plus and my Wetek Play 2 are running perfectly with TVHeadend and VDR (except the actualisation time for the EPG in VDR)

    The overall performance but also stability until now is just perfect. I also didn't find any problems for the WiFI connections, etc.

  • kszaq, and other guru's... I have not been keeping up mainly cause stuff is pretty much working, but I don't want to get to a space where I can't upgrade. Previously upgraded by full new load on sd, reboot, and load desired add-ons and happy happy.


    Minix U1, running 8.0.2a


    Can I use the Upgrade method/procedure and jump releases, from 8.0.2a to 8.0.2.d ?
    Or do I need to single step a-b-c-d.. ?

    Minix U1 with A2-Lite

  • kszaq, and other guru's... I have not been keeping up mainly cause stuff is pretty much working, but I don't want to get to a space where I can't upgrade. Previously upgraded by full new load on sd, reboot, and load desired add-ons and happy happy.


    Minix U1, running 8.0.2a


    Can I use the Upgrade method/procedure and jump releases, from 8.0.2a to 8.0.2.d ?
    Or do I need to single step a-b-c-d.. ?

    you can upgrade straight to 8.0.2d, just put the .tar file on the update folder and reboot.

  • Putty is for SSH, not Samba (i.e. Windows file sharing) ;)

    I think the user originally mentioned he was using SCP to connect - which is SSH and NOT samba. He was asking how he could rectify the problem.


    Hello,


    I have a Tronsmart S905 box loaded with 8.01k, back then using Winscp without a problem. Today I am trying to update it to the latest version and I am failing to connect via SSH, or FTP. It just refuses all connections.

    Any idea how to solve that?

    Or maybe is there another way to seed the update file into the .update/ directory?


    First - make sure your IP address did not change. Check the "LibreElec" settings under "connections". I noticed that several of the updates to new versions caused my IP settings to be reset. I noticed because I could no longer SSH to my box haha.


    I will also second clarkss12, and will say try to use either Putty or FileZilla if you're on Windows.


    FileZilla - General Tab - Settings:


    HOST: your boxes IP

    Protocol: SFTP

    Logon Type: Ask For Password

    User: root


    everything else blank.



    FileZilla - Transfer Settings Tab


    Transfer Mode: Passive


    Now hit 'connect'

    It will prompt you for password when you connect.




    Hope that helps. But definitely check your IP address!

  • I think the user originally mentioned he was using SCP to connect - which is SSH and NOT samba.

    But then asked (in response to frequenzy's suggestion/advice "enable samba, then transfer the file.") . . .

    Quick tip if any...how do you connect to Samba from a PC?

    Receiving the reply. . .

    If using Windows, use Putty.

    Which, as Forage correctly pointed out. . .

    Putty is for SSH, not Samba (i.e. Windows file sharing) ;)

  • Hey Guys,


    Top work on your builds have been using them for awhile now but I have a problem with a MXQ Pro 4K it appears the WiFi is not working in this build for me. I have tried different DTBS but can't seem to get it to see the WiFi the WiFi is working in Android. And everything else seems to be working any suggestions ?


    Many Thanks in Advance :)

    Hey Guys, just an update I managed to figure out this issue and get my WiFi working is a WI-FI AP6181 chip. Instead of using one of the DTBS from the Device Tree Folder I used the one that was already in the build.


    But now I am trying to install onto my nand and get the following error :


    Code
    1. Formatting system partition the file /dev/system does not exist and no size was specified 


    Any suggestions ? Many thanks in Advance.

  • Any suggestions ? Many thanks in Advance.

    Open a new thread.

  • Alright report:


    Installed on Internal Memory.

    Device T95X. S905x 1GB RAM (2x SpecTek PE029-125 F1606 )

    It has neither eMMC nor NAND afaik. Some kind of hybrid memory from FORESEE , to save costs even more I guess.


    I used device tree p212 1gb nand


    So far everything seems to work just fine. Nice work!

  • I made some further testes (clean install - 8.0.2d) , and noticed that it happens when the screensave gets active. If I set the sceensaver to 1 minute then the TV switches back after 1 min.


    One Option would be to disable the screensaver ... but I really would like to keep it on. Is there maybe a second option, a hidden CEC Setting?


    These are the last debug log lines:

    Code
    1. 16:20:44.783 T:4146805872 NOTICE: NFS is idle. Closing the remaining connections.
    2. 16:20:45.302 T:4115628960 DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
    3. 16:20:45.302 T:4115628960 DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
    4. 16:20:45.307 T:4146805872 DEBUG: ------ Window Init () ------
    5. 16:20:56.353 T:4115628960 DEBUG: CAnnouncementManager - Announcement: OnScreensaverDeactivated from xbmc
    6. 16:20:56.353 T:4115628960 DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverDeactivated
    7. 16:20:57.407 T:4146805872 DEBUG: ------ Window Deinit () ------


  • 1. FYI, I'm using a Logitech Harmony One remote control with my Minix Neo U1, and since switching to LibreElec my play/pause/rewind/f.fwd stopped working. I noticed that these keys do however work with the original remote control so I figured I should use the Logitech remote software and remap my problematic keys. Play/Pause remapped to OK, Rewind to Left and F.fast to Right. Maybe this helps someone.


    2. Question, Is anyone else having issues with Search within Kodi? I am able to watch series/movies, choose categories/genres/etc to find a show but just not a manual search - when I search there are no results. I tried the original android OS (by removing my SD card with LibreElec on) and searching but that also doesn't work. I've read that I must get an API key from themoviedb.org and then changing episodes.py, movies.py and tvshows.py. I've now got an API key but not sure how to access these 3 files to edit them. Help me Obi-Wan.