[] LibreELEC Kodi Krypton - S905 & S912 devices

  • chewitt and wrxtasy I'm a long, long time user of Openelec and now Libreelec moving from Rpi to S912 and loving it. Is there any way to support the development of the S912 build via Patreon or something?

  • External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Panfrost has memleaks, graphical glitches, and no proper kernel driver or 32-bit userspace support so we are still a long (long) way from having something generally usable. It's still rather awesome to see mainline (everything) on an S912 board though :)

    Simply amazing! Congrats to all involved! This is definitely a major milestone! Really cools to see that these devices won't be going to the garbage bin so soon!

    All the luck in the World!

    Kudos to the Panfrost team (Alyssa and Lyude)!!!

  • chewitt So long as you guys and your excellent work are supported via that I'll contribute that way. I wasn't sure how it worked with a 'community' supported build.

  • Hi - new LE user here and I've just loaded via sdcard on my Beelink GT1 (S912 16/2/GigE) from Release LibreELEC - S912 release · wrxtasy/LibreELEC.tv · GitHub.

    So far it seems to run very well, with DTS audio now working without issues, which solved all my struggles with various Kodi/Android/firmware combinations. I know I know ... ;)

    But for some reason the LAN port is not detected (no link light) - wifi is fine. The install appeared to go fine, except that I didn't know how to "download a device tree", nor even what a device tree is, apart from I guessed it was something to do with device support.

    I assumed this might be relevant to the LAN port not working (though later on in the Install FAQ it says "when upgrading to or later you no longer have to provide a device tree for an update" so I'm not clear whether it's still required).

    I tried downloading the S912 device tree as per the instructions "New S912 device trees needed for GPU Overclocking" but I didn't understand the instruction "Simply drop .dtb file into the Update folder along with the .tar file".

    I don't see an Update folder nor a .tar file.

    There was a bunch of .dtb files so I guessed "dt" must refer to a device tree, so as I have a 2GB box I plumped for cxm_q01_2g_1gbit.dtb in the Gigabit folder. However I noted it was only 44k compared to the original 144K. I copied that into the root folder on thr sdcard and renamed it as per instructions.

    I booted it and only a quarter of the TV was visible, but LE/Kodi was running. Another boot and the display is fine but still no LAN.

    # cat /proc/device-tree/le-dt-id

    gxm_q201_2gLibreELEC:~ #

    so the file is at least being read but the significance of gxm and q201 is rather lost on me. :(

    If I copy back the original dtg.img (140k) then

    LibreELEC:~ # cat /proc/device-tree/le-dt-id


    What am I missing? Apologies if this is a newbie question, but I did search first ...!

    Edited 4 times, last by mr-b ().

  • After more trial and error I found that this one allows the LAN to work -1000M-Gigabit-Ethernet\gxm_q200_2g_minix_neo_u9.dtb.

  • In image of 905D is bug that without going internet is not going DVB-t (tv headend with setting on localhost

  • Hi. I am running S912.arm- on my MINIX U-9H, I am experiencing problems to start UHD movies. Don't know if it is related to MSGQ not initialized, but they are not playable. Any ideas?

    Log: hastebin (errors start at line 147 where I try to start a movie)

  • wrxtasy  kszaq your image is stunning in how smooth it play. Thanks for the great work.

    Is it possible to disable 4k <<-->> 1080p switching. I need always 4k, because i play at 50% screen size, so at 4k that would be 1080p. Why would i do this: my eyes are very bad i see only 4 degrees (normal people 150-180). The movie/tv show needs to be small enough, so that i can follow, but the GUI needs to be normal big (not fast moving, so i can scan that) so that i can read and the fonts are not to small. Kodi is the one and only Software (i know) what makes it possible to use a big nice up 2 date TV set and still follow because the movie is small enough. In 2,5m i see only the size of a A4 piece of paper.

    Is the source of somewhere available?

  • wrxtasy  kszaq your image is stunning in how smooth it play. Thanks for the great work.

    Is the source of somewhere available?

    Yes I did a search for it in this forum thread and you will find thelinks on post #561. Great build on teh S912 boxes, works a treat on my Tanix TX9 Pro 3/32GB box.


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Hello wrxtasy. I would like to thank you for all your support and work you do for people. It is amazing. I have several mecools KI devices. Now I use KI PRO as my tv box.

    I know LE 8.2.5 is tha last with Krypton (which I still prefer). I found your link containing also some releases. Could you please recommend last stable krypton LE release for KI PRO? I need dvb-s support and standard services.

    Thank you very much.

  • Hi wrxtasy,

    I am extremely happy with what you brought to these builds and I have been using your latest (?) S905 build for quite some time now:

    There is one thing I noticed only recently, because I rarely watch that kind of content:
    Refresh rate switching to 24.00Hz is flawed. I am pretty sure it is being displayed as 23.976Hz, because frame skips occur.
    These skips do not occur if I change the UI resolution to 24.00Hz beforehand.

    This is something that used to work on older builds "back in the day", probably before you took over.

    Maybe it's an easy fix - I just wanted to let you know. :)

    Thanks again for your great work!

    Mini M8S II 2G/16G (S905X)

  • Check the settings again.

    Refresh rate works as it should.

    For smooth playback you can also set:

    - 50 Hz in GUI

    - Adjust display refresh rate to match video ON

    - Sync playback to display ON

    It's better solution than 24 Hz in my opinion.

    TX5 PRO S905X

  • Check the settings again.

    Refresh rate works as it should.

    Yes it does for 23.976Hz, but not for the rare, even 24.00Hz sources.


    For smooth playback you can also set:

    - 50 Hz in GUI

    - Adjust display refresh rate to match video ON

    - Sync playback to display ON

    It's better solution than 24 Hz in my opinion.

    I respectfully disagree, I like my sources being playbacked with their native refresh rate. :)

    Mini M8S II 2G/16G (S905X)

  • I'm trying to get this to boot on a MXQ Pro 4k device with 1gb ram and an S905X chip.

    Extracted the image (using dd), tried a few device trees already to an SD card, inserted into device, rebooted via

    the toothpick method -> end up in recovery

    reboot recovery -> and up in recovery

    reboot update -> reboots

    I've also tried on a USB stick, no difference... what magic is needed to get this to boot the USB/SD?