[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • satel, could it be that you have too many devices with netflix installed?


    Don't they limit the number of devices you can use?

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • I have already many times installed Netflix and the entire system in the past 3 days. Unfortunately the Netflix does not go. :cry:


    Thank you

    Have you checked inputstream.adaptive add-on is active?

  • satel, could it be that you have too many devices with netflix installed?


    Don't they limit the number of devices you can use?

    I always with this Box connected to Netflix. I have 2 Screens +HD contract and I always logout from the others if I try on laptop.


    thanks

    Mini MX-G 2/16 S905.arm LibreELEC

  • Have you checked inputstream.adaptive add-on is active?

    of course


    Sometimes when I updated the InputSream Adaptive, I got to browse the movies, but the movie was not played.


    thx

    Mini MX-G 2/16 S905.arm LibreELEC

  • Netflix works well on MiniMX, I just installed Netflix add-on and make inputstream add-on active, then login and that is all.

    I can confirm this, installing the Netflix add-on from GitHub - asciidisco/plugin.video.netflix: Inputstream based Netflix plugin for Kodi (Scroll down to 'Installation & Updates' to reach the download link for the repository) is enough, all dependencies will be installed automatically (with my box, see signature).

    Thanks, GDPR-2



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE 8.2.3.1 (thanks kszaq) and CE 8.90.0 (thanks adamg + afl1)

  • of course


    Sometimes when I updated the InputSream Adaptive, I got to browse the movies, but the movie was not played.


    thx

    satel, I had similar experience before. I presumed that you can browse different titles under Netflix (your posts were a little misleading as if it was credential issue, then you could not browse at all, not even see your user(s) on the list). I solved this problem by removing the widevine directory under ssh and install it again. Also I didn't use the procedure suggest for use with RPi (as what your did). I used the procedures suggest in Gendo's build which involves only one command. Perhaps the results are the same but I'm not sure.


    s905 and s912 Leia builds

  • Pls, send me debug log from LE 8.2.

    afl1 Here is a log from LE 8.2. I didn't see the option to enable verbose logging for A/V timing info, I guess that's a new feature of Kodi 18? Anyway I checked both Audio and Video components.


    kodi.log

  • afl1 Here is a log from LE 8.2. I didn't see the option to enable verbose logging for A/V timing info, I guess that's a new feature of Kodi 18? Anyway I checked both Audio and Video components.


    kodi.log

    In Le 8.2 is perfect data feeding by pvr.mythtv. LE 8.x and LE 9.x use different pvr versions (4.x.x vs 5.x.x). It looks like issue in pvr.mythtv for LE 9.0.

  • GDPR-2


    I know that you will be adding LCD support to T95M and others soon, but I decided to see if I could get mine working myself, and asap.

    After some trial and error I think I made some progress, but it still doesn't work.

    I built my own device tree like so:

    At first I had conflicts with audio_btpcm_pins, but I removed that section from the DT and the conflicts are now gone. (in dmesg: conflict and now no conflicts)

    But sadly the LCD does not light up or display anything. I installed the FD628 Service and it seems to be active.

    Do you have any suggestions on what I should try next?


  • Try the following

    Code
    1.         fd628_gpio_clk = <&gpio GPIODV_22 GPIO_ACTIVE_HIGH>;
    2.         fd628_gpio_dat = <&gpio GPIODV_23 GPIO_ACTIVE_HIGH>;
    3.         fd628_gpio_stb = <&gpio GPIODV_21 GPIO_ACTIVE_HIGH>;

  • Try the following

    Code
    1.         fd628_gpio_clk = <&gpio GPIODV_22 GPIO_ACTIVE_HIGH>;
    2.         fd628_gpio_dat = <&gpio GPIODV_23 GPIO_ACTIVE_HIGH>;
    3.         fd628_gpio_stb = <&gpio GPIODV_21 GPIO_ACTIVE_HIGH>;

    Thanks for replying.

    Well I'll be damned! The above didn't actually work, but what I decided to do was:

    Boot up android, go to the device tree folder, grab those files and just look at them with a hex editor.

    My conclusion:

    On my particular box, which is a Sunvell T95M S905X 2G/8G, the correct configuration is as follows:

    Code
    1. fd628_gpio_clk = <&gpio_ao GPIOAO_5 GPIO_ACTIVE_HIGH>;
    2. fd628_gpio_dat = <&gpio_ao GPIOAO_4 GPIO_ACTIVE_HIGH>;
    3. fd628_gpio_stb = <&gpio_ao GPIOAO_3 GPIO_ACTIVE_HIGH>;

    It did turn the screen on, but it looks a bit messed up. I guess the LCD is wired differently on this box than it is on the Tanix.

    But now that I got it working, I'll fix the mapping tomorrow.


  • I had the same problem when trying to use the vfd driver by anpaza so I know what you mean, I would of preferred to use his driver, I did email him/her asking how the mapping is determined as I couldn't understand the document he wrote, it needs explaining in laymans terms but he didn't reply =(.

    The problem with the fd628 driver is the LCD mapping is set in the driver files where as with the vfd driver by anpaza it is set in the device tree which is much better for supporting multiple devices and as a bonus he has already provided the settings for the T95M.

    The vfd driver is vastly superior as it will scroll the display and let you see things like CPU usage/temperatures/disk space.

    I can use both drivers as a work around but it's not been high on my priorities as it's time consuming adding it and then actually getting the code accepted into LibreELEC upstream.

    There has been some discussion within LE circles of not supporting Chinese boxes/vendors and only supporting SBC's as the cheap Chinese box makers do not contribute anything to the community or try and help the community, kernel source and driver sources are constantly withheld from us making supporting these devices extremely difficult and troublesome, I'm not sure how kszaq or afl1 feel about this but I for 1 feel this would probably be for the best.

    If you look at the Khadas KVIM the whole source code for their product has been published to GitHub and they work with their users on the forums and they are somewhat neglected by a lot of people because a Chinese crapbox can be sourced for half the price.

  • Hello to all! I have a Beelink mini mx III II box, with installed LE 9. My problem is that my system won't update to 8.90.2 version. After I turn my box on, the system reminds me, that there's an update, but when I restart it, the pdate process doesen't start. I checked the update folder, there I can find the downloaded image file. I tried to copy to that folder the image manually, but that didn't help. Do you have an idea what to do?

  • After upgrade to 8.90.2, my K1 Plus quite often restarts itself (after freezing). I have a fan mounted for cooling the processor and how I check it now CPU temperature is 40-50 pcs (without the fan on this version Libreelec reached 85 degrees and hung up :( (on the LibreELEC 9.x version 1.0.6 there was no problem stopping the box Problems began with version 1.0.8 and only removing the plugin resulted.) In attachment are logs of the last crash and previous crash logs in version 8.90.2. Is there any solution for this?

    Files

    • crash_log.zip

      (52.37 kB, downloaded 90 times, last: )
    • crashlog.zip

      (54.31 kB, downloaded 89 times, last: )
  • Hello to all! I have a Beelink mini mx III II box, with installed LE 9. My problem is that my system won't update to 8.90.2 version. After I turn my box on, the system reminds me, that there's an update, but when I restart it, the pdate process doesen't start. I checked the update folder, there I can find the downloaded image file. I tried to copy to that folder the image manually, but that didn't help. Do you have an idea what to do?

    Do you a VPN service running?, I have a number of 905 boxes and none of them auto update unless I go into the VPN manager addon and disconnect VPN, although all display the "update available" notification, once VPN is disconnected, go into Libreelec setting and just re click on Updates auto and it should download. PS. I also have a Beelink mini mx III II box and by doing the above it updates.

  • Do you a VPN service running?, I have a number of 905 boxes and none of them auto update unless I go into the VPN manager addon and disconnect VPN, although all display the "update available" notification, once VPN is disconnected, go into Libreelec setting and just re click on Updates auto and it should download. PS. I also have a Beelink mini mx III II box and by doing the above it updates.

    No, I do not use VPN.