[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • Hey there,

    thank you for the possibility to use kodi leia on libreelec, even with an alpha version. Really appreciate that.

    Simple (hopefullly) question: I saw ppl are able to get the lcd-display working on their boxes with your build. I have a T95-Max box and wonder if i can make it work on that one, too? Is there something special to implement, do i need specific drivers to be enabled?

    Atm the display only works when booting into android, but not in libreelec.

    System: Bqueel T95-Max TV Box | 2 GB Ram | 32 GB eMMC | Amlogic S905 Cortex A53 Qcore CPU 2Ghz | GPU Mali-450 5-Core | WLAN 2,4 & 5 Ghz | LAN 1000/100 Mbit
    OS: Android 5.1.1 on Nand |LibreELEC 8.90.4 Build on SD

  • LED (VFD) Displays in LibreELEC

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • OMG, thanks for pointing me there! *thumbs_up*

    Added FD628 Display addon and it works like a charm. Perfect! :thumbup:

    mh.. edit: was too fast with my euphoria. Display started when enabling the addon, but time was not correctly displayed. In fact it stayed at 08:14 pm. After a shutdown it's black again. X/

    System: Bqueel T95-Max TV Box | 2 GB Ram | 32 GB eMMC | Amlogic S905 Cortex A53 Qcore CPU 2Ghz | GPU Mali-450 5-Core | WLAN 2,4 & 5 Ghz | LAN 1000/100 Mbit
    OS: Android 5.1.1 on Nand |LibreELEC 8.90.4 Build on SD

    Edited once, last by azido ().

  • Currently, I have an MXQ Pro S905 TV Box with 1/8 GB RAM/eMMC running on the last version of LE v8.2.3.1 with a device tree of gxbb_p200_1G_mxq_pro_4k.dtb (S905). Right now, I would like to try LE 9.x (from here), but I did not find any DTB image from here for this device. Since my device has only 1 GB RAM, I tried all the 1GB version DTB images from the device tree to no avail (ended up with debugging messages). I certainly will appreciate if anyone here who has managed to run LE 9 on an MXQ Pro can lend some hands on which DTB version for an MXQ Pro to use.

  • Hello, I have mecool m8s pro+ and I copyied file remote.conf to "Configfiles" folder like in this video

    but my IR still not working. What should I do to work IR?

  • Please point out both files for WP2 on SD card, which burn to card and dtb

    SOC:Amlogic S905

    RAM: 2 GB DDR3

    Gigabit Ethernet

    Have you tried gxbb_p200_2G_1Gbit.dtb

    Index of /releases/dtb/S905

  • I try this, but, not work, while, other builds working

    You may have to go to [8.90.4] LibreELEC 9.0 Alpha for S905/S912 devices

    Then ask members who have this Hardware. There was a Development build which worked for them.

    I think it's been pulled off the server but members may have it for you to share.:)

  • Is it possible to set the screensaver dim value to less then 20% somehow? (was possible in early builds, now 20 is minimum)

  • got some trouble updating from 8.2 and didnt found a solution searching in the forum, maybe is already posted but:

    upgrading from is failing using 8.90.4, but -> 8.90.0 -> 8.90.4 is working

  • I wanted to report that this devel update works very good with my 905x box, no playback issues. I had hdmi-cec (LG TV remote) and screensaver problems with the previous builds which are gone now. (had to reset the cec driver)

  • LibreELEC-S912.arm-8.2- + gxm_q200_2g_minix_neo_u9.dtb

    Flashed to a 16GB USB Stick booted into my Minix U9-H.

    Functions fairly well except for only playing audio in stereo. When I select 5.0 channels, I lose the center channel when playing 5.1 video streams.

    Pandoki only plays one selection for any of my radio stations.

    I've generated and attached a log of these two problems. Hopefully it will give you enough information to further enhance this build.

    Thank you for the work you're doing.


  • Unfortunately remote.conf don't work with this build on mecool m8s pro+. I installed 9.0-Leia-testing-Gendo-20-10-2017 and LibreELEC-S905.arm-8.2- and there remote working on start.

    in that case you are doing something wrong.

    1. You need to use latest dtb (Device tree) for 8.90.4 build

    2. You need to config you remote as described in LE9.0 remote configs ir-keytable Amlogic devices. (remote.conf doesn't work anymore)