S802/S812-Libreelec images for 7/8/9

  • gthebest could you please explain to other people a little step by step how you managed to boot the new release so i dont have to revert my devices bootloaders i custom builded from source , that would be very helpful to all and save me a lot of lost time.

    Ok I will try to explain


    1.Well first of all I make a format to my SD card with the SD formatter to my pc


    2. Then with the Win32DiscImager I install the ".img" file to the SD card


    3. I power on my TV box without put in the SD card


    4. The TV box will open to Android


    5. Then I put in the SD card to my TV box


    6. I open the "update&backup "app. In local update we check the select button


    7. After a while the files appears in the screen. We select the "aml_autoscript.zip" from the SD card and then select to update.


    8. The TV box will restart and then it will install the Libreelec firmware


    I notice again than everything is working fine except the power off selection not working (the TV box is restarting) and there is no "Boot to Android" selection in power menu!

  • I've been checking this thread and I hope someone finds a solution. I have two MXIII 4K boxes, 1G/8G (no BT) and 2G/8G (/w BT) and it would be great if I could get LE 9.0 working on them. Maybe I could finally get my IR remotes to work properly since they switched to ir-keytable on the latest release.

  • I will try to release images for only for the two devices i own

    - MXIII-PLUS/MXIII-G/PROBOX2-EX-PLUS

    - S82/S82B/S82H/MXIII/S89/S89H

    and that's it

    If you can get MXIII-PLUS working you'll be my hero. :thumbup:


    But seriously good luck there. I'm not sure but I think balbes150 gave up, because of the old kernel that the S812s are locked at.

  • If you can get MXIII-PLUS working you'll be my hero. :thumbup:


    But seriously good luck there. I'm not sure but I think balbes150 gave up, because of the old kernel that the S812s are locked at.

    Its already there StackPath

    Will wait patiently for 9.1 to be tagged

  • Since these images are for the MXIII-PLUS, would they even work with the original MXIII (the one with the red 4K logo) 1G/8G or 2G/8G models properly? They're both S802 based not S812.

  • Its already there StackPath

    Will wait patiently for 9.1 to be tagged

    Thanks for your hard work so far. This works on my Tronsmarts.


    However, UPNP connections seem to be broken. When you try and connect to a UPNP server via file browser, KODI crashes and reboots.


    Since this is fairly new, thought I would just let you know of a possible problem.


    I personally prefer UPNP for things that should be streamed like videos and music.


    EDIT: If I remember right there was a recent known bug in the linux UPNP library that was causing segfaults, that was recently fixed.


    EDIT2: Hmmm. Looks like it's Kodi itself that has a bug with UPNP. I tried to revert to Android on one of my Tronsmart MXIII-PLUS boxes and installed Kodi 18.1 Trying to use UPNP still caused a crash even there.


    EDIT3: Never mind. I found the problem. In K17 you didn't have to do anything other than add a UPNP source. Looks like in K18 you NEED to turn on UPNP in services first. Its working nice and smooth now.

    Edited 3 times, last by kingsombra: Forgot a comment ().

  • [edit] In step 7 you said you select aml_autoscript.zip from the SD card, but there's no such file. My understanding is that any dummy .zip file will work, because it's only there to trick the box into rebooting into recovery mode. When I do this, it reboots into recovery mode and I get a message that says "Filesystem corruption has been detected!" and the that's it. Sorry, but this method does not work for my MXIII 1G/8G or 2G/8G boxes.

    Edited 2 times, last by Kashim ().

  • [edit] In step 7 you said you select aml_autoscript.zip from the SD card, but there's no such file. My understanding is that any dummy .zip file will work, because it's only there to trick the box into rebooting into recovery mode. When I do this, it reboots into recovery mode and I get a message that says "Filesystem corruption has been detected!" and the that's it. Sorry, but this method does not work for my MXIII 1G/8G or 2G/8G boxes.

    exactly same issue here om mxiii 1g/8g older version works fine

  • In step 7 you said you select aml_autoscript.zip from the SD card, but there's no such file. My understanding is that any dummy .zip file will work, because it's only there to trick the box into rebooting into recovery mode. When I do this, it reboots into recovery mode and I get a message that says "Filesystem corruption has been detected!" and the that's it. Sorry, but this method does not work for my MXIII 1G/8G or 2G/8G boxes

    exactly same issue here om mxiii 1g/8g older version works fine

    Sorry this is the file.

    aml_autoscript.zip

    Is missing from the img file

  • First of all, thank you very much for the 9.0 update.


    I got it running on my MXIII MXIII 2G/8G boxes. So far as I can tell, everything seems to be working fine, except when I stop a video, Kodi just hangs and have to power cycle.

    I even reset librelec to factory defaults, but still happens.

    can can get log from SSH, so kodi is still running in the background


  • Hello thx for a update its great but i have this same problem with "baalho" when i stop watching video kodi crash and ssuspended. I must restart device. Can you solve this problem?

    I use mxiii plus img device

  • Hello thx for a update its great but i have this same problem with "baalho" when i stop watching video kodi crash and ssuspended. I must restart device. Can you solve this problem?

    I use mxiii plus img device

    set kodi setting in "expert mode" , define a whitelist

  • Hey all,


    Thanks so much for your work on the MX3 Plus! It works brilliantly, but I am experiencing the same issues as Kamilson and Baalho.


    When I play a video (any type or resolution), if i Fast Forward or stop, it totally hangs the system. No relevant debug log is created.


    I have tried adding a white list and changing the Sync refresh Rate from Start/Stop to Off.


    Neither seems to work.


    Cheers!

    Ken

  • I hate to be a ME2. But ME2.


    However, give Demitris some time. LE 9.0.1 is out and it takes time to get a distro ready.


    And I could swear I remember reading somewhere that the forward/backward stuff has been fixed in Kodi 18.1

  • I realize this may be disloyal to this forum but Alex has Leia 18.2 RC1 working great on the ARM. I've SD installed the AlexELEC-S9XX.arm-3.0.4.img.gz
    on my MINIX NEO U9-H and AlexELEC-S812.KII.arm-3.0.4.img.gz on my Matricom Q2 both are working great once you figure out how to change the language which comes up in Russian.

    AlexELEC-3.0.4 (Amlogic S805 / 812/905/912)


    Systems for Amlogic S805, S812, S905 / S905X / 905D / 905W and S912.

    Main software:

    • Linux-3.14.29 The nucleus of the project "OSMC" (S905)
    • 3.10.108 Linux kernel (S805 / 812)
    • What git 18.2 RC1: f7242ad
    • TVIP 3.8.25 (S805/812)
    • Tvheadend v4.3-1771 & Tvheadend v4.2.8-14
    • Oscam 1.20 rv11504-emu790
    • AceStream 3.1.33
    • TorrServer 1.0.65
    • youtube-dl 2019.01.30.1
    • Tvheadend HTSP Client AE 5.4.14
    • PVR IPTV Simple Client AE 4.5.7
    • Skin Arctic: Zephyr AE 2.3.20
    • Skin Aeon Nox Silva AE 6.1.9
    • Аддон Keyboard Layout 1.0.0

    Added driver Wi-Fi module - "SCI s9082c" (thanks @Cmlog).

    Added build for Amlogic S805 with 512 MB of RAM - "AlexELEC-S805.MXQ_V31.arm".

    For consoles on Amlogic S905 (X / W / D) and the S912 uses the same system - "AlexELEC-S9XX.arm".

    Added additional color management options, playback and overclocking GPU.

  • Damn, I need help. My box is MXIII (S802 2GB) Some time ago managed to install Remix and LibreElec 8.2.3 (S82 build, worked great), then started to play with Lakka 2.1.1 S82 and decided to install to nand. All good. Now, months later, I want to try "again" LibreElec 8.2.3 and I cant for the life of my boot from SD nor Pendrive. Flashed the IMG, put "nocompat.zip" and "remote.conf", and cant boot with the damn toothpick. If I use a SD card, it says filesystem corrupted, and if I use pendrive, it goes to recovery or boots directly to Lakka.

    Could someone describe the exact and precise process to boot again from SD or Pendrive?

    I also want to try 9.0... but fisrt 8.2.3

    Thanks

  • Damn, I need help. My box is MXIII (S802 2GB) Some time ago managed to install Remix and LibreElec 8.2.3 (S82 build, worked great), then started to play with Lakka 2.1.1 S82 and decided to install to nand. All good. Now, months later, I want to try "again" LibreElec 8.2.3 and I cant for the life of my boot from SD nor Pendrive. Flashed the IMG, put "nocompat.zip" and "remote.conf", and cant boot with the damn toothpick. If I use a SD card, it says filesystem corrupted, and if I use pendrive, it goes to recovery or boots directly to Lakka.

    Could someone describe the exact and precise process to boot again from SD or Pendrive?

    I also want to try 9.0... but fisrt 8.2.3

    Thanks

    In such cases, you need to start with Android Image again. USB Burning tool is your friend

    Kodi 18.2 x64 Windows | LibreELEC 8.2.3 MX-III 2GB S802 by Demetris | LibreELEC 9 RR WeChip V5 S905X by 5schatten