[8.0.2e] LibreELEC 8.0 for S905/S905X


  • Try installing disabled temp version

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.


  • are you somehow using CEC between the box and the samsung tv?


    I know suspend is experimental, but I can reproduce the issue using LE8 and LE7. Setup is S905x directly connected to the Samsung via HDMI with CEC enabled.


    When I turn-off the TV, the box goes to suspend. No issues.


    Still on suspend state.
    1. When I turn-on the box via remote, it wakes up the TV as expected. No issues.
    2. But if I turn-on the TV first, box doesn't wake up. So I turn-on the box via remote, it changes to Blue light but no display and hangs. No ICMP response from the local lan either. Tried a few times. Only way to resolve is to unplug/plug the box.

    Edited once, last by frequenzy ().


  • I must say that this is the best OS/Kodi build I've ever used. I'm new to LibreElec and put 8.0.1j on my Tronsmart S95 Meta. I put it on the Meta b/c Tronsmart screwed me on storage. Somehow 8GB really means 4.8GB. I guess the box's bootloader is 3GB!!!?? Anyway everything is smooth and responsive on 8.0.1j. The only thing I've noticed that someone earlier mentioned is the backwards skip is unreliable. It only works on certain videos but I haven't isolated the files types and codecs that fail. For me it's about 50% which may be my mpeg h264 files. Most of my files are flv or avi. Starting the file from the beginning is the only fix. Other than that keep up the good work! At the moment I'm testing this on a second box as my main box (S95 Telos) is the only way to watch Netflix now. So will definitely be on the look out for bugs and such. Thanks.


    Hi.
    Kill that Android and reclaim all the storage space. You'll be able to reinstall Android anytime, of course, but you wouldn't. ;-) LibreElec works way better than Android.
    Of course, do it only if feeling confident with this stuff.

    Edited once, last by alexeiyo ().

  • kszaq
    Found it! :) Someone wrote about subtitles causing stutters so I did a test with the Star Trek movie one more time. This time with and without subtitles.
    And what a surprise! Video is butter smooth when subtitles are disabled.
    Below is a sample file of the video. To replicate please play the video from the beginning with enabled subtitles. Important part is that subtiles must be enabled by default and not during playback.
    Stutter occurs exacatly with the first line of subtiles: 00:01:24


    Sample:
    Zippyshare.com - STB-sample.mkv

    TX5 PRO S905X


  • How to disable CEC and suspend??


    From Kodi and to TV??

  • Hi kszaq,


    Once again many thanks for Your devoted work.
    I'm compiling from Your github source a version with openSSL instead off libreSSL.
    For compiling this I do have to commit locally some changes.
    I would like to keep my clone up to date with Your remote source without overwrite my changes.
    Please, I like to ask If You Could give me the right commands to do so?


    kind regards, Jefken.

    Raspberry Pi2 LibreELEC Milhouse nightly builds

    Q-Box 2G/8G and Q-Box 2G/16G LibreELEC 8.2 kszaq 's
    NexBox A95x balbes150 Armbian_5.32_S9xxx_Debian_jessie_3.14.29_server_20170907 with tvheadend and OScam.
    Digibit R1 Sat>IP server. (80 cm. dish with disecq 4/2 (28.2E, 23.5E, 13.0E, 19.2E) and fixed 90 cm. dish at 30.0W)

    4 x TP-LINK TL-PA411


  • Today's build to test:
    LibreELEC-S905.arm-8.0-8.0.1-devel-2017-05-05.tar


    Changes: a little bit less stuttering with problematic samples.


    Sent from my Nexus 4 using Tapatalk


    Hi, I have tested devel build LibreELEC-S905.arm-8.0-8.0.1-devel-2017-05-05. It seems absolutely perfect on my S905 box. All my media and test files play with no frame skips, perfectly smoothly and without problem.
    Note: Is interesting - if I switch on video processing info (Ctrl-Shift-O), frame skips is started and video playback is jerky. And when I switch info off, then video playback is smooth again and seems there are no frame skips again.
    But as i wrote - with normal playback is everything OK :-)


    I have tested also afl1 test build from 2.5. (LibreELEC-S905.arm-8.0-8.0.1j-test-I.tar) from here. But unfortunately this build is not good for me. There are massive frame skips again on my test files.
    It is strange, because somebody wrote, that this version has no problem. How is it possible? How difference can be in our boxes?
    Thank you for your work!

    Sunvell T95Z Max (S912) 2G/16G 1Gbit LAN, MXV+ (S905) 1G/8B 1Gbit LAN , NAS D-Link 320L, TV LG 65UK6500MLA, Receiver Yamaha RX-V475

  • Hello kszaq


    I think Kodi its not assuming my personal settings on advancedsettings.xml
    After open kodi.log the settings are completely different what i define.


    my advancedsettings.xml

    Code
    1. <advancedsettings>
    2.     <cache>
    3.         <memorysize>419430400</memorysize>
    4.         <buffermode>1</buffermode>
    5.         <readfactor>5.0</readfactor>
    6.     </cache>
    7. </advancedsettings>


    On kodi.log

    Code
    1. <advancedsettings>
    2.     <cache>
    3.         <memorysize>524288000</memorysize>
    4.         <buffermode>1</buffermode>
    5.         <readfactor>6.0</readfactor>
    6.     </cache>
    7. </advancedsettings>

    Files

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

    Edited once, last by Rootz ().


  • I think what you need to do is to make a git patch.

  • re LIbreelec on s905x/X96 box has anyone found the best release for picture quality and searching forwards/backwards that doesn't lockup?
    later releases seem to be worse rather than better at this.


    thankl
    Minsik.

    In theory there is no difference between theory and practise, but in practise there is!


  • re LIbreelec on s905x/X96 box has anyone found the best release for picture quality and searching forwards/backwards that doesn't lockup?
    later releases seem to be worse rather than better at this.


    thankl
    Minsik.


    I have the s905 on the Vega S95 and I had the same issue with backwards skip causing video to freeze. Under Settings-Player-Videos-Processing I have the following configured and seems to have improved. I think its something with the h264 acceleration.


    Enable HQ scalers for scaling above: 50%
    Allow hardware acceleration - amcodec: On
    Accelerate MPEG2: Always
    Accelerate MPEG4: Always
    Accelerate h264: Never


    I'm still playing around the settings to get the maximum performance but only have been using 8.0.1j for two days now.

  • A little off topic but wondering if someone can help me with a frustrating problem. I have 2 identical spec 905x boxes running the latest version of kszaqs builds and nearly identical set ups. I am running Potato TV and Simple IPTV client. both boxes play live TV perfectly and have accurately populated guides.


    I created a channel list and saved my tv29.db file so I could restore it in case I mistakenly crushed it. I then copied it to the database folder on both boxes. On one box it works perfectly, on the other, the channel manager shows that all the right channels have been deactivated but they still appear. Whats even stranger, the groups guide is only partially populated. I did notice that the tv29.db file gets overwritten on the problematic box for some reason.


    I tried every combination of clearing possible and am at my wits end.


    Any Ideas?
    [hr]
    What are the latest and greatest video playback settings or modifications? I can't seem to play 1080p properly on one of my boxes. It's not a bandwidth issue because one box plays fine.


    BTW, it might be a good idea to put a build specific tips and tricks section in the 1st post to get the latest optimization settings.

    Edited once, last by Skripo ().


  • What are the latest and greatest video playback settings or modifications? I can't seem to play 1080p properly on one of my boxes. It's not a bandwidth issue because one box plays fine.


    BTW, it might be a good idea to put a build specific tips and tricks section in the 1st post to get the latest optimization settings.


    I use no additional "tweaks" at all and I'm happy with smooth playback.

  • I use no additional "tweaks" at all and I'm happy with smooth playback.


    It's smooth. Only those subtitles stutter issue. Most of us are not native english spekaers and we watch movies with subtitles.
    Can you have a look at this problem?
    I did mention about it in post #2,847 and attached a sample so you can easily reproduce it.
    You're alpha and omega here :) Hats off to your work. Absolutely invaluable.

    TX5 PRO S905X

  • I rarely use subtitles so I haven't struggled with any issues. I watched a German movie last night with English subtitles. Seemed smooth to me but it wasn't a very big file. Could you describe the subtitle stutter for me?