[8.0.2e] LibreELEC 8.0 for S905/S905X

  • An issue started to happen on 8.0.1e and it's happening more frequently on 8.0.1f. My TV blinks even when Kodi is idling on the Menu. It's totally random. Some times it blinks twice in a row, some times only once, some time it takes 20 seconds to happen again and some times it happens more than twice in a span of 5 seconds.

    What I noticed is that it only happens after I play any type of media. So I reboot and it's fine. Once I play a mkv or a IPTV channel, it starts happening.

    I didn't change anything on the settings after updating so I'm not sure what triggered this. I would provide more info but this is pretty much it... it happens on the Kodi interface when nothing is playing (it also happens when something is playing but what I mean is that it's not related to any specific media).

    I'm running Libreelec on a Mini M8S II connected to a Samsung KS7000. I have it set to 3840x2160p and a refresh rate of 60.

    Any idea? As it is, the box is unusable.


    Disabling UHD Color for the HDMI port to where the box is connected and rebooting seems to have solved it. I only tested for 5 minutes so it might happen again. I don't know if kszaq made any changes that could have triggered this but it didn't happen before 8.0.1e. Anyway, if it happens again, I'll let you know.

    Thanks for the continued support.

    Edited once, last by dastinger ().

  • Beelink Mini MXIII II recently updated from 7.0.3.x to latest 8.0x and unable to connect with Bluetooth remote which previously worked well. Is this a known issue? I went back a few revisions and was able to get remote recognized paired/connected successfully on 7.95 beta6 so seems like something changed? I was then able to successfully update directly from 7.95 beta --> 8.0.1f and Bluetooth remote functionality survived.

    Edited once, last by 7up ().

  • I have installed vitmod 1.2 on kii pro but there no sound on neutrino plz any one help

    No idea what Vitmod is ? You will get help here #1
    for LibreELEC

  • No idea what Vitmod is ? You will get help here #1
    for LibreELEC

    I wrote my opinion in other thread:


    You probably on wrong forum!!!
    Why do you ask help on LibreELEC forum for this russian dilettante product using open source LibreELEC without publishing sources for his own fork?

  • K1 Plus Combo @ 8.0.1f
    Anybody else having a problem with video playback when jumping back over timeline ? There is about 20 percent chance that the video got stuck and will remain still, audio continues. Only way to fix it is to stop playing the video fine and open again. It happens randomly, sometimes it's ok within the same video file, sometimes it got stuck. Playing files through NAS (SMB).
    Video: MPEG4 Video (H264) 1280x720 23.976fps 1206kbps [V: h264 high L4.1, yuv420p, 1280x720, 1206 kb/s]
    Audio: AAC 48000Hz stereo 156kbps [A: aac lc, 48000 Hz, stereo, 156 kb/s]

    I observe this behavior since 8.0.1b, never seen with previous versions and I have seen it with every following version up to 8.0.1f

  • Kszaq is aware of this problem, but we have to wait until he finds a solution, wait for him to release a patched version.

    Edited once, last by plikmuny ().

  • there is also an issue with subtitle positioning since previous version(8.0.1e), if i set subtitle position to fixed 900 height, after playing any video content the subtitle is shown at default height (1042 if i remember correctly), but if i press back button during playback the subtitle is shown on correct position see pic 2
    now i'm back on 8.0.1c, where i had no problems

    No one is watching movies/series here with subtitles?

  • No one is watching movies/series here with subtitles?

    I have noticed that even though the video calibration in the main settings is correct, when you play the movies, then go to video settings, the video calibration & the subtitle position are incorrect.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • From what I understand If it weren't for Vitaliy not anyone would have a dvb driver for K1+

    AFAIK Vitaly has never posted full sources of his DVB driver. afl1 has written the driver almost from scratch.

  • On T95X of my bro the playback for 24p seems jerky. is this normal?

    I want to get a Yundoo Y6 (seems like same internals as Nexbox a95x, just different case and remote and fw).
    If 24p playback is fine of course.

  • Hi, it's very interesting and strange.
    Thank you for your advice, but unfortunately no.
    My setup: MXV+ S905 1GB 1Gbit LAN, NAS on Gbit LAN, LE connected to NAS via NFS and Gbit LAN. My tests are always on clean install from scratch, without addons and without "tuning" with advancedsettings.xml, regular settings only.
    And I really have some issues on my posted sample videos. It's started from 8.0.1e version. On versions "c and "d" all videos play smoothly and correctly.
    1. Test file "Peter Gabriel" - here pls ignore small "blackout" on first 6 seconds - it's maybe cutting problem. But after this, video play little jerky. Not to much, but it's visible-
    2. "Samsung Italy" 4k video: Again, it's playable, but jerky. It's very visible.
    3. Hi bitrate "Jelly fish": This video is, in fact, unplayable. Video sometime stops for a moment and Dolby THD doesn't play.
    The same configuration with version "d" has no problem and all test files plays smoothly and correctly.

    EDIT: There are log and dmesg files, maybe will be useful: log-2017-04-17-16.12.45.zip , dmesg.txt

    Edited once, last by Whitesak ().

  • For people who for some reason want to try 64bit 8.0.1f : LE – Google Drive
    [built verbatim from kszaq repository]
    You can also find some TV related addons (some versions were updated)
    and some more LE addons in 'addons' directory.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • With the 8.0.1f build Kodi hangs at the end of playing a YouTube video.

    These are the relevant log lines:
    10:31:01.114 T:3676406688 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
    10:31:01.169 T:3676406688 ERROR: CBitstreamConverter::Convert: error converting.

  • I absolutely do believe you that you see those problems. But if all three files and DolbyTHD work for me and not for you, there must be some variable in our setups that is responsible. It could be something inconspicuous, like default resolution and refresh rate. I am a little busy today, but I can take pictures of my playback and system settings later in the evening, so we could compare them.

    As you are using NFS and I am using SMB, did you check if the files play fine from a USB stick?

    Wetek Hub: LibreElec (Philips 42PFL8404)
    MK808B+: LibreElec (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Is there maybe a simple way to test and compare (quantify) the network performance between Jarvis and Krypton?
    Some SSH command to measure up/down Mbit/s?

    Mini M8S II 2G/16G (S905X)

  • Decoder pipeline in Kodi is very different between Jarvis and Krypton, network speed has nothing to do with high bitrate videos stuttering. Jarvis build with my Frankenstein Nougat kernel plays these files smoothly.

    AMLCodec/DVDVideoCodecAmlogic needs to be optimized in Krypton to play these videos smoothly. I've tested some approaches with no success so far.