Geniatech Mygica HDStar DVB-S2 USB HD not working

  • Many thanks for the reply. Thats where I started from I used this firmware with 9.2.4 libreelec but it would not work with the HD channels. It only worked with the crazycat TBS driver but not HD. Which is why I was looking for a way around this. Hopefully libreelec this will be addressed in a later release of libreelec. I may see if I can build a libreelec with the UpdateLee DW1202 driver.

    I have compared the firmware with md5sum and it is the same. So comfortable I am using the same stuff.

  • don't use crazycat TBS driver for that device, it is know bug for some transponders, if you use libreelec x86_64 you must upgrade to latest nightly //where kernel have support included

    from Index of /

    LibreELEC-Generic.x86_64-9.80-nightly-20201010-45d6ccb.tar copy to /storage/.update/

    and copy firmware dvb-demod-m88ds3103b to /storage/.config/firmware/


    Geniatech Mygica HDStar DVB-S2 USB HD not working

    your device is probably not listed yet in linuxtv wiki version 3103B of Geniatech HD Star DVB-S2 USB2.0 - LinuxTVWiki

    this group of devices from 2018 > like cinergy s2 , s4600 and some others too have already proper support in current kernel , maybe for only this one support was not merged to dw2102 or dvbsky modules

    Edited 2 times, last by stpf99 ().

  • Many thanks for your response.

    I was using a RPi3 with 8.2.4 (linux 4.9.80) which was using the dvb-demod-m88ds3103.fw (the B frmware). I upgraded to 9.2.4 and lost the HD channels.

    Thanks your advice. I have download various nightly image for the RPi2. The 2020 10 03 and worked with my TV via HDMI but would not connect to Wifi, but works fine on Ethernet. I use tvheadend, downloaded from the nightlies, (4.2.8-36) worked fine but did not find any channels on the muxes. Showed a reasonable signal.

    I tried the RPi2 images for 4,5,6,7,8,9,10 October. On the RPi 3B connected via HDMI to a Samsung TV but none got beyond the basic boot screen. I did not connect to Ethernet to see if it was just an HDMI problem. Happy to try again with these or other builds if this is useful.

    The Chris Lee Update on Unbuntu x86 gives slightly different output on dw2102 but seams to work ok for both std and HD channels.

    • Official Post

    Ziggyzhang Don't post your logs as plain text, because it will make this thread hard to read. Use quoting / code formatation for short log snippets, and services like PasteBin for longer logs. Thanks!

  • I am trying to execute Crazycat system build in a RPi4 with Raspbian to support HDstar tuner. I am stuck in the following problem: ERROR: "__devm_regmap_init_sccb" [/home/pi/media_build-master/v4l/ov9650.ko] undefined.

    I appreciate any help or clarification on how to clear this.

  • I am trying to execute Crazycat system build in a RPi4 with Raspbian to support HDstar tuner.

    Would love to hear how you get on, I had trouble getting this to work on a RPi4 and gave up!

  • Hi there guys.

    Can anyone provide me a step-by-step comprehensive guide on how to make this work in 2021?

    I've got mini pc with Ubuntu 18.04 LTS running kernel 5.4.0. Will it work there?

    Thank you very much in advance.