@balbes150 LE images with Kodi-19 for S9xxx

  • So what you mean is you have to connect the box to a pc with usb burn tool but it's not necessary to flash anything in order to fix uboot?

    You'll have to flash the Android firmware using the tool.

  • You can update the android with the same version you have now from the recovery, and you will not lose anything installed.

    Download the firmware of your device from the manufacturer's website.


  • Download the firmware of your device from the manufacturer's website.

    for most tv boxes this sounds like a good joke ;)

    Unfortunately that's how it works for my x92. Only place where such things can be found are places like freaktab...

  • You'll have to flash the Android firmware using the tool.

    That's quite odd if you are used the unbrickable boot sequence of allwinner SOCs.

    At the time I wasn't aware something would be altered on the emmc. Else i hadn't tried CE back in the time.

  • Pretty much anytime one of the typical Android boxes wants to run something other then the Internal Android the U-boot environment gets slightly altered or patched to allow that altered environment to stay in effect from that point forward, unless someone once again decides to change it...

    So by using the original firmware for the box it will restore the u-boot to the factory state...

    The only other way to fix it that i can think of would be to use a serial rig to stop the u-boot when it boots and issue the commands to restore the environment that way... as long as no ones messed it up to bad and over written it there is normally a backup of the factory environment in the system, or if you know what the factory settings were you can manually set the environment from the serial terminal... its just not something most users would do as it requires setting up a serial uart on the box and using a terminal from a pc or other source to talk to the box... Doing the restore this way would in no way effect the installed Android or your personal settings as you would be basically only adjusting U-boots enviroment reqarding how it boots the box up...

  • I tried 03/12/2019 on my Beelink GT-King Pro, it booted.

    Screen was Blue/Green my MX3 airmouse did not act as normal, mouse function is ok but keyboard doesnt work.

    Tried a few Hevc movies but none of them was successfully showed.

    As a start I'm happy to see LE booted with GT King Pro.

    • Official Post

    GT King and King Pro should both work as the hardware is almost identical .. although ealier versions of their Android firmware have u-boot versions that can be fussy with SD card or USB booting. The washed out screen colours are caused by the vendor u-boot setting HDMI properties that the latest kernel releases don't fully understand. The correct but slow fix is extending the DRM driver. The faster but more brutal fix is to replace vendor u-boot with mainline u-boot (which doesn't support the HDMI properties that aren't supported in the kernel .. thus sidesteps the issue). I have Beelink's u-boot sources if we need to go in that direction, but Oleg is also experimenting with another approach which might be more subtle :)

  • DVD playback has been flacky in Kodi for years at this stage, it has not got attention for years because the people who maintain Kodi do not have any interest in supporting it properly. Its effectively a dead technology.


    Sure, but in LE 9.0.2 and all versions before it all worked perfectly fine, as do the recent Windows builds. So why doesn't it work properly on C2 anymore? Kodi itself works fine for other builds. DVD might be a dead horse, but people have hundreds of them in their collection...

  • Besides the problems with some addons still not py3-ready the

    LibreELEC-AML.arm-9.80-devel-20191205090358-6e9040d-amlgx.img.gz Build works nice on my x96mini 2/16 with eth.
    Since may this is the first release where even plugins with widevine like joyn or zappn work again...libreelec with kodi 19alpha seem to move forward into an usable direction somehow-nice! :)

    • Official Post

    The new version of images 20191209. This version changes the DTB setting principle for the Odroid N2 model. Now the principle of setting is the same for all devices. You need to use two files (uEnv.ini) and (extlinux.conf). For models based on g12 (s905x2 s922), which have a problem not the correct color of the Kodi interface, you need to use the SD card to write the image and additionally download and copy the file to the SD card (u-boot.ext).


  • Hello everybody,

    do one of you use a Kodi 19 image of balbes150 on an ODROID-N2 in connection with the EMBY client?


    NanoPC-T4 with LibreELEC, EMBY and TVHeadend Client, 9.2.0
    Odroid-N2 with CoreELEC, EMBY and TVHeadend Client, 9.2.1

    NAS with EMBY Server, TVHeadend Server

  • Update version 20191216 with kernel 5.5.

    Added support for built-in WiFi.

    Installed your build 201912120 LibreELEC-AML.arm-9.80-devel-20191220155508-6e9040d-amlgx.img.gz onto SD

    Modified uEnv.ini and extlinux.conf to ensure pointing to correct dtb for my vim2 "meson-gxm-khadas-vim2.dtb"

    Vim2 booted up into LibreELEC OK with following minor? warning message a start of 1st and subsequent boots

    [FAILED] Failed to start Set CPU Frequency governer and its tunables

    Build in WiFi "AP6359SA BCM4359" for my Vim2 Pro initially did not seem to be being recognised within LibreELEC settings, however when I physically connected LAN cable to VIM2 both wired and available wireless connections appeared.

    Successful made connection to LAN as expected, then attempted to switch to available wireless connection(s).

    1st attempted to switch connection to 5GHz band, entering password when requested etc. Upon entry of password and OK all available wireless connections disappeared from LibreELEC Settings list with no warning/error message. (recollect this as existing issue with LibreELEC settings, going into existing LAN connection as if to edit but select refresh option, finds and re-presents all available connections in list)

    2nd attempted and successfully switched from LAN to 2.4Ghz band, great news

    3rd attempted and successfully switched from 2.4Ghz to 5GHz band, great news

    Switching/Making WiFi connections via the LibreELEC settings menu seemed a little flaky, but with persistence and additional attempts

    Looking great for fully working WiFi on Vim2 Pro moving forward :cool:

    RPi4, (LibreELEC 11.0) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

  • Installed your build 201912124 LibreELEC-AML.arm-9.80-devel-20191224125321-6e9040d-amlgx.img.gz onto SD

    Modified uEnv.ini and extlinux.conf to ensure pointing to correct dtb for my WP2 "meson-gxbb-wetek-play2.dtb"

    Boot Ok

    Pvr IpTv Client Ok

    Lan Ok

    Pvrhts Ok

    Tvheadent Ok

    Youtube 1920x1080 - 2560x1440 vp9 SW ok

    Youtube 3840x2160 vp9 SW no, video freezes.

    Tuner No

    Audio No

    Wireless No

    Netflix NO


  • Installed building 20191224 onto SD. uEnv.ini and extlinux.conf are modified to point to the correct dtb for my Khadas Vim3.

    I notice that all the audio passthrough options are now gone.

    In terms of Audio Output Device, I can only choose between 'ALSA: G12A-KHADAS VIM3, Analog' and 'Pulse: Default, Bluetooth Audio (PULSEAUDIO). I think there used to be an option for HDMI.

    • Official Post

    I made the decision to stop patching audio card names in the kernel so we hoard fewer patches. This means the AMLGX and AMLG12 card names will be replaced with more random names (whatever is in the device-tree file). Anyway.. I'm still in the middle of fiddling with audio things in the Linux 5.5 kernel so some things work, some don't work. I'll have a look at VIM3 in the next couple of days..

  • Hi All ! 😋

    I am back after many months since a summer issue.

    Thanks to Christian for fixing my account ID and for helpful notes on vdec issues, and to Oleg ( balbes150) for doing some magic including referral to two of his Armbian threads ( I posted him on his main Armbian thread for S9xxx.)

    So I have a tip and many questions, after reading through the last 6 months of this thread and of the above 3 balbes150 Armbian threads:

    1. Tips for many (including me) still confused about multiboot, and booting LE balbes builds after CE boot (from SD card or emmc.)

    A. Here are the instructions from Post#1 of Oleg's Armbian S9xxx thread, if you are booting a fresh Android Box, i.e., one that hasn't had CE/AE/other distro booted from before:

    ARMBIAN for Amlogic S905 and S905X (ver 5.44 =<) - TV boxes - Armbian forum

    B. It's not clear to me if the above basic method will work for prior CE/AE boot, which has tripped many.

    In this case, you should first follow below instructions to change u-boot (modified by CE/AE) back to the original Android u-boot.

    (Thanks ukmark62 !)

    This method looks simpler ( correct me) than having to change back to original Android u-boot via using USB Amlogic burn tool on PC that will then install original Android firmware on emmc of the affected Android Box:

    Test LibreELEC images with KODI-18 for S9xxx

    This method first resets Box to original Android reboot, then you follow partial (A) instructions ( A instructions minus the Update &Backup steps for restoring original Android uboot), in its later steps.

    Edit. My concern about A v B is: In B, the (first) reboot occurs once and the box then boots to Android ( then you follow remaining instructions in A.) In the A scenario, there are two reboots ( boot into Android after first reboot?) and the box then boots to LE balbes OS.

    It is also true ( from a subsequent @balbes 150 remark on method B) that the files required for B already are all part of the img.gz for LE balbes builds now.

    So it appears to me that in both cases (a fresh Android S9xxx box or a CE/AE booted Android S9xxx box), method A should suffice. But I will wait for guidance ...

    C. My 2c on why Oleg is using this more complex universal multiboot boot method:

    To integrate development of various OSes ( LE versions, Armbian, Debian) and various hardwares ( Amlogic gxl, gxm, gxbb, g12, Rockchip 3288, 33**, Allwinner H series.)

    He already is working on a single Armbian image for above hardwares, and might just do so for LE too.

    Now my questions !

    My use case here is a generic S905/x/w box with 1/8 or 2/16 GB, streaming 720p ( no 1080 p or 4K.)

    2. Is LE mainline u-boot the same as above universal multiboot u-boot Oleg is using?

    3. Which last kernel version for LE balbes does support emmc install?

    4. The balbes Yandex Kodi 18 folder is grayed out.

    Can I just use the Kodi 19 builds with the same features and compatible addons support as for Kodi 18, for 720p streaming on a gen S905/x/w box?

    If not, where can I find the last LE balbes build for Kodi 18?

    I ask because I was informed of video decoding issues with Kodi 19 ( need to be kernel compatible.) But I don't know if this suggestion of switching off hardware acceleration for gxl and g12 boards also affects the gxl variety for 720p streaming.

    4a. On p66 of this thread, ukmark62 says that hardware video performance is better on another distro with bespoke kernel (3.14.29 ? 😏.)

    Does this apply to 720p or higher res?

    5. I am looking for some boot script(s) such that I don't have to go into Kodi menu after boot.

    Rather, at boot time, after splash screen etc, the OS should have screen prompt for the user configuring WiFi ( AP mode, or input WiFi sta mode SSID available and password.)

    I know some wifi chips like ssv6051P (e.g., on x96) don't work in WiFi AP mode, given old drivers. But Realtek wifi chipsets should.

    Also a boot script for switching between HDMI and AV output.

    ( I am told LE mainline does auto switch, but don't know about LE balbes.)

    This way I can SSH later and edit if I need to !

    Unluckily I am not a dev/coder, but I can follow instructions and try to emulate someone else's script.

    6. Is there a performance/features difference between Armbian Kodi and balbes LE distro for a S905* tv box with 1/8GB ?

    How about for 2/16 GB variety for 720p streaming?

    I guess the Armbian should be slower, but it'll be nice to hear from someone else.

    And yes, Happy Holidays and a great New Year 🎉 2020.

    Edited 4 times, last by shippy: Additional note for boot methods, A, B. ().

  • balbes150

    I bookmarked your Yandex.Disk, but recently you deleted all kore-18-based LibreELEC images, but for me, many plugins do not support kodi19, and the image in my computer is also lost. you can also provide Does the mirror of kodi18 give me? My device is AMLGX, s912, thank you very much for your contribution.