[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • TX3 Mini Test

    Just plugged in my powered hard drive which is formatted NTFS and it does not show up under file manager or videos.

    I rebooted and not showing up.

    No notification when plugging it in.

    Notification comes up when i pull it out. (Successfully Ejected)

    Tried both USB Ports.

    This powered Hard drive is normally plugged into my TX7 and records my TVHeadend Recordings.

    No issues with it being seen on the TX7 Box Running 8.2.3.1. See signature.

    From below log something not right Line 609 and 610 maybe ???



    Note:

    For interlacing issues artefacts Create autostart.sh and copy to .config

    The TX3 Mini suffers from this when playing .ts TV Recordings.

    It is not this build. It happens on all stable builds as well.

    Code
    1. echo 1 > /sys/module/di/parameters/bypass_all

    Edited 6 times, last by kostaman ().

  • My remote works but time reaction is really slow. Same slow behavior when using TV remote in CEC mode.

    Navigation with Yatse Remote app is works (normal).

    TX5 PRO S905X

    Edited once, last by yatoya ().

  • i would LOVE to know why i receive no help at all....=x i was expecting this forum to be friendly!


    I need to find out how to set av video output to 480p on my box, please! any tips? im using ntsc tv.

    AZW W95 android box with s905w and 2gb ram

  • My remote works but time reaction is really slow. Same slow behavior when using TV remote in CEC mode.

    Name your Box/Remote to compare to others.

    My TX3 Mini lags in receiving command presses. There is a delay.

    Official Kodi Remote via my phone works perfect.

    CEC is perfect with my Sharp TV Remote.

  • I need to find out how to set av video output to 480p on my box, please! any tips? im using ntsc tv.

    This is an Alpha Build so i would not be trying this until you use stable kszaq builds to see if it works.

    Read from [8.2.3.1] LibreELEC 8.2 for S905/S905X

  • I guess with this new build the importance of this topic

    remote.conf repository

    raises immensely.

    I would appeal to post issues, related to IR remotes there, as well as "confirmed-to-be-working" solutions for the various boxes...


    :thumbup:

  • Will the remote of my beelink minimx III II ever work?

    Beelink MiniMXIII II 2GB, 32GB always running latest Libreelec from SD card. No issues so far(except for the ones already known or posted by me).

    Mecool m8s Pro+ which with widevine level 1, Android runs a hacked version of android TV.

  • I would appeal to post issues, related to IR remotes there, as well as "confirmed-to-be-working" solutions for the various boxes...

    Maybe a better idea to eliminate confusion.

    LE9.0 remote configs ir-keytable Amlogic devices


    If kszaq decides to do another community based release then it will be the same, this is a LE9 change. If people create remote configurations and share them then they can be added to future builds for the benefit of all, the instructions are not rocketscience and I have tried to make them as easy to understand as possible.

    Edited once, last by kostaman ().

  • Will the remote of my beelink minimx III II ever work?

    Hi,

    I have generated a config file for my Beelink GT1 and GT1U remote. I think the ir codes are the same with the Mini MV III II. I have mapped a few keys to use it with Libreelec. Please take a look in the beelink_gt1 file.

    1. systemctl stop kodi
    2. systemctl stop eventlircd
    3. copy the file "beelink_gt1" to "/storage/.config/rc_keymaps/" and "rc_maps.cfg" to "/storage/.config/"
    4. ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
    5. systemctl start eventlircd
    6. systemctl start kodi

    Files

    • beelink_gt1.zip

      (921 Byte, downloaded 133 times, last: )
  • Thanks Adam for your usual helpful response. Yes I fully understand and of course as always support and respect your good work here.


    I was just making a point here as these days there seems so may so called updates in so many walks of life that I find end up being downgrades and was worried this might end up the same way. Sure I fully understand these are early test releases only and you are right to comply with the new default system for remote mapping. I will try to adapt my really nice Beelink MXIII II remote.conf file I use in LE8 to this new mapping system when I get my head around it. The key allocations I currently have mapped and use with LE8 I find very user friendly with all keys on the Beelink remote being mapped for useful purposes. If I succeed when and if I get time to try, I will indeed post it wherever is appropriate here for the LE9 remote mapping files. I will also do the same for my TX7 box too. Just finding the time as retirement can be so busy hmm :-)

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Might as well try a clean install too

    Clean install did it! Right now to grab the X96 and MiniMX keycodes . . . :thumbup:

  • The latest 8.90.4 build is running great on my X96 Mini (S905W). I used the specific S905W DTB: gxl_p281_1g.dtb.

    Only weird thing with these S905W boxes is still the deinterlacing. Some 1080i material via an TvHeadend server is showing weird artifacts (green/pinks lines) after a few seconds. For example look at this topic: X96 mini - green/pink lanes on picture


    When setting this via SSH it is fixed 'echo 1 > /sys/module/di/parameters/bypass_all'

    But if I understand correctly the Amlogic deinterlacing is turned off completely with this command? So it only is an workaround?

    I don't really see any difference when watching interlaced material, maybe my TV is deinterlacing when bypass_all = 1? (on 1080p output?)


    I can provide examples of problematic 1080i files, if someone wants to look into this problem?