[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • Hey GDPR-2 or anyone else.. 1.0.3 runs great but I can't seem to find any pvr plugins. Is there a working repo? Should I use the ones from Gendo builds? I am specifically looking for the TVheadend PVR client.

    I ended up using the TVHeadend client from Gendo this worked.


    The good news is on Kodi 18, they've finally fixed HLS streaming! Kodi 17 HLS was horrible.

  • How does one install amazon prime? I get a dependencies error when trying to install. Do I need to install java separately or something?

    Strange... anyway I recommend Amazon VOD addon instead the one Gendo and Johngalt recommend on their github pages, because there are no updates done for at least one year. The last version of the well maintained addon (Amazon VOD by Sandmann) is 0.4.5 beta. Just google it

  • Hey GDPR-2 or anyone else.. 1.0.3 runs great but I can't seem to find any pvr plugins. Is there a working repo? Should I use the ones from Gendo builds? I am specifically looking for the TVheadend PVR client.


    pvr plugins will be uploaded soon and then available in the kodi repository that comes preinstalled


  • pvr plugins will be uploaded soon and then available in the kodi repository that comes preinstalled

    Awesome thanks!!! That would be very much appreciated. Otherwise your rom is working great for me.

  • all the addons are uploaded now and available in the libreelec repo or you can browse them here

    a number of addons are broken and not included until they are fixed upstream, these are listed below

  • Edited once, last by e123enitan ().

  • Docker and linuxserver? Awesome! Can't wait to try it.


    Thanks

  • GDPR-2

    any plans of releasing an update based from kszaq's latest 8.2 build?


    There would be little point in that as there was no major changes by him in his recent build that was specific to the S905, most of the updates in it where related to Kodi and as this build is based on the master branch anything that is in 8.2 is already in here.

    I believe the LibreELEC team will be pushing its next round of big changes the beginning of November, so another build will be incoming then, I'd like to focus more on dealing with any issues people have with the current build at present so any fixes go into the next one.

    -edit
    Thinking again on your post, I make daily builds that have slight changes but these are often things that I believe do not warrant a version bump, I have made a devel folder on the server if you are interested in running these however they will not automatically update if you do choose to run them.

    Edited once, last by GDPR-2 ().

  • Hi GDPR-2


    I see that some libretro addons not exist at Index of /libreelec/addons/9.0/S905/arm and not are on the list of broken.


    If you are interested on add more/better support I can port come code from Lakka-LibreELEC


    I have send some changes to upstream, and I have more ready to be send, but maybe will be interesting send my changes over your branch before send it to upstream (in order to test my changes over a bigger range of users, not just my own testing).

    Edited once, last by CGarces ().


  • I saw your changes a few days ago and thought they was a brilliant idea, I noticed a lot of inconsistencies in the libretro package files, with support coming upstream soon for rockchip/allwinner it makes more sense for the if/else statements to be cpu specific rather than project specific, I will definitely push your changes to the next build. Thanks

  • I've downloaded the 1.0.1 release.


    Burnt the .img to the microSD with Rufus, Libreelec boots fine the first time.


    Then, after the first reboot, it gives me the error in the pic.

    Even with the 1.0.3, I have the same issue.


    GDPR-2 have you tried this via microSD? Thanks

  • Hi Guys,


    Not sure what I'm doing wrong here...I'm trying to install on sd card to my Wetek Play 2.


    I've downloaded img.gz file and used both Rufus & LibreELEC.USB-SD.Creator to burn image to SD card. However the installation hangs at the 1st splash screen (the one that says Press power button to boot to Internal NAND) and won't go any further! I cannot install this build.


    Any help?