Posts by DS-1

    You don't need to flash it to your board, you just need to substitute the existing .dtb file on your sdcard with the other device tree provided

    Now something a little different happens: the box always bypasses microSD boot and goes into ARMbian, but now microSD isn't empty and the double partition of the microSD card is shown into ARMbian (I have two microSD icons on the desktop).

    I don't think it is possible at the moment. Armbian u-boot is compiled to do what you want, but due to the bug libreelec kernel does not boot. But if you try and use the device tree I posted in the armbian forum it will probably work for the time being.

    try that device tree is what I will do tomorrow ..but is it easy to flash to my rk3229 box?

    The boot issue is an issue with armbian u-boot/trust (I use mainline u-boot and OPTEE) installed in eMMC and libreelec u-boot (which uses legacy): CSC Armbian for RK322X TV Boxes - Page 14 - TV boxes - Armbian forum


    No idea why the sdcard has been emptied though.

    I've tried another microSD: it doesn't become empty, but it doesn't boot.


    I've seen what you've posted about the boot issue. What you have on your eMMC? I would like to try something on eMMC that makes no boot issue/bugs to boot legacy libreelec u boot.

    Thanks for the reply and for the infos!

    Unfortunately I am not able to boot any of the legacy image! Red led and nothing happens! A couple of minutes ago I tried with A95XR1 legacy image. It was succesfully burnt on microSD with Libreelec tool (I've also tried with Rufus) and I've checked files and partitions on my pc and everything was ok, but when I putted the microSD into the box, it bypassed the SD boot and went to armbian o.s. I've extracted the card from the box and checked it in the pc: the card was empty! I've used the same card for armbian and for Libreelec mainline and it worked fine!

    I have csc armbian installed on eMMC and I'm trying to boot Libreelec via microSD.


    I'll try again, I took a look at the characteristic of the images in the first post and no one has DDR2 and eMMC together...I hope that any of the DDR3 and eMMC will work!

    ..the Kernel is in the image and has nothing to do with the Kernelversion of your android.. just try a new build (nov/dec '18) and follow the instructions carefully(the procedure is DIFFERENT from that on old kernels!..). Most likely all that will result in an working LE for you...

    Ok. I believe the steps are in this thread. I think I'm not doing it wrong, but obviously I'll start from the beginning, again, to try to solve this issue. Thanks!

    Both the points are possible. The dtb I'm using seems to be the right one. I'll double check the instructions. In the meantime, what kernel is good to run this newer release? Can I check it looking into the android infos of the internal memory ROM?

    From which specific version of the image are you trying to use dtb ?

    balbes150 from 8.2.3 LibreELEC release. But I think dtb is not the problem. I think the problem is that the newer "boot configuration" files don't work on my box. If I try to boot any LibreELEC release lower than 9, it boots. But 9 release and ARMbian that uses the same "boot system", don't boot.

    ..you should also try the dtb's delivered with the build again after the update.zip thing done once..

    That's what I've done:


    - burnt the latest LE 9.0 for s812 .img.gz on a 4gb SD card using Rufus;


    - added the working LE 8.0 dtb into /dtb folder and modded the uEnv.ini with my dtb name;


    - booted the box into Android, putted the SD card into the slot and selected the aml_autoscript.zip as "update".


    At the reboot, the boot stops on the libreELEC logo.

    ..did you activate new bootloader by using the update&backup app in android, loading the aml_autoscript.zip?! This might be needed to load the newer builds properly, even if boot from card is activated already. Had some troubles with that after using a libreelec le potato official build to test. After that trying to boot the balbes-build again failed until I re-installed the zip with android..


    Did you try to get an armbian work on your box? Maybe try a newer Version and also an older one. If that works, maybe you could use the dtb from these builds..

    I didn't know about the .zip to activate the new bootloader. I've tried it via update&backup, using my working .dtb took from LE 8, but it doesn't boot. Now I'll try with a default dtb. If it doesn't work, I'll try installing armbian.

    ..and you downloaded a s812 version of the rom(and not one of the s9xx builds?!)?..
    What happens if you copy the original dtb to sd card and try to boot?! For me on s905w-boxes (x96mini & tx3 mini) the builds work fine using the right dtb..


    In my collection of several dtb's for many boxes I found one specific for your m8splus(just unzip and insert in BOOT/dtb and alter uEnv.ini)-maybe that works.

    Maybe try also another (older build) and try to update that if you get it work..

    Yes, I downloaded the s812 release. I've also tried with a dtb I used on Le 8 without success. I'll try yours, let see if it works.


    The older builds work for me, those are the ones I used for months. Using the manual update, I can choose the Le 9 Channel, but the release panel is empty.

    I guess it didn't work because you copied the dtb into sd card root (like on older builds). With the latest builds you need to alter the uEnv.ini (and data_to_emmc_uEnv.ini too if you want to install to emmc AFTER getting all work from sd card) with an text editor and change the path/name from the different dtb files. No need to rename them in root of card!

    I've tried to edit the uEnv.ini using every single .dtb namefile present in dtb folder, but no one makes my M8S+ s812 based boot.


    Is there anything else I should edit to make it boots?

    I guess it didn't work because you copied the dtb into sd card root (like on older builds). With the latest builds you need to alter the uEnv.ini (and data_to_emmc_uEnv.ini too if you want to install to emmc AFTER getting all work from sd card) with an text editor and change the path/name from the different dtb files. No need to rename them in root of card!

    I was looking for some kind of infos about this ..I knew I was missing something, but dunno what! Thanks for the advice, I'll try it!

    I have the same box as yours, but I can't make it boots. It hangs on LibreELEC logo. I'm trying the latest November release. I've tried all the different dtb files into SD root card without success.