@balbes150 LE images with Kodi-19 for S9xxx

  • After running this build on a tronsmart vega s89 for a while I can say that it is not stable. I experience frequent crashes and freezes. I'm forced to go back to the previous released builds...

  • For me this builds work good. Even front display and remote is easy to get working on tx3 mini. When installed to internal besides android, how to reboot to libreelec on internal(sd card works, reinstall to internal too..) after using android?!

  • I have the same box as yours, but I can't make it boots. It hangs on LibreELEC logo. I'm trying the latest November release. I've tried all the different dtb files into SD root card without success.

  • I've tried all the different dtb files into SD root card without success.

    I guess it didn't work because you copied the dtb into sd card root (like on older builds). With the latest builds you need to alter the uEnv.ini (and data_to_emmc_uEnv.ini too if you want to install to emmc AFTER getting all work from sd card) with an text editor and change the path/name from the different dtb files. No need to rename them in root of card!

  • I guess it didn't work because you copied the dtb into sd card root (like on older builds). With the latest builds you need to alter the uEnv.ini (and data_to_emmc_uEnv.ini too if you want to install to emmc AFTER getting all work from sd card) with an text editor and change the path/name from the different dtb files. No need to rename them in root of card!

    I was looking for some kind of infos about this ..I knew I was missing something, but dunno what! Thanks for the advice, I'll try it!

  • Hi Guys, has anyone make success of writing this image into emmc. I have everything working so far on SD, but I couldn't get to write to Internal emmc.

    pls share your steps, if you are successful in writing into emmc.


    Thanks

    Edited once, last by e123enitan ().

  • Hi e123enitan, I successfully installed the system on 2 of 3 boxes to internal after having it working on card. It is quite simple:

    1. check/alter data_to_emmc_uEnv.ini(in BOOT) to fit the same dtb file working for you with sd card

    2. boot to libreelec from your card

    3. choose the libreelec icon in settings and navigate to services

    4. navigate to eMMC in the list(the point under bluetooth), choose Install to eMMC and start the process

    5. the files are transferred to internal and after some seconds the box is ready and powers off

    6. pull your sd card out of the device

    7. start the box and enjoy libreelec from internal! :-)


    P.S.: If possible keep the card safe, just in case you need to reinstall libre with all your settings, addons and stuff..

  • I guess it didn't work because you copied the dtb into sd card root (like on older builds). With the latest builds you need to alter the uEnv.ini (and data_to_emmc_uEnv.ini too if you want to install to emmc AFTER getting all work from sd card) with an text editor and change the path/name from the different dtb files. No need to rename them in root of card!

    I've tried to edit the uEnv.ini using every single .dtb namefile present in dtb folder, but no one makes my M8S+ s812 based boot.


    Is there anything else I should edit to make it boots?

  • ..and you downloaded a s812 version of the rom(and not one of the s9xx builds?!)?..
    What happens if you copy the original dtb to sd card and try to boot?! For me on s905w-boxes (x96mini & tx3 mini) the builds work fine using the right dtb..


    In my collection of several dtb's for many boxes I found one specific for your m8splus(just unzip and insert in BOOT/dtb and alter uEnv.ini)-maybe that works.

    Maybe try also another (older build) and try to update that if you get it work..

  • ..and you downloaded a s812 version of the rom(and not one of the s9xx builds?!)?..
    What happens if you copy the original dtb to sd card and try to boot?! For me on s905w-boxes (x96mini & tx3 mini) the builds work fine using the right dtb..


    In my collection of several dtb's for many boxes I found one specific for your m8splus(just unzip and insert in BOOT/dtb and alter uEnv.ini)-maybe that works.

    Maybe try also another (older build) and try to update that if you get it work..

    Yes, I downloaded the s812 release. I've also tried with a dtb I used on Le 8 without success. I'll try yours, let see if it works.


    The older builds work for me, those are the ones I used for months. Using the manual update, I can choose the Le 9 Channel, but the release panel is empty.

    Edited once, last by DS-1 ().

  • ..did you activate new bootloader by using the update&backup app in android, loading the aml_autoscript.zip?! This might be needed to load the newer builds properly, even if boot from card is activated already. Had some troubles with that after using a libreelec le potato official build to test. After that trying to boot the balbes-build again failed until I re-installed the zip with android..


    Did you try to get an armbian work on your box? Maybe try a newer Version and also an older one. If that works, maybe you could use the dtb from these builds..

  • ..did you activate new bootloader by using the update&backup app in android, loading the aml_autoscript.zip?! This might be needed to load the newer builds properly, even if boot from card is activated already. Had some troubles with that after using a libreelec le potato official build to test. After that trying to boot the balbes-build again failed until I re-installed the zip with android..


    Did you try to get an armbian work on your box? Maybe try a newer Version and also an older one. If that works, maybe you could use the dtb from these builds..

    I didn't know about the .zip to activate the new bootloader. I've tried it via update&backup, using my working .dtb took from LE 8, but it doesn't boot. Now I'll try with a default dtb. If it doesn't work, I'll try installing armbian.

  • ..you should also try the dtb's delivered with the build again after the update.zip thing done once..

    That's what I've done:


    - burnt the latest LE 9.0 for s812 .img.gz on a 4gb SD card using Rufus;


    - added the working LE 8.0 dtb into /dtb folder and modded the uEnv.ini with my dtb name;


    - booted the box into Android, putted the SD card into the slot and selected the aml_autoscript.zip as "update".


    At the reboot, the boot stops on the libreELEC logo.

    Edited once, last by DS-1 ().

  • Thanks for the write up', I am 100% certain I followed exact steps as you described, but when the system reboot, it generates an error message. I will review the uEnv.ini file again as that could be the only portion where things could have got messed up.

    Cheers!

  • Hello. I have install the s812 17.6_20180122 mxiii plus to my mxiii-g TV box and I notice that when I select power off from power menu the tv box seems to closing but after a while it's opens again. I think there is issue with the CEC operation