[] LibreELEC 8.2 for S905/S905X

  • Hi kszaq,

    In your build for odroid C2 live tv has dd 5.1 when passtrough enabled.

    Raybuntu's krypton build has multichannel when passtrough enabled.

    Is something changed?

    How to set the audio settings in your build to get multichannel i live tv with passtrough enabled?

  • I'm afraid you won't get decent channel switching times in Krypton. The best so far is @afl1's build but I don't want to include his patches as they look too hacky for me. On the other hand, Leia is reported to be excellent in channel switching.

    Thank you for this insight, i was wondering myself about the pvr & videoplayer progress in Leia.

    No particular rush for me on the s905 models i own, because i really think what you did in the latest 7.0.3 versions is truly magnificent. I will happily keep using that build for now and i will surely find out how to send you a coffee!

  • Greetings,

    Also I think I have found a bug, the channels that use the H265 / HEVC code are not open in the IPTV Streams that I added to the TVHeadend system.

    Best regards...

  • I was trying to build 64bit image on 8.1.1 tag but it fails at getting qca-firmware_1.0.0-3_armhf.deb

      GET      qca9377-firmware-aml

    I guess there is a way to fix this?


  • Oddly I was able to get the box booting from SD card today. Last night I tried at least 10-15 times with no boot activity.

    The really strange thing is that the "x96" boot logo was not present during boot. The first thing I saw was the LE bootsplash. This was the same over several cold boots and reboots while I was restoring backups to sd. The x96 bootsplash returned only after I copied LE back to nand with "installtointernal."

    Still not sure what happened. I doublechecked my device tree and it's the same one I'm using now. Possibly just a buggy Chinese TV box!

  • Thanks Kszaq for your excellent work as always!

    Anybody tried playback and, more importantly channel switchtimes for Live-TV in this build?

    I am still running version as this does the job for livetv and switching channels perfectly. Still waiting for a Krypton build that doesn't take forever to change the channel (especially noticable with HD streams, sometimes it takes as long as 30-40 secs).



    What add on do you use for live tv?

    I use enigma2 and tvheadend, and I had fast channel switching on all built I used ( nearly all released builds ).

  • In your build for odroid C2 live tv has dd 5.1 when passtrough enabled.

    Raybuntu's krypton build has multichannel when passtrough enabled.

    Is something changed?

    How to set the audio settings in your build to get multichannel i live tv with passtrough enabled?

    Raybuntu's build doesn't include a patch that enables passthrough for live TV. You can get multichannel audio if you disable passthrough - that way DD 5.1 is decoded to multichannel PCM.

  • Hello,

    I have a Nexbox A95X that worked without a hitch with the remote control using some release of 8.0.2, I don't remember which.

    Then the box refused to work with the remote as late as 8.0.2e.

    Note that I always ran LE from the internal memory.

    I did a complete wipe of all the data and internal memory and then I installed the 8.1.1 build.

    It works great but still no remote support.

    I found a remote.conf for the A95X on the net and put it in the rc_keymaps folder as explained, still no luck.

    How can I debug the problem?

  • @xtrips

    Seriously, just read the goldmine of info that is available (in these threads for sure, but also in other forums)

    You can create a remote.conf for any remote you care to use.

    Avoid asking for everything to be handed to you on a silver platter.

    The only way anyone ever really learned anything is by researching for themselves.

    Try it, one day you might be able to help someone else out (which is the point of these type of forums):thumbup:

    People that have discovered the answers you seek do, eventually, tire of keep answering the same questions (again and again) for those that won't attempt to read what is already available ;)

  • Video calibration values doesn't work. It works only in Main UI but when I play something don't apply the value

    I helped a member in the following post #3,021

    Have a read and maybe it will help you as well.

    Having to use Video Calibration is the last resort when an older TV needs to be calibrated in Kodi.

  • I posted this message repeated here below in the other 8.0 forum thread having forgotten there is a new one here for the latest 8.2 builds. So repeat it here as it is relevant to this thread and in case it was missed. I know Kszaq was interested about the auto 3D switching . Sadly there seems to be a flaw in the current 8.1.0 and as outlined below. But hey now I am here in teh right thread I just noticed that there is now 8.1.1 out so will try it with that newer version.

    Here is the post form the other forum :-


    Kszaq I replied a week ro so ago about the auto 3D function which I can say now that it is working with V 8.0.2e running on my Beelink S905x box, and indeed when running 3D content it now auto switches my 5 year old Samsung Series 7 into the correct 3D mode (usually SBS or sometiems TB) and theg KODI bottom of screen controls and subtitels all display correctly in 3D (very nice).

    However, I now install to my Beelink, together with the correct S905X new device tree, your new test version 8.2.-8.1.0 and can advise that the 3D feature no longer works and usually crashes my box when I llaunch 3D content leaving me in a black screen and requiring a reboot. Although the remote powere button does still switch the box off okay so it cannot be totally crashed btu no display and no sound. I did at one point get the 3D picture up (same content so dont know why it worked this once) but when I closed the video the same problem occurred with a blank black screen and had to shut the box down and reboot. With the reboot needed I cannot see how I can get a log or even if it would be relevant anyway with this issue.

    So thought you would like the feedback to advise you that the auto 3D seems flawed in the new 8.2 test build. Have now reverted back to 8.0.2e which is a superb build albeit only the MM kernel. So as always Kszaq, mega thanks for all your great work. Will be more coffee coming your way, just as soon as I get some new stock in :)

  • Guys thank you for your remarks and advice. I have been using forums for a very long time, so I am accustomed with the do's and don'ts.

    I have read the FAQ, of this forum and others dealing with that same problem. I have tried what has been advised, all of it, naming the file remote.conf and also sometimes rc_maps.cfg, depending on who you ask. I have tried putting it in the /storage/.config folder and also in the /storage/.config/rc_keymaps folder depending on who you ask. I have tried countless files downloaded from a lot of different sources. I have even changed the batteries on the remote, mind you. And still, it does not work.

    I am feeling stupid going after these instructions, blindfolded.

    What I am lacking here is 2 things:

    - how can I make sure that I have the right conf file and then restricts the tests to one and only one file?

    - how can I monitor the process of loading the file by LE ? This to make sure I am actually loading something