[] LibreELEC 8.2 for S912

    • Official Post

    Just a professional Q , I'm a software developer myself yet wouldn't know the first thing about modifying the kernel and the various other bits and bobs that you do. How did you pick that up? Professional background, curiosity? I've always looked upon the guys dealing closer to the hardware as the real guru's yet I dont see how I myself can go from a regular software guy to a on the bare metal dev like yourself.

    The only qualification required is the initiative to poke code and hardware with a hint of curiosity and method and see what happens. Our current extended contributor team includes a Carpenter, Paramedic, and an Airline Pilot, and sometimes the "least-qualified" folks are the most prolific creators :)

  • Above testing was done with old dtb.img...

    Using proper dtb.img from 2018-03-28 I get 500/792.

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • So wrxtasy no idea why only your builds crash while opening livetv?

    If you are watching 4K 50p HEVC TV and have a Chroma 444,10bit set that will not work because it's outside of HDMI 2.0 Specs.

    It's why we need 422,10bit working without the green screen bug - because then you can use 4K 50/60p display modes.

  • Hi,

    First of all thanks for the great work on the S912 builds.

    I've been using on a Minix Neo U9 and it worked great.

    When installing AAC audio doesn't work anymore (either on locally stored files or on IPTV streams). was updated with the corresponding device tree.

    Anything I can do to have AAC work on or am I stuck on in order to have it to work.

    Thanks in advance!

  • Beware - support for 10 or 12 bit content doesn't mean support for HDR content - nor does it mean your TV has a 10 or 12 bit panel.

    SDR video can use 10 or 12 bit video, and support for accepting 10 or 12 bit SDR video is pretty widespread - even if your panel is only capable of bit bit or less display.

  • Hi

    I wanted to try the 8.2.4 for the HDR chroma bit depth 4:4:4 10 bit on U9-H, but i had some "no signal" screens on LG 55C7.

    I discovered that the culprit is the Yamaha RX-V681 who doesn't like the 4:4:4 10 bit signal.

    I don't know why ... The Yamaha documentation says it's 4:4:4 10 bit compatible in "HDMI 4k mode 1" ... i tryed but it doesn't work.

    U9-H directly connected to the 55C7 : 4k hdr video play normally in 4:4:4 10bit

    U9-H -> RX-V681(HDMI in 4k mode 1) -> 55C7 : HDR logo on the tv immediately followed by a "no signal" screen.

    The U9-H needs to be connected to the RX-V681 to have the HD sounds (DTS-HD, Atmos)

    So, do you think you could add the others 10 bit chroma 4:2:0 and 4:2:2 in a future release ?

    Thanks for your work.

    Minix U9-H LibreElec 8.2 - Yamaha RX-V681 - LG 55C7V

  • If you are watching 4K 50p HEVC TV and have a Chroma 444,10bit set that will not work because it's outside of HDMI 2.0 Specs.

    It's why we need 422,10bit working without the green screen bug - because then you can use 4K 50/60p display modes.

    Just regular old [email protected] tv channels, as soon as it tries to open the stream from mediaportal it just crashes kodi

  • Hey guys, when my LibreELEC release: S912.arm-8.2.4-Oclock-GPU scrapes it locks up my Kodi 17.6 and then crashes. Minix U9 box. All settings are default.

    All I can see is this error:

    23:08:20.400 T:3871339360   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/series//images/query/params|Authorization=Bearer%20eyJhbGciOiJSUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1MjIzNTc2MTQsImlkIjoiS29kaSIsIm9yaWdfaWF0IjoxNTIyMjcxMjE0fQ.ZwtFoz3p3ij4H8Um61tMhiUCVXLEp71zzFTndEmNOBUo-gMQc7EfFgmb5O85ZHgq7v_oiOwSvCBmCO2yZ58C_v6ij_R9QAd798R8UeVA5mmpxk7d1b6CeHPllBpPGhTTSPGEXAlhpDBNv41CHQRGrU4OXZUdsaUGbW2kmt_yK_KcfTahaKdbyCgvjjDTmvgQp41oNHZukWpRU5pbpbcL0Kqdo4wMo6ZC-gQLKh7fnmaD6HBB3Gn4BIvAF25m5mOBxvXgulCmUz4gmXGe_f6RZmBg7MozBoA6aKOc0B7njIbgBfZcwy145lZrlQSU9wCXnSXikrVJbTz49WmFG_v0gQ

    23:08:20.401 T:3871339360   ERROR: Run: Unable to parse web site

    23:08:20.407 T:3871339360   ERROR: GetDirectory - Error getting

    23:08:32.096 T:3871339360 WARNING: GetDurationFromMinuteString <runtime> should be in minutes. Interpreting '0' as 0 minutes

    23:12:13.773 T:3871339360 WARNING: Previous line repeats 1 times.

    If I browse to that link it shows:

    {  "Error": "Not authorized"
  • Current GPU clock Frequency:

    cat /sys/class/mpgpu/cur_freq

    I found a small typo in /usr/share/kodi/system/advancedsettings.xml

    cat /usr/share/kodi/system/advancedsettings.xml

    <?xml version="1.0" encoding="UTF-8" ?>


    It should read gputemp ;)

  • The S912 build in the folder I just posted. It's for all S912 boxes.

    As usual just pick the correct .dtb for your particular S912 box and rename to dtb.img for 792MHz GPU Overclocking usage.

    Hi wrxtasy. Can you please confirm that the tar updates are either for gpu OC or for the subtitles fix? If I just use the tar subtitle fix and I am currently using kzsaq's build with the correct dtb file for Mecool Pro L, do I need to also use the dtb file from the OC folder?

    Edited once, last by Ozcube ().

  • @wrxstasy How do I go about overclocking my U9-H? I dont see any options in LE about overclocking. Current frequency is 666.

    TV: Vizio 2017 M55-E0

    Streaming Apps: Roku Streaming Stick+ for 4K/HDR Netflix, Youtube, and Amazon Prime Video

    Kodi: Minix Neo U9-H w/LE installed on MicroSD

    Remote: Harmony Elite

    Media Server: Unraid 40TB BEAST!

    TV Tuner: 2x HDHomeRun Prime

    Server Apps: HDHomeRun DVR, Emby (for Kodi), Plex (for everyone else)

  • Do i need those new device trees even when i dont want to overclock? Just want to use 8.2.4., but the first post wasnt updated (yet?).

  • I have a 681 and it works fine with a samsung mu8000.

  • With a KIII Pro and a Samsung 32GB card, the box loses the boot from SD settings if I restart or remove power cord. The only way to boot Libreelec again is doing the toothpick method. If I put the box on standby everything works. Any idea?

  • Thanks to PJohnny

    After your post, I checked my setup again (U9-H-RX-V681-LGC7) and discovered that the 4: 4: 4 10-bit black screens were caused by the use of HDMI5 on the RX -V681. HDMI5 is not compatible with HDCP2.2. By connecting the box to a HDCP2.2 port solved the black screens.


    Minix U9-H LibreElec 8.2 - Yamaha RX-V681 - LG 55C7V