[8.2.2.3] LibreELEC 8.2 for S912

  • DISCONTINUED: These builds will no longer be updated but you are welcome to use them!


    LibreELEC 8.2 for Amlogic S912 devices.


    WARNING:



    Amlogic has not released fbdev Mali libraries and has no plans to release them. These builds use libhybris and Android gralloc Mali driver to provide OpenGL for Kodi - an experimental approach with CPU overhead - meaning suboptimal GPU performance.




    How to install, update and FAQ: [HOWTO + FAQ] Install community builds on S905/S905X/S912 device


    Important notes:

    • These are unofficial, community supported builds so please post all bugs/issues in this forum area only.
    • Bug reports will no longer be looked into as the build is discontinued.
    • I work on these builds in my free time. I also don't know a lot of things so please be kind and patient if you encounter any bugs.
    • Bugs? Read this first: [READ FIRST] Reporting bugs

    If you forgot to use a new device tree or used wrong one and your device doesn't boot:

    • don't panic!
    • if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB
    • if booting from internal:
      1. Boot this build from SD card or USB with correct device tree.
      2. Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k
      3. Power off, remove SD/USB, boot from internal.

    8.2.2.3 (2018-01-06)

    Downloads: Index of /s912/8.2/8.2.2.3/

    Device trees: Index of /s912/8.2/device_trees/


    Changelog:

    • cleaned up installtointernal script
    • update all Broadcom and Realtek WiFi drivers
    • added fstrim service for all trimmable partitions
    • fixed random MAC address for some Realtek WiFi chips - those without factory MAC will always use the same, default MAC address
    • added loading SYSTEM to RAM also for boxes with 1GB RAM - LibreELEC will now boot a bit longer but be as snappy as on 2GB boxes

    Known issues:

    • SAMBA/SMB/Shared folder issues? Read this blog post first.
    • Manual updates in LibreELEC Settings don't work
    • Built-in DVB tuners are supported only for KIII Pro. I use driver from afl1 with some modifications, please do not report issues with the driver to him! If you want support, please use builds from afl1 .
    • 9082xs driver is now included but because it doesn't come with source code, there is absolutely no support for it!
    • 4K support is experimental.
    • 3D and HDR are not supported, i.e. they might work but I don't provide support.
    • CEC might not work when your box has incompatible u-boot or your TV is not that well supported by Amlogic low-level CEC driver.
    • External DVB tuner support is experimental via media_build drivers from CrazyCat69.
  • Nice. I'm flashing an sd card right now... :)


    Edit:
    It doesn't work on my H96 Pro 3GB/16GB box with the default dtb.img but I tried my own dtb img and then TADAM! IT WORKS!
    LAN (RTL8211): OK
    Wifi (AP6255): OK
    BT: OK
    CEC: Doesn't work
    Remote: Doesn't work
    USB keyboard and mouse: OK
    AAC, DD, DD+, DTS, DTS HS MA, TrueHD: OK
    multi chanel PCM: only stereo
    4k: plays only half screen

    RPI3 1GB, MINI MX-G 2GB, Mini M8S II 2GB (7.0-devel-20170430185848-r23797-g7772046), H96 Pro 3GB (8.2), H/K AVR 161S, LG 60SJ810V 4k HDR tv
    pel.hu

    Edited once, last by Pelican ().


  • Just tried this on my H96 Pro 2GB/16GB, stayed on H96, no boot. How do you get the dtb? or can I try your's?

    NUC with LibreELEC Controlled by Logitech 350 / Beelink MiniMXIII S905 2G/16G 1000M Lan CoreELEC from NAND

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.95.5 Controlled by Harmony 650 (configured as Mecool KIII Pro)

    Mecool M8S Pro L running Android Leia RC1 / HD Homerun Duo / Plex Pass :)


  • Simply delete dtb.img from SD card.


    What can I say, Fanbloodytastic. I got it to boot. Remote is not working, but managed to plug in a keyboard & navigated around the menu,


    No sound though, audio is greyed out with Blue tooth, but in LibreELEC config, no blue tooth found.


    Thanks

    NUC with LibreELEC Controlled by Logitech 350 / Beelink MiniMXIII S905 2G/16G 1000M Lan CoreELEC from NAND

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.95.5 Controlled by Harmony 650 (configured as Mecool KIII Pro)

    Mecool M8S Pro L running Android Leia RC1 / HD Homerun Duo / Plex Pass :)

  • You probably have an old Android firmware that has an outdated device tree.


    If you don't want to update whole Android firmware, find the latest package on the internet, download "SD" update file and extract dtb.img from it to your SD card.


    Edit: After further consideration I may need to provide a few variants of device trees...

    Edited once, last by kszaq ().


  • You probably have an old Android firmware that has an outdated device tree.


    If you don't want to update whole Android firmware, find the latest package on the internet, download "SD" update file and extract dtb.img from it to your SD card.


    Edit: After further consideration I may need to provide a few variants of device trees...


    I have found a couple of newer firmwares, for my device, I have a RAR file, but I don't know how to extract the device tree from them. :s

    NUC with LibreELEC Controlled by Logitech 350 / Beelink MiniMXIII S905 2G/16G 1000M Lan CoreELEC from NAND

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.95.5 Controlled by Harmony 650 (configured as Mecool KIII Pro)

    Mecool M8S Pro L running Android Leia RC1 / HD Homerun Duo / Plex Pass :)

  • I tried without any dtb.img:
    LAN not present. WIFI works, BT works, there is only BT audio device in audio settings-> no sound
    I experienced a couple of restart of Kodi and freezing too.


    Back to my dtb (which came from balbes150, he made it to use for armbian)
    I edited remote.conf copied to the root of the sd card contained about six remote unit data, I kept only the 0xfe01 factory code (my remote send this) and deleted the rest -> remote works now (the arrows at least)
    There is AML-M8AUDIO PCM and HDMI devices. sound works with both.
    Shutdown and suspend both works with remote,


    Atteched the dtb from balbes150: q912_otg.zip

    RPI3 1GB, MINI MX-G 2GB, Mini M8S II 2GB (7.0-devel-20170430185848-r23797-g7772046), H96 Pro 3GB (8.2), H/K AVR 161S, LG 60SJ810V 4k HDR tv
    pel.hu

    Edited once, last by Pelican ().


  • not working for my S92 alfawise , freezing


    regards


    Try without dtb.img or try with one from my post.

    RPI3 1GB, MINI MX-G 2GB, Mini M8S II 2GB (7.0-devel-20170430185848-r23797-g7772046), H96 Pro 3GB (8.2), H/K AVR 161S, LG 60SJ810V 4k HDR tv
    pel.hu

    Edited once, last by Pelican ().

  • Is there anything we can do to help the development?
    Provide dtb, logs, serial debug, etc.?

    RPI3 1GB, MINI MX-G 2GB, Mini M8S II 2GB (7.0-devel-20170430185848-r23797-g7772046), H96 Pro 3GB (8.2), H/K AVR 161S, LG 60SJ810V 4k HDR tv
    pel.hu

  • Dbt for Mecool BB2: bb2.zip (2GB RAM, 16GB flash)
    - ethernet: OK
    - wifi: OK
    - bluetooth: OK
    - audio passthrough: OK

    Edited once, last by afl1 ().

  • How is this possible. As i understood the problem with LE on s912 was the lack of a framebuffer driver with the neccesary librarys. Has this issue been resolved? Did amlogic released the t820 linux driver?

  • A few notes to clear things up:

    • For the moment please do not provide logs, device trees etc. First I need to fix a few things, e.g. resolution switching.
    • I will prepare and upload several device trees to try.
    • Amlogic has not released fbdev Mali libraries. This build uses libhybris and Android gralloc Mali driver - this is why the builds will always be experimental until proper Linux libraries are released (if ever).
  • Hi Kszaq


    Hope you are doing good


    I just wanted to ask can you please help regarding 2 issues in Libreelec for S812 M8S+ (BCM4335 wifi)


    Everything works fine in Openelec 6.95.1.1 from kerber Amlinux but when updating to Libreelec 7.0.2 from Amlinux Wifi does not work and once its turned off, unit cannot be restarted from remote control (need to take the power cable out and then put it back to restart)


    Strange thing is when I am on version 7.0.2 when connected with ethernet cable at the startup, I get a pop up that says "Update available". I then go to Libreelec setting and check updates and it starts downloading a update file 7.0.2.001 file and it takes about an hour and then after the restart wifi starts working


    Could you please fix this up if thats ok and do a Kodi 17 version ( if not 16.1 will be good too) and do a proper zip and tar file for this box and I am happy to contribute/donate in anyway you would like. I am also happy to send you M8S+ box if need be.


    I can also send you Kernel and driver files if that helps.


    Please help


    Thanks


  • I just wanted to ask can you please help regarding 2 issues in Libreelec for S812 M8S+ (BCM4335 wifi)


    You can open a new topic or find another one for S812 issues...

    RPI3 1GB, MINI MX-G 2GB, Mini M8S II 2GB (7.0-devel-20170430185848-r23797-g7772046), H96 Pro 3GB (8.2), H/K AVR 161S, LG 60SJ810V 4k HDR tv
    pel.hu

    Edited once, last by Pelican ().

  • I first thank kszaq for the work.
    Testing on a Q912, with the armbian @ balbes150 q912_otg.dtb.


    Thank you and greetings.

    Edited once, last by dieg0 ().