[7.0.3.012l] LibreELEC 7.0 for S905/S905X

  • @all I have uploaded a new version with a few changes to test. This build is not tested by me (I switched to Krypton testing), please experienced users only! In case anything goes wrong, you can always downgrade by simply putting a previous version in Update folder and rebooting.


    Changelog over 7.0.3.012a:

    • fixed Bluetooth using hciattach (e.g. Realtek 8723BS)
    • new QCA9377 WiFi driver
    • new QCA9377 Bluetooth driver
    • added an udev rule in hope to fix non-working WiFi on boot (you no longer have to toggle it in settings)


    Edit: Please use a newer version from OP.


    Version with temperature sensor disabled will follow if this build is confirmed to work well.

    Edited once, last by kszaq ().

  • Hi...


    I've got a problem regarding audio latency when using analog output (active speakers) together with audio over hdmi (TV). Is there a way to solve this? Can't exactly separate, which one is "faster" :-(


    Use case is, I like to have box connected to TV with audio while as also being able to have audio without TV on. (like listening to the three investigators while falling asleep :-) I could solve it without using both outs together, but TV sound is much nicer with additional speakers...


    Setting a delay isn't possible for audio only (music), afaik, only for movies, which makes sense.


    Thoughts?


    Btw, latest version is running fine, although I have kodi crashing sometimes, mostly when network is being used for updating epg (pvr) or other databases. WiFi throughput is awful slow, so I'm using wired LAN.
    I'll go and get the network chip's model and report back...

    * s905x, 2/8GB, Coreelec 9.2.1
    * RPi3, LE 9.2.0, GPIO IR
    * Server, kodi-headless, MySQL, VDR, NFS-Server (& much more)


  • Think you're almost there!
    There is one minor thing I noticed - if I disconnect the Ethernet and boot then when try to launch LibreELEC settings it posts error saying
    "LibreELEC settings not ready please try again later"
    but after about 30 s - 1 minute (this could be due to slow wireless connection) it will indeed open the settings;
    with ethernet connected the settings open immediately after boot.
    I have only tried about 5 boots but so far it has not required network access to be toggled
    Bluetooth is indeed working and I was able to successfully connect to a device which it found instantly
    (didn't even know it was in the room - one of my Mrs Fitbit type devices which it immediately found)
    Couldn't do anything with it of course, but at least it saw it & able to pair to it.


    I'll do some more boots to see if the WiFi consistently activates
    I'll also go ahead & put it on my 'loaded' system running 12a, and then can measure wifi speed

    Edited once, last by DEcosse ().

  • Just registered to say thanks kszaq . Went from sluggish Android firmware on my Beelink MiniMX 1GB/8GB to comparatively blazing fast LibreELEC. Used gxbb_p200_1G_1Gbit.dtb device tree and booted off microSD card using the toothpick method for anyone who is curious.


    EDIT: I also just donated, keep up the good work :)


  • If it's not too much to ask could you please compile your next build for 'installtointernal' directly as well. I need to update several friends MiniMX-G boxes that are using Alex's old 7.0.2.005 build and I would prefer to do so directly via recovery. Sorry if I'm out of line by asking, I appreciate all your hard-work greatly :)


  • 7.0.3.012b
    Great work kszaq
    Confirming Bluetooth Works.
    Wifi Hooks Up Every time without toggling.
    Wifi Speed has jumped to over 30mbps (Using 5g with an ac capable router over 20 metres away on another floor.)
    :)

  • I too just registered with the LE forum and am trying to put LE on my "Beelink Mini MXIII II Android 6.0 Amlogic S905X TV Box with Quad- core 64-bit ARM Cortex-A53 up to 2GHz Penta-core ARM Mali-450 RAM 2GB ROM 16GB" but am having trouble. I have two older Tronsmart TV boxes with openelec that I did not have issues flashing with the toothpick method. I have read the posts about how to do it, but I can't seem to get it right. I dl 7.0.3.012a to a folder and extracted it to an SD card, then copied gxl p212 2g.dtb to the SD card and renamed it dbt.img. I then used the toothpick method to reboot several times. I used a Lexar High Performance 32GB class10 SD card. I have attached a pic of the error from my TV screen. Can someone please point me in the right direction?


    Thank you,
    mike


  • I too just registered with the LE forum and am trying to put LE on my "Beelink Mini MXIII II Android 6.0 Amlogic S905X TV Box with Quad- core 64-bit ARM Cortex-A53 up to 2GHz Penta-core ARM Mali-450 RAM 2GB ROM 16GB" but am having trouble. I have two older Tronsmart TV boxes with openelec that I did not have issues flashing with the toothpick method. I have read the posts about how to do it, but I can't seem to get it right. I dl 7.0.3.012a to a folder and extracted it to an SD card, then copied gxl p212 2g.dtb to the SD card and renamed it dbt.img. I then used the toothpick method to reboot several times. I used a Lexar High Performance 32GB class10 SD card. I have attached a pic of the error from my TV screen. Can someone please point me in the right direction?


    Thank you,
    mike


    You might want to re-read the first post that explains it thoroughly.


    You need to burn the 7.0.3.012a image to your sdcard via Rufus then replace the dtb.img file on the sdcard, insert sdcard into device and boot with toothpick method. The method you are trying is to flash via recovery which is incorrect for 7.0.3.012a.

  • Thanks kszaq for the new 7.0.3.012b build.


    Just tried this on Nexbox A95X (amlogic S905X 2/16 gb)
    - now tvheadend server with my dvb-t2 usb (mygica t230) working flawlessly
    - will test more later, especially docker :)

  • Sadly I don't have the time to go over all of the LE threads for the S905X so I just wanted to post my findings so far and a few questions:


    I have a Vizio M60-D1, currently on 2.2.7.4 firmware. The box I got is a Sunvell T95M (2GB + 8GB), with a S905X processor.
    I got this box specifically for HDR and the possibility of having the front display in the future. Obviously right now it works in Android, but not in LE.


    To the issues I found so far:
    1) After a reboot, Kodi GUI is very dark until I start a video or IPTV stream. Once a video starts playing the GUI brightness goes back to normal.
    Now the other two issues I am not sure what's at fault, the TV or the box, but anyway:
    2) At [email protected] HDR does not engage. If I manually switch Kodi to [email protected] and disable refresh rate switching, I get HDR in 30FPS and 60FPS videos. 24FPS HDR video plays fine because it switches the TV down to 24Hz.
    3) At [email protected], 4K H264 files, such as this one. It plays, but there are a lot of artifacts (including Kodi OSD) going on the screen. It looks like parts of the image are being displayed in a different places on the screen. If I set it to [email protected] and disable refresh rate switching, the videos play perfectly fine. There's no problem playing 30FPS or 60FPS 4K HEVC files at [email protected]
    *) If you need me to run some tests, I can do that, so let me know. I'm currently on the (a) build, not (b). I don't use BT nor Wifi on this box, but it was able to pick up my and my neighbors WIFI routers, so I guess it works.


    Now to my questions:
    1) Does the box output 10bit 4:2:0 signal when displaying HDR? If not, what configuration does it use?
    2) I created a backup on my S812 box with LE on it, and after restoring the backup on the new box, at [email protected] and [email protected] the screen is cut off and the image looks like it's zoomed in. Is it possible to fix this without having to restore LE to defaults and configuring everything from scratch?
    3) What would it involve to get the front display on this box working in LE? I assume it uses some sort of driver, maybe it's possible to fish it out of the android that's still on the internal flash?


    kszaq
    I just wanted to thank you for the work that you do, I'm sure it takes a lot of time and effort.
    It's really impressive what can be done with $35-40 hardware.

  • I see in the first post the default download for LE is version A but i noticed there is a version B as well.
    What are the differences, which one should I be using. A, B, or the Temp Sensor version?


    I have a Tronsmart S95x.

  • I am using this on my Mini M8S (s905 version) 2GB and I keep having some problems.


    1.- The device takes a few tries to boot, sometimes it hangs on the "google tv" screen.
    2.- Once Libreelec is running it randomly hangs for no apparent reason, I have no add-ons installed, just a fresh install
    3.- The SSH and Samba servers die out of the blue as well, and I get disconnected, but kodi keeps working the the keyboard, they will work again after I reboot the device :(
    4.- When I choose "reboot" device always hangs.


    I am using the NAND install, but those same thing happened with the SD install as well :(


    I am using the dtb that came with the download as it was the only one that would let me use WiFi., do I need to try another dtb?

    Edited once, last by niabi ().


  • I also have this box and I use this dtb "gxbb_p200_2G_100M.dtb". It won't fix the boot problem but it should fix most of your annoyance.

  • I also have this box and I use this dtb "gxbb_p200_2G_100M.dtb". It won't fix the boot problem but it should fix most of your annoyance.


    Thank you, so you also have the booting problems?


    and also, do you know how to update the dtb on the nand without erasing everything? or do I have to do a fresh install? :)

  • I have built release 012 from source and when I boot it (from sd card on s905x 2gb/16gb) I get the LibreELEC logo and it's stuck.
    I don't get the "Partition is resizing" part.


    If I download kszaq build it works.
    I had the same issue with release 010.
    Release 009 works when I build it.


    I have built release 012 for "arm" arch.


    Any idea what direction should I dig ?


    Thank you in advance.

  • If you have an S905 Chip (Not a S905X)


    Read the Opening Page and use the below.


    Issues with booting? Freezes? Use a build with disabled temperature sensor:
    http://kszaq.libreelec.tv/s905/7.0.3.012...led.img.gz
    [hr]


    Sadly I don't have the time to go over all of the LE threads for the S905X so I just wanted to post my findings so far and a few questions:


    You might have tried to find 30 seconds of your time to read the Changelog and known issues which would answer the KNOWN issues you asked about.
    It would have taken you less time than writing all the observations you just wrote.

    Edited once, last by kostaman ().