[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Same for me, I connect to my NAS using WiFi and since mounting the NAS at the OS Level, I never had any issues, even on 50 Go HDR 4K files...

    Panasonic 50DX750F / HK 161 / Beelink MiniMXII S905X

  • Hi guys, apologies if this is posted in the wrong area, but does anyone have a link for the recent Nexbox A95X S905X updated firmware for 1/8 and 2/16. If so, would you please share.
    Many thanks.

  • Hello kszaq!

    I've been using your images for a while, thank you for developing them. It is actually my first post in this forum.

    I have 2 identical MX III S905 2GB mem boxes with Gigabit wired. Recently I've bought an GTX 1060 card for my main PC, which makes available to stream the desktop and/or the games from it to the boxes trough an addon called moonlight.

    I have only tried it on LE8 versions, but no luck so far. I attached today's debug kodi.log and some command line outputs from ssh.

    When i try to pair with my PC from GUI it shows the confirmation code
    When code typed into pc, box throws an error: Failed to pair to server, try again.

    Strangely, i can pair them trough commandline. Sadly the stream cannot be started, SDL is not build with video support.

    This week i tried to build the image from your git multiple times. I've modified the SDL2 .mk file, enabled video and video-opengles.
    I used an up-to-date Ubuntu server 16.04 in Virtualbox, but builds always fail somewhere in media_build. :(

    Is there a magic trick to build you image apart from "PROJECT=S905 ARCH=arm tools/download-tool" and "PROJECT=S905 ARCH=arm make image"?

    Thanks in advance

  • [hr]

    Thanks for the suggestion but I'm not sure that this would resolve the issue for me. I'm familiar with mounting network shares locally as I do it on another machine but this particular clip (jellyfish) is 528MB in size and is 30 seconds long. This works out at a sustained data rate of 17MB/s which is way in excess of what a 100Mb/s ethernet connection can handle. Typically you might get 10 - 12 MB/s max. I don't know if the jellyfish clip is typical of HDR samples or if it's not compressed properly, but a one hour version of the file would be 60GB in size. This would take about 90 minutes (rough calculation) to download, so you would have to buffer probably 30 minutes before starting to play the file to ensure you didn't "catch up" with the buffer. I have a couple of other 4K VP9 encoded samples which require sustained data rates of about 5 - 6 MB/s which is comfortably handled by 100mb/s ethernet. It's just this particular test clip that won't play for me. I don't yet have a 4k TV, so my interest is mainly in "future-proofing" but the downscaled output on my 1920x1080 TV is pretty stunning, nevertheless. Just like HD TV was when it came out about 10 years ago, before the broadcasters started reducing the bit rates :(
    Perhaps your file data rates are just marginally in excess of your network speed so that you don't have to buffer quite so much?

    Edited once, last by fat-tony ().

  • Fat Tony,

    I'll admit, I don't have anything that needs that much bandwidth. If you really are at the limit, wouldn't a USB ethernet dongle get you the test of the way there? USB 2.0 max speed is 480 mbs.

    Before I started mounting the nas at the os, this didn't help any, but I have a feeling it would if you did both.

  • albertstroh77 - I actually started researching UHD bit rates to see if that "jellyfish" video was a bit of an anomaly and it seems it is. Most of the high bit rate Blu Ray files won't exceed 66Mb/s (about 8MB/s) which would seem to be half the "jellyfish" bit rate. The simple, obvious, solution is to get an ethernet dongle!

  • Which USB 2.0 ethernet adapther works with the S905x and this Libreelec?

    Use adapters with this chipsets:
    USB2 - ASIX AX88178 works with LE and Android
    USB3 - Realtek RTL8153 works only with LE

    Network speed ~350MBit

  • Thanks, Tim. Good to know. I really want to get one, but I keep remembering nothing I have doesn't play. Guess I'll have to get one so I can play Tony's test file...

  • Oop's, maybe my bad but a newbie at this... although a long time computer person.

    Just got a Minix U1 and went to build an SD with LibreElec version and thought I had my ducks in a row.. have a working bootable USB that runs LibreElec with Kodi on this pc built with the Libre USB Creator tool.

    I believe I have downloaded the correct files:
    Downloaded the image - LibreELEC S905.arm-8.0-8.0.1j.img.gz
    Downloaded the device tree - gxbb_p200_2G_minix_u1.dtb

    Then it happend, I started the LibreELEC_USB_SD.Creator.Win32

    The first selection box has several options, generic amd/x86, Odroid,WeTek... but no option to select Minix Neo U1 ?

    What now.... is there a "kszaq" version available somewhere ?

    Minix U1 with A2-Lite

  • It happen every movie what i see. I tried with 23.97 and 24 fps movies, with or without subtitles.
    I cannot give you sample, because the official sample to small (only 1 minute), and the movie is big.
    Operation.Mekong.2016.1080p.x264.TrueHD.5.1 14.69 GB

    Finally, downloaded and watched the movie. I've copied the file to a SD card from which Libre runs.
    I can assure you, that the playback was very smooth with no jitter or visible frame skips. I've carefully watched the whole film, despite I didn't like it. ;)
    The audio track was decoded by the box itself (not passed through) .
    I'm pretty sure it was I/O throughput limitation of your device. Try to use another, faster SD or installing to internal storage.

    Edited once, last by alexeiyo ().

  • the first selection box is only for downloading images via the tool, if you select an already downloaded image in step 2 - as you need to with community builds - step 1 is irrelevant.

    Nexbox A95x (S905X) running kszaq's LE 8.1.10 build

  • 8.0.1i is working the best for me right now, after daily driving with both 8.0.1i and 8.0.1j.

    On 8.0.1i:

    Chapter seeking / skipping backwards is near 95% reliable. Every once in a while it hangs with the "buffer circle 100" in the middle of the screen, but it's very rare and very random. It happens during playback of the exact same file(s) it has previously worked, without issues, many times before. To get the video to resume playback without stopping it, you need to skip forward to (or past) the point in the video you were at, when you first tried to skip backwards. To me this says playback isn't completely hung, and as such should be possible to fix and make reverse skipping 100%.

    There are zero audio sync issues on my box, even YouTube live streams have good audio sync. I do not do anything PVR addon related on this box, so I cannot speak on PVR streams.

    There are zero buffering issues with live streams, YouTube live for example.

    I do not ever put this box in standby mode, nor would I want to, so I did not / do not test this.

    On 8.0.1j:

    Skipping backwards is 0% reliable again, as it was before @afl1's patches to 8.0.1i.

    Everything else, I couldn't see any significant differences with.

    So, on my setup, it is a choice between being able to skip backwards in a stream 95% of the time, or 0% of the time.

    I hope, @afl1's patches in 8.0.1i aren't completely abandoned, and some sort of middle ground is found, where we can both skip backwards 100%, and audio sync on other hardware / setups is also 100%.

    Wanted to share this, as I read through recent posts, it seems like almost everyone is using 8.0.1j, even if they don't do anything PVR related. I can see why both builds are advertised as being the latest in the OP, but I think a lot of users aren't understanding the difference.

    - Beelink M18 / S905 / 2GB / 16GB / 1Gbit
    - Stock Android 5.1.1 on 16GB Internal
    - LibreELEC 8.2.x [kszaq] on 32GB Samsung Evo+ microSD

  • Sometime after Libreelec started, Kodi Freeze out of TV with dimmed screen at startup and I must unplug and replug the powercord more than one time to solve the problem.

    I´m using right img.dtb and remote.conf for my tronsmart S95 Telos (S905) box.

    I Have two box connected via HDMI directly to different Samsung TVs and other connected to Denon AVRX-7200WA + Sharp Aquos TV

    All the box have same occasional Kodi Freeze problem.

    All version of LibreELEC 8.0.1 have this problem

    Is it Kodi Bug or LibreELEC bug?

    LibreELEC is installed to internal

    What can I do to solve this?

    Thankyou for your effort!

    Edited once, last by mrtr32 ().

  • I must say that this is the best OS/Kodi build I've ever used. I'm new to LibreElec and put 8.0.1j on my Tronsmart S95 Meta. I put it on the Meta b/c Tronsmart screwed me on storage. Somehow 8GB really means 4.8GB. I guess the box's bootloader is 3GB!!!?? Anyway everything is smooth and responsive on 8.0.1j. The only thing I've noticed that someone earlier mentioned is the backwards skip is unreliable. It only works on certain videos but I haven't isolated the files types and codecs that fail. For me it's about 50% which may be my mpeg h264 files. Most of my files are flv or avi. Starting the file from the beginning is the only fix. Other than that keep up the good work! At the moment I'm testing this on a second box as my main box (S95 Telos) is the only way to watch Netflix now. So will definitely be on the look out for bugs and such. Thanks.

  • Any idea if this device (very cheap) will work with S905X/LibreElec devices to speed up the connection?

    Chipset driver are built in LE -> adapter will work
    Not working in Android