7.0.2.008 build for S905/S905X

  • Yesterday I've received my first android tv box, Mini M8S II.
    I've installed latest developement build (2016-10-28) with gxl_p212_2g device tree on a microsd card and I'm very satisfied.
    Only problem I'm having is wifi not working. In libreelec settings wifi is active, but i cannot find ani ssid, and only cable network is working.


    I installed network tools and output of iwcofig is:


    LibreELEC:~ # iwconfig
    eth0 no wireless extensions.


    wlan0 IEEE 802.11 Nickname:""
    Access Point: Not-Associated
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 invalid crypt:0 invalid misc:0


    lo no wireless extensions.


    Can you please help me?


    Thank you in advance
    Luca

  • Might be the trouble, yeah. Cable and Router can't be blamed, as i can successfully connect my laptop with 1Gbit on exact the same cable/router setup. Must be a not so good soldered port then. Damned. :@


    Finally found a workaround for this with buying an usb-2-gbit adapter which successfully connects as eth1 with full gigabit speed :)


    (Second good value on that: i have a fixed mac adress again, as that adapter provides one.)

    cheers,
    azido
    System: Bqueel T95-Max TV Box | 2 GB Ram | 32 GB eMMC | Amlogic S905 Cortex A53 Qcore CPU 2Ghz | GPU Mali-450 5-Core | WLAN 2,4 & 5 Ghz | LAN 1000/100 Mbit
    OS: Android 5.1.1 on Nand |LibreELEC 8.90.4 Build on SD


  • I decided to "installtointernal" from a working SD card setup. Everything went really well and the box works great, except it only works if the SD card is left in the box. When I pull the SD card out there is an error on start up "To prevent an automatic repair attempt continuing - press any key to power off your system within the next 120 seconds.
    So is this normal once the "installtointernal" command is run in putty?
    Second question, I cannot get KODI on any of my boxes to play a full album. It will play the first song, but none after that. I have tried hitting the play button on the folder and it just opens the folder up. How do you get KODI to play all the music files in a folder?


    Can anyone comment re: the need to keep the SD card in the box after running installtointernal?

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.


  • Yesterday I've received my first android tv box, Mini M8S II.
    I've installed latest developement build (2016-10-28) with gxl_p212_2g device tree on a microsd card and I'm very satisfied.
    Only problem I'm having is wifi not working. In libreelec settings wifi is active, but i cannot find ani ssid, and only cable network is working.


    Hi Luca.


    The 1º step is identify the WIFI chip used.


    Try to use adb over android and updoad the dmesg to pastebin or similar service, do the same with Libreelec.


    Also paste the result of lsmod at LE to check the modules that are loaded.


  • Thank you CGarces.
    now my children are watching cartoons on libreelec (they are happier than me!!), so I can only paste LE outputs.


    dmesg: [ [email protected]] Initializing cgroup subsys cpu [ [email protected]] Linux version - Pastebin.com
    lsmod: Module Size Used by sha1_generic 2212 0 dhd - Pastebin.com


    As soon as I can switch to android, I will paste dmesg on android.


    Thank you
    Luca

  • Hi i have a95x 2/16g box...i am using an 8g old class 4 microsd card...shall i use a faster card to get better results ??


    Guys can anyone reply pls...does microsd card used make any difference ??

  • Has anyone noticed any pops/clicks like static on the audio since trying "LibreELEC-S905.aarch64-7.0-devel-20161028232312-r23412-g028df0e.img.gz"?


    S905 T95N 1GB/8GB/100mbit


    Connected straight to the TV using HDMI - changed to make sure it was HDMI output in Audio settings.


    I've gone back to .008 to see if it goes - probably didn't need to try the devel version anyway since everything is working well already!

  • Hi kszaq


    first of all, many thanks for your work.


    I've received a Mini M8S II (S905X, 2 Gb/8b) and installed the latest dev version from 10/28, with the correct dtb.img file.


    Everything works so far, but I can't install any extension/skin in Kodi (no error message, but I don't see how to browse the repositories).
    I'll try with 7.02.008 and report.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND


  • Here you can find dmesg from Android: [ [email protected]] Initializing cgroup subsys cpu [ [email protected]] Initializing c - Pastebin.com


    Thank you!


  • As a heads up: It seems like the Nexbox A95X with S905X chipset only features Bluetooth in the 2 GB RAM versions. The cheapest 1 GB RAM, 8 GB ROM version does not have Bluetooth built in.



  • I have not. The audio is way better for me on the latest build.


    NEXBOX A5 2gb/16gb s905x
    [hr]

    Guys can anyone reply pls...does microsd card used make any difference ??



    The bigger the better, I use 16 gb cards. I would say 8gb minimum. The more important thing is the speed and quality though I think.


    I use the fastest card. I think it has 10 m/bit speed.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Small issue with DNS resolver (I realized when using 'wget', every download was slow to start).


    Using 7.02.008 and DHCP, I don't get the correct DNS servers (the first one provided by my DHCP server is omitted) :
    # cat /etc/resolv.conf # Generated by Connection Managernameserver 37.187.0.40nameserver 185.10.203.37nameserver 37.59.72.228


    On a RPI2, which uses the same DHCP server :


    # Generated by Connection Manager
    nameserver 8.8.8.8
    nameserver 178.32.122.65
    nameserver 37.59.72.228


    Edit : well, my previous issue (unable to install an add-on) was related to the DNS resolver issue, now it's working fine :)

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

    Edited once, last by Fredouye ().

  • I need some help please. I'm trying to update my a95x (s905, 1GB/8GB) with the latest development build of 008. I downloaded and renamed to img.gz and dtb.img, put into Update folder via samba access, then reboot and I get an error saying "not find a valid system partition in image file" (see attached photo).


    I'm sure it's a stupid mistake on my part - any help will be much appreciated....

  • Just a random thing.. I played a movie today and noticed it was playing at 60hz instead of 24hz. A reboot fixed it. I'm guessing that my TV and amp need to be on before I turn the kodi box, otherwise it won't be able to query the display's capabilities at boot? Just a guess.


    I'm using the 2016-10-28 build, and my box is Beelink Mini MX 2G.

    Edited once, last by RowanDDR ().