[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • Did you change the device tree? I got stuck at the Vorke logo when I used a wrong device tree. The latest beta device tree for S912 3gb 1000Mps is wrong (see my post further up from 25 October).


    I used the following device tree from 6/18/2018 at the link below.


    gxm_q201_3g_1gbit.dtb


    Edit: wrxtasy can you confirm which are the correct device trees for boxes with S912 3GB mem and 1GBit Lan?

  • I ended up using the device tree from October 2017 which worked.


    The latest versions of this build and correct device trees should be on the first post of this thread, please update.

  • How do I update to LibreELEC-S912.arm-8.2.5.1-444-1000nits.tar? I have 8.2.4.1 which was used to create the image on my SD card and it worked But 8.2.5.1is a tar file and when I use it to create the SD card it isn't recognised in the computer any longer?

  • Hi,


    Just popped on to say thanks, upgraded from an old kszaq build to LibreELEC-S905.arm-8.2.5-Chroma.422.10bit and all is great.


    Using the new device tree I've bumped up the GPU, the GUI seems smoother now, also a big plus is the option to disable the interlace post processing. I have recently brought a Pi TV HAT and am using a Zero running TVHeadend to stream live TV, I was seeing the red artifacts in kszaqs builds that made it unusable really, all gone now !


    Thanks again !

  • ** POST REMOVED **

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

    Edited once, last by chewitt: we don't condone piracy ().

  • using as I do BS Streams

    ^ pirate stream crapware; all future support will be refused pending proof of a clean system.

    Edited once, last by CvH: removed streamname ().

  • Would be possible to update the title and first page to reflect the current versions available? Thanks :)

    Zenbox Z11 Pro 2G/16G - 100M LAN - Wireless AC Qualcomm QCA9377 1-stream (433 Mbps) - LE 8.2.4.2-Test2

  • Context :

    Currently running kzaq's latest build on a T95X (1G/8G, S905x) .
    I had to use the dtb image with temp sensor disabled to get it working.


    Question:

    If I want to run wrxtasy's latest build, what dtb should I use ?


    thanks

  • Can the KM8 Pro 912 box running LibreELEC handle switching between 1080P and 4K content? i.e. colour space switching which i keep hearing about?

  • I will for sure says, that according wiki and offcial information is 650 mhz maximum requered speed for gpu mali 450 on KI pro. Please add possibility for max 650 mhz, and not only 792 mhz. S912 have not mali-450, but it have Mali-T820 GPU on max 750 mhz!!!. Maybe also is it too much for cooling system! Graphics and Multimedia Processors | Mali-450 GPU – Arm Developer.

  • Hi hopefully somebody can help me.. I’ve been using wrxtasy build for a long time without any problems and for some reason I decided I would try out the coreelec build, it installed ok but playback was terrible so I copied over the wrxtasy image and dtb to the upgrade folder and restarted and it went through the process but I am now stuck on the mecool logo. I’ve tried creating a sd cars with the image creator tool and it is still stuck on the mecool logo. (My original install was installed to internal) I’ve looked and I can’t find any hard reset button. The device is a mecool m8s pro 3gb s912

    Anyone have any ideas?

    Thanks

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • Hi hopefully somebody can help me.. I’ve been using wrxtasy build for a long time without any problems and for some reason I decided I would try out the coreelec build, it installed ok but playback was terrible so I copied over the wrxtasy image and dtb to the upgrade folder and restarted and it went through the process but I am now stuck on the mecool logo. I’ve tried creating a sd cars with the image creator tool and it is still stuck on the mecool logo. (My original install was installed to internal) I’ve looked and I can’t find any hard reset button. The device is a mecool m8s pro 3gb s912

    Anyone have any ideas?

    Thanks

    Use the USB burning tool to get it back to android then install LE on eMMC

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Use the USB burning tool to get it back to android then install LE on eMMC

    Thanks for the reply! I couldn’t find a working link for the stock rom so I used the usb tool to install a custom nexus rom from freaktab, box now boots and is useable but I ran out of time so I havnt installed librelec yet but hopefully all will be ok now.. will definatly be sticking with wrxtasy’s build from now on!


    For anybody with the same mecool m8s pro 3gb s912 box there is a hard reset button on the bottom of the board you have to remove the case and the board to access it (6 small Philips screws in Total)

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • Hello,


    I didn't read the whole thread so forgive me if the answer is there, but I couldn't find the github repo from where the 8.2.5 version of the image has been built.

    I looked at this repo GitHub - wrxtasy/LibreELEC.tv: Just enough OS for KODI (supposing that's the same wrxtasy) but the most recent branch there is 8.2.4.1 updated 7 months ago, while the image I'm using is (on a mecook ki pro) LibreELEC-S905.arm-8.2.5-Chroma.422.10bit.img.gz which is newer (I think).

    The image as is works fine, but I need to use vdr instead of tvheadend and the provided version doesn't work with dvbapi. I also need a home brew vdr plugin. I wouldn't like to build the vdr addon with the wrong source tree.

    Edit: Oh, and what's the correct PROJECT to use once I have the correct source tree?

  • Quick question if anyone could answer it would be appreciated.

    I have version 8.2.5 running very smoothly on my Tanix TX3 Max.


    The infrared remote it came with is not very useful so I was looking to replace it.

    I tried turning on Bluetooth & put my my FireTV remote into pairing mode but it does not come up as an option to pair.


    Is Bluetooth not working on this version?


    Thank you

  • First off, thanks to wrxtasy for the work on this build.


    I think I'm having trouble getting HDR content to show. I'm new to the HDR world, as I just got a TCL 6-series TV (R615). Using test clips, built in to the TV, I can get the "Dolby Vision" and "HDR" notifications to show.


    However, on my Minix I'm running "LibreELEC-S912.arm-8.2.5.1-444-1000nits", and I can't get these notifications to show when playing (supposed) HDR files. So I'm not sure if HDR is working.


    I got the clips from 4kmedia.org, like this whale clip:

    Sony: Whale in Tonga HDR UHD 4K Demo | 4K Media


    It certainly doesn't help that these clips seems to have HDR/4k notifications baked into them. So at first I thought all was good, until I realized by pausing, or fast forwarding, that it was stamped in the clip, and not the TV itself displaying the tag.


    I'd appreciate any help figuring out if HDR is actually working from my Minix setup to my TV, and if not, what I should be looking at to fix it.


    Thanks.