[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • I get a lot of jerkiness watching RTSP IPTV streams using Tvheadend .

    Frame drops/skips until buffer fills up to 20% and above, usually it starts playing right from 3-5%

    Any chance of fixing this?

  • I am not talking about included libretro, this is a way to run optimised lakka retroarch alongside kodI basically


    kodi emulators, at least in the case of pcsx rearmed, are unusable...probably has something to do with why lakka s905 pcsx rearmed os over 1mb when kodi uses generic one that is around 500kb

    Hi.


    I have some free time to work on Libretro addons.

    Can you detail the errors that you have and the addons affected?

  • Actually I backported the fix from Leia to Krypton but you are correct - the code is present in Leia source unless it was changed later at some point.

    Thanks kszaq.


    I guess something's been changed in Leia as the behaviour is different between Krypton and Leia.

  • Thanks!

    It is nothing urgent, just a desire to have control over which version we update to.

    Beelink MiniMX III 2GB/16GB gigabit LAN
    LibreELEC running from SD card (will confirm version on post).

  • Thanks!

    It is nothing urgent, just a desire to have control over which version we update to.

    I will look into this, it's a relatively easy change to make.

    On another note, a new version has been uploaded v1.0.7.1 unfortunately this will require a manual upgrade as I broke automatic upgrades in 106 by moving the patch for LE-settings. Just place the update tarball in the update folder and reboot.

    This version includes the latest version of Kodi source and the RTL8723DS wifi driver and of course the latest changes in the LE master branch.

  • I will look into this, it's a relatively easy change to make.

    On another note, a new version has been uploaded v1.0.7.1 unfortunately this will require a manual upgrade as I broke automatic upgrades in 106 by moving the patch for LE-settings. Just place the update tarball in the update folder and reboot.

    This version includes the latest version of Kodi source and the RTL8723DS wifi driver and of course the latest changes in the LE master branch.

    1.0.7.1 videos work all over again, only problem im still having compared to 1.0.5 is retroarch, cos included librerto support is still way off, maybe when there is a good frontend for launching roms, but doing it from included file manager, especially if its in bin, cue, and other cd files(as it just wants to play them as audio) is not viable. and still no reicast in kodi as well. ive put a file that is supposed to terminate kodi on retroarch start and that has done just so up to version 1.0.5. the line in question are near the bottom of the file, if you could check it out it would be great


    nevermind, it terminates kodi now, just fixed itself after several tries...now i only need to find out why audio is not working even thou it works in all versions up to 1.0.5

    Files

    • retroarch.zip

      (1.82 kB, downloaded 96 times, last: )

    Edited once, last by grimyhr ().

  • I will look into this, it's a relatively easy change to make.

    On another note, a new version has been uploaded v1.0.7.1 unfortunately this will require a manual upgrade as I broke automatic upgrades in 106 by moving the patch for LE-settings. Just place the update tarball in the update folder and reboot.

    This version includes the latest version of Kodi source and the RTL8723DS wifi driver and of course the latest changes in the LE master branch.

    This version also does not play the video file I sent you a few weeks ago.

    Beelink MiniMXIII II 2GB, 32GB always running latest Libreelec from SD card. No issues so far(except for the ones already known or posted by me).

    Mecool m8s Pro+ which with widevine level 1, Android runs a hacked version of android TV.

  • 1.0.7.1 videos work all over again, only problem im still having compared to 1.0.5 is retroarch, cos included librerto support is still way off, maybe when there is a good frontend for launching roms, but doing it from included file manager, especially if its in bin, cue, and other cd files(as it just wants to play them as audio) is not viable. and still no reicast in kodi as well. ive put a file that is supposed to terminate kodi on retroarch start and that has done just so up to version 1.0.5. the line in question are near the bottom of the file, if you could check it out it would be great


    nevermind, it terminates kodi now, just fixed itself after several tries...now i only need to find out why audio is not working even thou it works in all versions up to 1.0.5

    CGarces may be able to offer some help here, I can only assume it's one of the packages that has been updated if it's broken as they have all been recently updated to their latest versions or a configuration problem.

  • CGarces may be able to offer some help here, I can only assume it's one of the packages that has been updated if it's broken as they have all been recently updated to their latest versions or a configuration problem.

    never mind, it all fixed itself after several restarts and alot of tinkering, dont even know what fixed it in the end, tnx anyway

  • never mind, it all fixed itself after several restarts and alot of tinkering, dont even know what fixed it in the end, tnx anyway

    Glad to hear it's all working for you now :)

  • just wondering if anybody is familiar with the error below, sometimes when i click on a file, it doesn't play. when i check the logs only error is that line. its quite random, not sure if its specific to LE9 but I don't get this when running LE8.2


    ERROR: CDVDVideoCodecAmlogic::Open - InstanceGuard locked

  • tried it LibreELEC-S905.arm-8.2-8.2.1.1-temp_sensor_disabled.img.gz did not work. The firmware is stitched into the internal memory.

    Try the .tar

    Sometimes .gz will not work for downgrade

  • just wondering if anybody is familiar with the error below, sometimes when i click on a file, it doesn't play. when i check the logs only error is that line. its quite random, not sure if its specific to LE9 but I don't get this when running LE8.2


    ERROR: CDVDVideoCodecAmlogic::Open - InstanceGuard locked

    THX for reporting. I found bug in DVDVideoCodecAmlogic. I'll fix it in next release.

  • THX for reporting. I found bug in DVDVideoCodecAmlogic. I'll fix it in next release.

    tnx for looking into it. not sure if it helps, but it seems to happen frequently on standard resolution files when I have hardware decoding set to always.