[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Are addons like TuneInRadio counted as Piracy?

    I don't believe an addon based on an official Android / IOS Application would be classified as a piracy.

    Read here to help you more.

  • Can anyone help with what is likely a simple solution that is evading me. Using my Beelink MXIII II 2G/16G box running 8.2.2.3 build from a Class 10 SD card. Have recently got a new TV a LG Super UHD set and have set my KODI system to the UHD resolution 3840 x 2160 and all is well playing some 4K streamed content too. However now when I switch to Android using the Reboot from Internal option I get the normal Android start up to the home screen and then a few seconds later I get the spinning wheel working icon and the picture is suddenly zoomed right in as though I was sending a UHD resolution to a FHD screen. So I only seeing a distorted quarter of what should be the Andorid home screen filling my UHD TV display.


    So anyone got any ideas why this is so and how to cure it ?? I am sure it worked to the new TV okay when I first tried it out to the new LG set. Much appreciate any help here as clearly some parameter has changed but difficult to get into the Android settings with this screen display problem. If I get tiem to click on the Settings option it does go to the Setrtings screen but unusable as the screen display gets massively zoomed. Sure Android is fine it seems when I tried it the same way on my Tanix TX7 box which is configured the same as the Beelink running LibreELEC KODI 17.6 off of an SD card

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

    Edited once, last by RayW: typos ().

  • For the Ambilight and Hyperion backlighting, I connected to the Arduino UNO R3. If I set the baud rate to 115200, then everything works fine, but slowly. If I set the baud rate to 460800, the Hyperion log shows an error opening the RS232 port.


    Works and does not give an error unless the baud rate is set to 115200. At any other baud rate values, it gives an error and Ambilight does not work.


    Is it possible to correct the error and make it possible to use the baud rate more than 115200?

    How can I fix the error and set the baud rate to 460800?

  • doc_bravn


    You'll need to modify the Hyperion firmware on the arduino, if you have the source, to match the baudrate you want to use.

    Please read this reply to make sure that you pick a frequency that will work reliably with the arduino.

  • Using my Beelink MXIII II 2G/16G box running 8.2.2.3 build from a Class 10 SD card. Have recently got a new TV a LG Super UHD set and have set my KODI system to the UHD resolution 3840 x 2160 and all is well playing some 4K streamed content too.

    Why are you doing this ?

    All it does is heat up the GPU portion of the Chipset unnecessarily drawing 4K pixels onscreen. The user interface is likely slower as a result as well.


    AML 4K LE Kodi Krypton is designed to run at a 1080p Kodi user interface, so your 4K TV with it's superior 1080p > 4K picture upscaling hardware produces a sharper picture when viewing anything 1080p on a 4K TV.


    If Kodi refresh switching is set to Start/Stop any 4K content you watch will trigger an auto resolution switch from 1080p to 4K anyway for true 4K output.

  • You'll need to modify the Hyperion firmware on the arduino, if you have the source, to match the baudrate you want to use.

    Please read this reply to make sure that you pick a frequency that will work reliably with the arduino.

    In the sketch for arduino the baud rate is 460800. In Hyperion settings, I also set the baud rate 460800. In the log Hyperion gives an error opening the port. I set the same baud rate in both the sketch and the Hyperion settings. It works only if I install the baud rate 115200 in the sketch and in the Hyperion settings the baud rate is 115200.

    On all other values of the baud rate does not work and gives an error in the Hyperion log.

  • In the sketch for arduino the baud rate is 460800. In Hyperion settings, I also set the baud rate 460800. In the log Hyperion gives an error opening the port. I set the same baud rate in both the sketch and the Hyperion settings. It works only if I install the baud rate 115200 in the sketch and in the Hyperion settings the baud rate is 115200.

    On all other values of the baud rate does not work and gives an error in the Hyperion log.

    I can hardly remember when was the last time I worked with an arduino in general, and serial specficially, but there could be something else that forces the arduino into 115200 baud rate. You should be using baud speeds that are fully supported by the library the sketch uses. Why have you chosen this specific baud rate? 460800 doesn't sound like something I heard about in the serial world. Try to stick to baud rates that are more 'standard'.

  • Thanks for your feedback wrxtasy. I set the default res in KODI to 3840 x 2160 as I so when availabel stream in 4K content and I noptice it also auto switches on the HDR on my set where it is HDR content. So are you saying that if set to FHD res then when a 4K content is being screened it automaticlaly switches the dispaly output to 3840 x 2180 ?? I do set my KODI refresh rate to Start/Stop already. I was unaware this would change the reosolution automatically to 4K if 4K content is being streamed. So I will try that and you reckopn I will get a better result with 1080 and 720 content by leaving the TV 's more advanced system to do the upscaling. What I did not want is for my 4K content to be downscaled to 1080 and then the TV updscalign it back up to 4K.


    Do you think this is the cause also of the Android screen corruption ? I will find out soon no doubt when I change the default KODI res to 1080p

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • I doubt it would work, but because of the remote control changes, it would be best a start a fresh install on a separate usb drive

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)