[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • thx. not the answer I would have liked.

    I have another solution You would not like

    Philips TV with ambilight - working perfect

  • I have tried few months ago and there was problem with grabber. Kodi checker was not working correctly and led were all the time on even in menu. I guess I will give hyperion another try during Christmas.

  • When I press the "Info" button on the remote of my UH6100 it indicate BT.2020 on my HDR content and nothing on my SDR content. So I presume if it is not specified BT.2020, it's BT.709.


    If I put the "echo 444,10bit ..." command in the autostart, 4k SDR and HDR contents is BT.2020. Personnally I don't like BT.2020 colorspace on non BT.2020 contents, color is too saturate... I test it a lot of time.

    Exactly. I will have to test this on my Vizio and see what it does, but LG does seem to behave this way when you enable 10 bit 444 output.

    It's a bit frustrating. When 10bit is not enabled, and I play HDR10 content, even though the TV switches into HDR/BT.2020 mode, color saturation is lacking. I made side by side comparison by playing the same content with the internal player. Once I switched 10bit 444 on, the color saturation is the same with HDR, but then SDR is oversaturated. So the only workaround I came up with is to enable 10bit 444 when I want to watch a HDR movie, and then switch back to 8bit 444. A bit of a pain.


    By running Kodi in 2160p and 444 10bit, I have the same picture settings on my TV for HDR and SDR, accept for the color saturation, this is about 10 clicks higher on HDR. And if your TV is adjusted right, you'l see that HDR is overrated;)


    But if i set Kodi to 1080p, there is no way I can get the same picture as with 2160p on 1080p content, But this might have something to do with the way my TV handles UHD and HD.


    And since my TV has different profiles for HDR and SDR, the settings are applied automatic when changing source between HDR and SDR:)

    The only thing you achieve by doing that is screw with how the TV displays normal SDR content.

    1. You can't do that by eye with accurate results.

    2. This will screw up SDR for other sources if you use the same picture setting across sources.

    3. Why would I want to do that?

    4. HDR is not overrated at all. It highly depends on the content you watch, and the quality and the capabilities of your display.

    Some movies are just not that much different to their SDR counterparts.


    If you ask me personally - I have no idea. ;) Use what looks better to your eyes.

    Is there any way to determine the type of content being player (ie. SDR/BT.709 or HDR/BT.2020) and automatically switch 10bit 444 on and off during the automatic resolution/refresh rate switch? Not being able to do this right now is probably a low priority, but I think that in the long run it's an important one. Please see my reply to mike in this post.


    And another, unrelated, question. I use live TV with the IPTV PVR addon. Now this addon only supports a single playlist.

    There's a fork of the IPTV addon, which allows using up to ten playlists. This would be a very useful addition (perhaps optional? I don't know) to your already great builds. Here's what I'm talking about: pvr.iptvsimple/pvr.iptvsimple at master · AndreyPavlenko/pvr.iptvsimple · GitHub

  • kszaq And one more request, looks like GDPR-2 has added support for the LCD display on the TX3 Mini. I have a T95M, with the same display.

    I was wondering if it would be possible to add this to your builds as well, or install it later (I assume there needs to be a driver for the LCD + updated tree?)


    Happy Christmas everyone!

  • What is the current recommended commands to enter for 'RGB FULL' 4:4:4 HDR?


    1. Enable RGB Full


    2. Enable 4:4:4 chroma for HDR


    3. Any relevant HDR settings/commands I have forgotten to list.



    Newest changelog says the output_rgb feature was re-added. I tried echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb but get no display on either of my RGB monitors. Tried adding to autostart and rebooting but same result - no display. Passed colorspace manually via TV but same result (no display after LE bootup). Hopefully I am just missing something.


    We should consider adding this kinda stuff to the main page, as the "method" to change these settings has been dropped numerous times, as well the command syntax has changed between releases.


    Merry Xmas to everyone!

  • hi, i cant get librelec working on my mxq pro 4k box with the new 905w cpu, it boots fine but all the usb slots dont work, i have tryed all the dtb files, still no luck. any ideas? cheers

  • Ever since I figured out how to get my TV to show the signal it is getting at a HDMI port, I haven't been able to get LE to pass through 720p content without upscaling it to 1080p. I've made the GUI resolution 720p, and tried various combinations of "Adjust display rate" and "Sync playback to display" in Player Settings.


    Have I missed something? I'd like to compare the TV's upscaling to that of my S905W box running 8.2.1.2


    Thanks.

  • hi, i cant get librelec working on my mxq pro 4k box with the new 905w cpu, it boots fine but all the usb slots dont work, i have tryed all the dtb files, still no luck. any ideas? cheers

    S905W its not supported i think...

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • Nope, not ‘officially’.

    If it sort of works you are in luck

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

  • HI there,

    I have an mecool m8s pro+ s905x 2gb that i purchased recently. it is of the 'bad batch' of emmc. so im running 8.2.2.1 kszaq temp enabled version of libreelec from an sd card. with correct dtb.


    all is great, apart from some odd intermittent crashing i've been noticing. I am using a airmouse to navigate, and it locks up having to restart the box by unplugging the mains. any ideas what is causing this? When the box crashes, freezes, restarts itself then the cursor/navigation and airmouse is unresponsive until box is unplugged and restarted that way. can work perfect for a day, then crash once or twice.


    I have managed to finds some logs and uploaded them here libreelec logs if someone could take a look who understands these files, and could shed some light as to why it crashes i would really appreciate it.


    kind regards

  • Anyone gotten the onboard IR receiver working on the LePotato (905X) ? I do not have a NEC RC5 remote, so I tried using my trusty old HP MCE Remote, but I cannot get it recognized by remotecfg. Tried enabling LIRC in LibreElec but /dev/lirc0 is never created. Is meson_ir module required?

    And yes, I have lost the IR->USB receiver.

  • Redferne Try this: open boot.ini on your eMMC/SD card and replace

    Code
    1. if test "${amremote}" = "1"; then fdt set /meson-ir status disabled; fdt set /meson-remote status okay; fi

    with

    Code
    1. if test "${amremote}" = "0"; then fdt set /meson-ir status okay; fdt set /meson-remote status disabled; fi
  • change regulatory domain for Broadcom WiFi to EU to cover more 5GHz channels

    kszaq my TX7 (signature) auto updated 2 days ago to 8.2.2.1

    Because i use ethernet i did not check wireless until today when i checked the changelog.

    Unfortunately my 5ghz wifi network has disappeared with 8.2.2.1

    I downgraded to 8.2.1.2 and my 5ghz wifi network reappeared.

    I did some googling on Australia channels but got nowhere in my limited understanding of what the EU difference is.

    I did not play with settings in my router to try solve this as i await your thoughts.

    Screenshot of router settings.


  • I actually tested by setting amremote=1 but kept the original "if test.." line on a previous attempt. Couldn't say I saw any different behavior. But then again.. I have fiddled alot with remote.conf and toggled LIRC on/off several times, I probably broke something ;-) I could actually see some kernel prints from "remote:" so the IR receiver is working but it seems to be limited to the NEC protocol?


    Anyhow on a different note. I tested your latest build LibreELEC-S905.arm-8.2-8.2.2.1-LePotato.img.gz but It does not boot. Found out the hard way since it auto-updated and on next boot the Potato was dead ;-) Checked console UART and it fails in U-Boot, something about "not a valid dtb". So I tried to replace the working dtb.img but there was no difference. Just to let you know! Thanks for the builds! Everything else is just great!

  • I got a Mecool K1 Pro (s905D) running this LibreELEC on a usb stick on first try, but how do I get the DVB-S2 Tuner to work?

    I've been reading for hours and can't find anything about it despite some comments on how good it works.

    Can anybody give me a hint?