[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Hi, I just installed this on my A95X. Everything is working without issue except for some reason, when I try to install 'RTMP Input' and 'InputStream Adaptive' video player InputStream addons, I get "Installation Failed". It wasn't a problem on previous builds. Any ideas?

    Please wait a bit, addon site is being moved to a different hosting.

  • Hi Kszaq, Yes that must be the issue. I was thrown because I'd installed the TVHeadend addon just beforehand.

    Thanks, I'll be patient and wait for the site to move over.

  • Hi guys


    I'm running into problems to make network connection work, cable or wireless. Both method keeps waiting dhcp forever (I've tested it in two different network with different params ie netmask and so). Stactic config, also, doesn't connect. The player I'm using is from Hungsung, 1G/8G/S905. All the other peripheals seems to work fine. I've tested all the dtb files avaialable at Index of /s905/8.2/device_trees/S905.

    Please could you give some advice on how to test it further?

    Also wireless is able to detect available networks and cable shows correctly when I plug or unplug rj45 connector.

    Good point:), I will give it a try later

    Using an external USB/network dongle works flawlessly, but using the on board ethernet doesn't work (same for wireless)

    Any help will be welcome:/

  • Using an external USB/network dongle works flawlessly, but using the on board ethernet doesn't work (same for wireless)

    Any help will be welcome:/

    Either the NIC is faulty,

    or, most likely, there is no proper firmware for it, yet.


    Provide us with the output of these commands, for start:

    Code
    1. dmesg | paste
    2. ifconfig -a
    3. iwconfig
    4. ethtool eth0
    5. udevadm info /sys/bus/sdio/devices/sdio*
  • Either the NIC is faulty,

    or, most likely, there is no proper firmware for it, yet.


    Provide us with the output of these commands, for start:

    Code
    1. dmesg | paste
    2. ifconfig -a
    3. iwconfig
    4. ethtool eth0
    5. udevadm info /sys/bus/sdio/devices/sdio*

    Thank you ChimeyJimmey

    About the NIC faulty... it works using Android

    Code
    1. LibreELEC:~ # dmesg | paste
    2. http://sprunge.us/HgVR
    Code
    1. LibreELEC:~ # iwconfig
    2. -sh: iwconfig: not found
    Code
    1. LibreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio*
    2. P: /devices/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
    3. E: DEVPATH=/devices/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
    4. E: DRIVER=rtl8189es
    5. E: MODALIAS=sdio:c07v024Cd8179
    6. E: SDIO_CLASS=07
    7. E: SDIO_ID=024C:8179
    8. E: SUBSYSTEM=sdio

    I've take a look to the @szaq git and, if you give some advices, I could try to generate the image with the proper drivers. BTW, the image building process is started with a command like this "PROJECT=S905 ARCH=arm make image"?

  • Please wait a bit, addon site is being moved to a different hosting.

    Is there an ETA?

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • Thank you very much, kszaq !


    Now, the reason I was anxious to test was the problem with Sundtek-Sticks described here. Are you aware of this? Because I have the exact same issue with my Sundtek Media TV Home/Pro Sticks, which is quite annoying. Fortunately, the cheap XBOX ONE tuner works with your build, so I can test with that, but it has nowhere near the quality of the Sundteks. And, since those are "sunk cost", I would very much like to be able to use them with the China-Boxes ...


    If you want, we can take this up further in the linked thread and I would be happy to provide any information you might want.

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • Selectaa static config already test it. Doesn't work

    So then the problem isn't DHCP related, but basic connectivity. I'd try a USB NIC if you can get your hands on one, just to confirm that it works then. You should also try with a different cable and check that nothing is stuck in the LAN port of your device.

  • Thank you very much, kszaq !


    Now, the reason I was anxious to test was the problem with Sundtek-Sticks described here. Are you aware of this? Because I have the exact same issue with my Sundtek Media TV Home/Pro Sticks, which is quite annoying. Fortunately, the cheap XBOX ONE tuner works with your build, so I can test with that, but it has nowhere near the quality of the Sundteks. And, since those are "sunk cost", I would very much like to be able to use them with the China-Boxes ...


    If you want, we can take this up further in the linked thread and I would be happy to provide any information you might want.

    Please open a separate thread and attach logs.

  • Hi guys


    I'm running into problems to make network connection work, cable or wireless. Both method keeps waiting dhcp forever (I've tested it in two different network with different params ie netmask and so). Stactic config, also, doesn't connect. The player I'm using is from Hungsung, 1G/8G/S905. All the other peripheals seems to work fine. I've tested all the dtb files avaialable at Index of /s905/8.2/device_trees/S905.

    Please could you give some advice on how to test it further?

    Also wireless is able to detect available networks and cable shows correctly when I plug or unplug rj45 cconnector.

    I had similar problem.

    Set static IP in Windows. Create login and password (you can set automatic login later)

    In LE change DHCP to manual.

    Now manually add SMB Location (enter Windows IP you set and login / password you created).

    Done.

    Shares will be visible.

    TX5 PRO S905X

  • So then the problem isn't DHCP related, but basic connectivity. I'd try a USB NIC if you can get your hands on one, just to confirm that it works then. You should also try with a different cable and check that nothing is stuck in the LAN port of your device.

    Selectaa as said before USB network adapter already tested and working flawlessly. I think that the best bet is what ChimeyJimmey said in his post. I'm waiting for his indications.

  • Please open a separate thread and attach logs.

    Done

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • cp projects/S905/linux/linux.arm.conf projects/S905/linux/linux.aarch64.conf should be enough IIRC.

    and to build any addon use

    Code
    1. PROJECT=S905 ARCH=aarch64 ./scripts/create_addon <any_addon>

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo