LibreELEC 8 community 64bit kernel 32bit libs | TVheadend Scan Problem

  • Hello everyone!


    I have to say that i use a LibreELEC build from Raybuntu from the forums at odroid.com but this issue seems tvheadend relatet I am posting in this forum - I got the hope you can help me with that.


    The Link to the Thread at odroid-community:
    http://forum.odroid.com/viewtopic.php?f=144&t=24753&start=450#p176211


    Hardware: Odroid C2 / Sundtec Media TV III (DVB-C/T/T2)
    Software: LibreELEC 8 community 64bit kernel 32bit libs - => this one: LibreELEC-Odroid_C2.arm-8.0-beta1i


    Problems:
    - Live TV with Sundtec Media TV III => DVB-C not working - scanning/tune at tvheadend is broken.
    - At Tvheadend config page there is ony the DVB-C showing up (no DVB-T)


    Here is the log of tvheadend:
    ORRY


    I already did the following tests:


    can you help me getting this working please, would be really awesome!!!
    btw.: the last realease for Odroid C2 (64bit) works fine, i just want to use 32bit version in future.

    Edited once, last by andy5macht ().


  • I got some more outputs!
    I hope this http errors gives some talented people a hint ;)


  • I got some more outputs!
    I hope this http errors gives some talented people a hint ;)


    andy5macht No new information. Can you enable trace for linuxdvb and diseqc?

  • Ok, thank you for testing. I'm not able to locate the error. I'm oretty sure something is wrong with the ioctl patch but error=Success is not very helpful to locate the problem. My Sundtek DVB-S2 works but it seems like this is a DVB-C/T specific problem.

  • I will try today (sorry for late reply) as i am back to 32bit builds right now ;)


    edit: still not working - same error

  • If it's possible for you could you try a fresh install of my leia builds and install the sundtek driver from my repo?

    MEGA

  • If you have no DVB-C signal, DVB-C scans will not find any services.


    For DVB-T, in Tvheadend at the Configuration - DVB Inputs - TV adapters page, click on the first line showing an IP address then in the right hand pane select DVB-T as the network type and then Save the selection at the bottom.


    Then check that the individual tuners are enabled by clicking on them. Amend as necessary and save any changes you make.


    Edit the DVB-T network under the Networks heading and select the correct muxes. Wait until the mux scans are complete, check that all your muxes are included in the pre-defined group and map the services found.

  • Great. Should be working with my new Krypton too. You just need to install fresh I think.

  • @Raybuntu What was the issue here? I am using community builds from kszaq and I am experiencing the same issue, that all seems to be fine, sundtek tuner shows up in tvheadend, just that scanning is not possible. Maybe you can help out here?


    Thanks for your great support here :)

  • Not sure if your issue is related especially without a log. Normally kszaq and me sync our code.

  • Not sure if your issue is related especially without a log. Normally kszaq and me sync our code.

    Thanks for the quick response, I attached another tuner and deinstalled the sundtek addon, now all is fine :)

  • Not sure if your issue is related especially without a log. Normally kszaq and me sync our code.

    I'm experiencing the same problem also with a Sundtek DVB-S2 tuner (Skytv ultimate v6) on this build:

    Code
    1. LibreELEC-S905.arm-8.2-8.1.9-C2.img.gz 23-Sep-2017

    The error it gives:

    Code
    1. 2017-10-03 13:26:21.951 mpegts: 11804V in Thor 0.8W - tuning on Sundtek DVB-S/S2 (VI) #1 : DVB-S #0

    Code
    1. 2017-10-03 13:26:23.512 linuxdvb: Sundtek DVB-S/S2 (VI) #1 : DVB-S #0 - DTV_CLEAR failed [e=Success]

    I've tried also with :

    driver.dvb.sundtek-mediatv-8.1.103.zip

    driver.dvb.sundtek-mediatv-9.0.4.104.zip


    Do you have a solution?



    Also, locking with mediaclient seems to work:

  • I've removed it and manually installed it from this zip file:

    Code
    1. driver.dvb.sundtek-mediatv-8.2.103.zip 14-Sep-2017 07:28 1249416

    Index of /addons/8.2/S905/arm/driver.dvb.sundtek-mediatv/


    I have the same issue.

    (I've created symlinks for systemd, enabled it. The tuner shows up in tvheadend after this, but i'm getting the same error:


    Code
    1. 2017-10-04 13:02:42.151 mpegts: 11804V in Thor 0.8W - tuning on Sundtek DVB-S/S2 (VI) #1 : DVB-S #0

    Code
    1. 2017-10-04 13:02:42.152 linuxdvb: Sundtek DVB-S/S2 (VI) #1 : DVB-S #0 - DTV_CLEAR failed [e=Success]