[] LibreELEC 8.2 for S905/S905X

  • Hello,

    today I tried to update my MXQ pro 4k from version 8.0.2b (I think) to version 8.1.9.

    My first try with SD-card failed. I used LibreELEC-S905.arm-8.2-8.1.9.img.gz and the dtb-file for MXQ pro 4k.

    The MXQ freezes while displaying the boxes start-logo.

    Then I tried to update via SSH with the same image.

    Now the box freezes also at the start logo. Nor libreelec neither Kodi is loaded.

    I think the LibreELEC-S905.arm-8.2-8.1.9.img.gz file is not working on the MXQ pro 4k.

    Where can I find an older Version to repair my box?

  • [8.1.9] LibreELEC 8.2 for S905/S905X

    then go to the parent folder

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass


  • It worked!

    I went back to 8.0.2b.

    Thank you for your help and the link.

    I looked atkszaq.libreelec.tv and there were no older versions...

  • Is there any way to disable V-Sync?

    Remove v-sync in kernel, compile kernel.

    Just out of curiosity, was there anything worthwhile in my debug logs regarding my startup issue?

    I don't remember looking at any logs from you, perhaps it's better to create so that it's not buried under 10s of other posts? Another thing is that I won't have much time to provide support in coming days/weeks.

  • Remove v-sync in kernel, compile kernel.

    I don't remember looking at any logs from you, perhaps it's better to create so that it's not buried under 10s of other posts? Another thing is that I won't have much time to provide support in coming days/weeks.

    Okay, I'll create a new thread in a week or so. It's just a minor nuisance, my box won't boot 9 out of 10 times. :D;)

    Seems like a warm boot doesn't always work. It show the libreelec splash screen and then nothing. No network, no Kodi ... have to unplug the power. Cold boot always works though.

    If it ain't broken: break it, fix it, repeat

  • updated 64bit image with some addons built from kszaq 8.1.9 git tag to LE – Google Drive

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Remove v-sync in kernel, compile kernel.

    Good one! ;) The reason I ask is because I discovered something that was a big surprise in Jarvis. I've mentioned about it some while ago but without response.

    There's a setting in Jarvis regarding Vertical Sync (enabled, disabled, enabled during playback and let the driver decide).

    Few weeks ago I've set this to disabled, restarted the box and I just couldn't believe how fluent and more snappier the GUI becomed, without any tearing. It's extremely fluent. And it has no influence to videos. They still play flawless.

    All sceptics, you can check for yourself.

    Really, it's like having Snapdragon 835 inside this Chinese box now.

    I'm just curious if the same trick would speed up GUI in Krypton which does not have this option but maybe it's not kernel related.

    TX5 PRO S905X

  • Yes, same here. I've checked all the other DTS HR files and none of them plays. Strange. Last time I checked everything was OK.

    Haven't figured out it yet completely, but now I can play this movie on all the LE versions if I play a 192kHz DTS HD MA track just right before it.

    And then all the other DTS HD HRA stuff plays fine as well.

    Maybe it is something about the 192kHz hack built in for S905X.

    It seems the DTS HD MA and the DTS HD HRA behaves differently if the frequency is 192kHz.


    Could you confirm if you can play HRA stuff after playing a 192 kHz MA track?

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V

  • @kszaq

    EDIT: So, I couldn't get my Khadas VIM to accept the latest 8.1.9 upgrade from 8.1.8. The first time, it succeeded and went to reboot, but before the boot logo would come on, the box would turn the power off. Any subsequent boot attempts with the SD inserted resulted in immediate power off (no boot logo). I setup a fresh SD with 8.1.8 and booted it succesfully. This time I tried the update again, and the same thing happened, however - I can no longer BOOT ANY SD card based OS including Linux, earlier LE releases, etc. All of this stuff worked fine a few hours ago.

    At first I thought the card slot might be fried, but when I loaded up Android, I was able to see the SD card, format it, copy files to it, read files from it (installed a few APKs as tests). I just cannot boot from it anymore. Same with USB (not sure if it was possible on the VIM).

    I have tried wiping the EMMC clean, and re-burning the Android version with Amlogic burn tool.... successfully, but the same results when trying to boot SD Libreelec. Sometimes it will just sit at the "Khadas" boot screen forever, and sometimes the boot screen doesn't show up at all (just black screen). As soon as I take out the SD card and reboot it, it boots up fine and Android will load up. I can then put the SD card in, and it works inside Android....

    I really don't know what the heck happened, or how on earth to go about trying to remedy this. But it seems like a bit of a coincidence that the SD stopped booting, right when I was applying the latest 8.1.9 update. I repeat... it works inside android (the SD slot)

    I am totally out of ideas!!

  • Hi kszaq

    where there any SMB changes from 8.1.8 to 8.1.9?

    I have this line at autostart.sh

    mount -t cifs -o username=xxx,password=xxx,rw // /storage/smb

    when using 8.1.7 and older versions, smb folder is properly mounted

    i tried upgrading to 8.1.8 and 8.1.9, i get a host is down error,

  • Ive just tried the download from post#1243 (thanks Nofan Tasi) (Prev had LE7 build)

    I also have an MiniMX 2gb

    The included dtb file worked and box went straight into Libreelec.

    But I have an issue that my IR remotes wont work. USB keyboard does but we use IR.

    I tried turning on lirc but it made no difference.

    Any clues?

    Thanks Bazzle

    EDIT: Just reread FAQs.

    Hopefully Ill get an answer there.

    pi3 and Beelink Android both with LibreELEC

    Odroid C2 and H96 Max 905X2 with CoreElec

    Edited once, last by bazzle ().