[8.2.2.3] LibreELEC 8.2 for S912

  • I tested this libreelec Version with my Mecool M8S pro L .


    Live TV with DVBViewer is a Problem using Full HD Channels.

    After a while the picture gets green and magenta frays in darker areas and beneath sharp picture edges.

    If I stop the player and restart then picture is ok again - for some minutes.

    Tested different Options in system and for the player. Nothing helps. No problems with Kodi in android.

    Temp is ok (about 65 Degrees C ).


    I have never seen that in libreelec with my other devices before. Any hints to solve that problem ?

  • bylderup This is caused by overheating. Temp sensor built-in the SoC may not always be accurate. In recent S912 builds CPU and GPU are set to stick to higher frequencies to work around libhybris overhead and keep GUI fluid.

  • ^ You only need crazy amounts of storage if you download full movies before watching or use wildly inappropriate buffer settings.


    With Qu*** you need the full space available. I don't know of any other good addon to stream legal 2160p legal documentaries or old non copyrighted movies

  • delz We don't care about personal legal/illegal beliefs because everything is allowed somewhere on the internet and banned somewhere else. We do care that you have an add-on installed that exists to openly encourage the consumption of pirated content. Please understand that if you ask for support in this forum it will now be refused until we see debug log evidence that shows Q**** has been removed.

  • Anyone have Kodi popping up the menu, like the back button is pressed now and then?


    Never seen this before, but happens við the latest build.

  • bylderup This is caused by overheating. Temp sensor built-in the SoC may not always be accurate. In recent S912 builds CPU and GPU are set to stick to higher frequencies to work around libhybris overhead and keep GUI fluid.


    I have tested now with active cooling and temp about 40 Deg C.


    I´m sad, because problems did not chance. Its only with livetv 1080i 50 Hz 25p .

    Changed from dvbviewer client to tvheadend client. Problem remains.


    As I said, no problems within Kodi or SPMC with android. No problems with 1080p Video file, too.

    But I prefer libreelec on all my boxes...



    pic1        pic2

  • Im putting together a team to infiltrate ARM holdings to steal the source code to the MALI drivers....

    can't guarantee your safety or that any will make it back alive....



  • This pic2, I have this specific problem since the first day that all my 3 KIII PRO arrived in my house. But it only happens when I watch DVB-C or DVB-S HD channels. It can be on Android DTV or TVheadEnd. Btw I have a KI pro and it is perfect. That's sad.

  • don´t understand techgurus posting.


    This thread is for [8.2.1.1] LibreELEC 8.2 for S912.


    I know, there are no Mali GPU drivers. But the libhybris thing.

    The device is working really fine with this drivers. The only issue I have is this with the live HD channels.

    So I gave some feedback. Not more. And I hope this issue can be solved in future releases.


    Btw, this is the first time I bought a device without problems using android with Magendanz Stock ROM.

    I do have deep respect about all the hard Work done by libreelec developers.

    Atm for me and for this S912 device it is not the best solution because I use it for watching live tv in HD mostly.

  • kszaq Thanks for the advice. I have just tested it. Same as before. After some minutes problems as described.


    ..but only with live hd channels with 50 Hz . Everything else is playing fine!

    For example tested some youtube 4k videos last night, shown with 1080 on my tv screen. Amazing.


    -------------


    edit : although I have a LG Panel (M3702C-BA) I did 2 things and made some further tests :


    Installing this version of libreelec: LibreELEC-S912.arm-8.2-devel-20171205200850-r26441-gdba9a67.tar


    Added this in advancedsettings.xml :


    <cache>

    <buffermode>1</buffermode>

    <memorysize>139460608</memorysize>

    <readfactor>20</readfactor>

    </cache>


    As long as I don´t zap from one Full HD channel to another one directly - the picture is fine without issues.


    Zapping directly will bring back the problem.


    edit 2 : after 3 h without errors the same bug again

    went back to to android for now

    Edited 4 times, last by bylderup ().

  • I´m sad, because problems did not chance. Its only with livetv 1080i 50 Hz 25p .

    Changed from dvbviewer client to tvheadend client. Problem remains.


    I watch Live / Recorded TV all the time on a S912 MINIX U9-H with TvHeadend at 50Hz 25i and have never seen any of the problems you describe.

    I suspect you have hardware issues and/or TV tuner problems that do not play nice with LE on your particular S912.


    Are you sure your local Network is operating optimally from your TvHeadend server ?


    My TvHeadend server is running from an external, seperate Gigabit S905 LE box.

  • i was having image issues on the kiii pro with 8.2.1.1 so i went back to 8.2.0.1... , anyone can help me or point in the right direction, when i watch tv from the dvb tuner the 0sd is not centered altought the image is correct, this happens in all the channels from the dvb tuner.... , in regular movies from the hard drive sometimes it happens sometimes dont.... , the box has 2 res options that say 1920 but only the second one puts the overscan correctly on my tv..... except when watching anything from the dvb/c/s/t tuner.....

  • its a joke (or is it?) the libhybris drivers are pretty crap for 3d acceleration in gaming

    real drivers would make the s912 chip MUCH better

  • all you guys with dvb problems...why not get a second hand pc...load libreelec on that...im sure it would work better that way..then with a under powereed tv box with no proper gpu drivers

  • wrxtasy


    Have a Digibit R1 with Satip Software from Perexg and DVB Recording Service plus standalone Boxes with TvHeadend
    Its running fine, no issues with libreelec and Full HD liveTv Channels. Only the new Mecool M8s pro L has this problem.


    And the strange thing is, even without active cooling the device is doing fine if I use Android and Kodi.


    Don´t think its a hardware fault, because it should have the failure always.

    I tested for days now, with different libreelec versions and different TV Screens, different settings, different Live TV Service..

    I assume a bug in the GPU driver or dtb.img. As I said I went back to android for now with this device.
    I am a retiered IT professional. Its driving me nuts if I can´t find the bug.. But 3 days/nights for a China box are enough..

    techguru


    The challenge is to take a cheap China Box, delete the crap, flashing a Custom ROM and having a lot of fun with it.

    Old Notebooks have to much power consumption, NUC is way too expensive.

    I do not understand why there are no proper GPU drivers for S912 chips.

    May be economic interests and piracy themes have influence (thinking of Minix with S912 boxes and OSMC boxes, they won´t sell their stuff anymore if it will run on a 35 euro device) But thats complete off topic..