S905 builds - general discussion


  • I'm just hoping Kszaq is able to fix the memory problems , everything else i know will eventually get addressed by him or other devs.


    Just leaving the box on for 2 days my MXIII has already used 60% ram, same config on a Rpi2 and ram sits at 15% when idle the MXQ would have frozen by now.


    My uptime is 11 days, 20h and I'm at 52% memory used (389MB out of 742MB). Running 7.0.2.003 on A95X with S905 and 1GB RAM.
    [hr]


    Did you look in the My Apps section in Android? It should be there. Mine was called Update and Backup. I have the same mxq pro 4k v1 box as you and had to use the Update and Backup app to get it to load the script. I could probably try to find the apk for it if you need it.

    Edited once, last by goofball ().

  • Hey thkas for the quick repsonse.. any you can pint me to? I know (or have heard) that Android firmware is very specific to that Andoid box and putting anyting other than that would brick it? Is this the case?


    I have the MXQ PRO 4K v1


    If its the blue board with the date 1511 then you can use hugsun_s905_mxq_20160304.img.


    Do a google search and you should be able to find it, you will need the usb burning tool

  • My uptime is 11 days, 20h and I'm at 52% memory used (389MB out of 742MB). Running 7.0.2.003 on A95X with S905 and 1GB RAM.
    [hr]


    Did you look in the My Apps section in Android? It should be there. Mine was called Update and Backup. I have the same mxq pro 4k v1 box as you and had to use the Update and Backup app to get it to load the script. I could probably try to find the apk for it if you need it.


    Huh..interesting... ill have another look tonight when i get home, but if you can point me towards an APK that would be great as well! Thanks again
    [hr]

    If its the blue board with the date 1511 then you can use hugsun_s905_mxq_20160304.img.


    Do a google search and you should be able to find it, you will need the usb burning tool


    thanks man! ill give this a shot..

  • Hi kszaq


    first of all thanks for a your great work !!!!


    will this releases also be "ported" to kodi 17 ( krypton ), or is there some neassary kernal etc etc that need to be fixed from other people


    / Regards


    Stainlessdk


  • Let the man finish with Kodi 16.1 (LE 7.0) so its nice and stable, i'm sure he will work on Kryton (LE 8.0) once its released and LE is stable on the s905.


    No point in asking him about software that isn't even released and the fact we don't even have a stable release by Kszaq.

    Edited once, last by JonSnow ().

  • Agreed. I also prefer to have a stable release first.

    Device: Nexbox A95X (S905 / 1GB / 8GB)
    Build: 7.0.3.012j and 8.0-8.0.1i on SD card



  • It has been proposed today in amlinuxmedia forum by alex a solution that would free up memory:

    Code
    1. sync; echo 3 > /proc/sys/vm/drop_caches



    Said to work via cron job that could run daily...
    I dont know much about linux, so i m just mentioning for you gurus, maybe it can be included in future builds until a propper fix in amlogic linux code
    Maybe a script can keep an eye for memory load every few minutes, and run when > 70% or something .. dunno :S

    I am insane! My mother had me tested.

    Edited once, last by infoalter ().


  • Really hoping that command worked, but it didn't do anything to my ram usage.

    Edited once, last by JonSnow ().

  • In my test it does not work either, drops RAM usage by 2-3 percent


    I have also read tutorials about tuning virtual RAM in linux, came to conclusion the problem shoud be dirty pages, resources cannot be set free by drop_caches. So, i have also been testing performance for long time last night with settings like

    Code
    1. echo 10 > /proc/sys/vm/swappiness
    2. echo 15 > /proc/sys/vm/dirty_ratio
    3. echo 5 > /proc/sys/vm/dirty_background_ratio


    None of those really solves this problem... There is a memory leak that needs to be itentified and patched, sounds like an Amlogic job to me, not a kodi issue

    I am insane! My mother had me tested.

    Edited once, last by infoalter ().


  • [...] There is a memory leak that needs to be itentified and patched, sounds like an Amlogic job to me, not a kodi issue


    If there is a leak, you might succeed to spot it with 'top'?

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo


  • If there is a leak, you might succeed to spot it with 'top'?


    Maybe? :) Already said i dont know much, so dont ask me whats the meaning of those numbers lol
    This is at a time when i see memory 77% in Kodi, so its just about to freeze, still responsive though - so for anyhting those might worth, here it is:

    I am insane! My mother had me tested.

  • I have finally found some time to try the SD install for 7.0.2.005 and I have not been able to get LE to boot.
    My MXQ Pro+ is running OE 6.95.3 from SD with balbes150's S905_autoscript. I am also running a Tronsmart Meta rom compiled by sd-robots. The original firmware was terrible. OE runs pretty well with no boot issues.
    This box has no reset switch in the AV hole, so I can't use that method. The firmware does not offer a reboot to recovery option, so I tried Quick Boot, which boots me into TWRP. I replaced the original MBOX recovery with TWRP so that I could flash sd-robots/Tronsmart Meta rom.
    I tried ADB, adb reboot recovery, the box booted into TWRP.
    I tried ADB, adb reboot recovery, with a USB with s905_autoscript and SD card with 7.0.2.005 extracted onto it - booted into TWRP.
    I tried the USB/SD combo with the S905_autoscript on the USB stick - USB OTG port, booted at the same time as the SD card - the first time it booted into Android and then went through an 18 app optimization then Andoid started. I rebooted and the box went straight to Android.
    The S905_autoscript is on both the USB and SD cards when booted - not sure if this was correct.


    I would appreciate any help/advice on how to get LE to boot. I can't think of anything else to try.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

    Edited once, last by doggyofone ().

  • Maybe? Already said i dont know much, so dont ask me whats the meaning of those numbers lol
    This is at a time when i see memory 77% in Kodi, so its just about to freeze, still responsive though - so for anyhting those might worth, here it is:


    A leak is when a process holds memory it should have given back. In practice all top might reveal is memory usage for the process constantly increasing. Of course the process might claim to have a good reason for holding the memory. But typically when done with some job, one gives back resources it needed. Another possible leak happens when a pointer to some memory is reassigned before memory given back. Then memory becomes garbage. Not sure if LE linux has easy ways to detect garbage.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • I can't install IPTV PVR simple client. I am using the latest version of LibreELEC on a Mini MX. Installation always fails but doesn't say why. Probably a dependency missing. Has anybody succeeded installing this addon?

    Edited once, last by Majorero ().