Posts by kane2931


    thanks to kszaq my beelink mini III is now amazing, love it, just one question though, its not major just that its bugging me, lol, how do you change to the correct time, the date and time are correct but they show an hour behind, i take it because of summertime daylight saving etc but how nad where do i correct this, any help would be appreciated and thanks again kszaq


    To change time, go to settings - skin - international section and chose your country, state, timezone.