Tvheadend nightly builds for LE

  • hello. im trying to use hdstar v3 dvb-s2 on coreelec latest matrix build. the crazycat drivers find the card and its recognized in tvheadend but there are so many contiunity errors and such that its basically unusable. with kernel and coreelec drivers tvheadend the device is not recognized in tvheadend. im using tvheadend 4.3

    on the net i have some solutions like this but none of them work? can you help me with this?

    [HOW TO] Geniatech HDStar V3 Dvb-S2 install - Raspberry Pi - OSMC Forums

    Totally outside the forum and topic.

    If you are not using LibreELEC here you will not find support.

    If you want help and support from LibreELEC you need to use LibreELEC and simple as 2 + 2 is 4

    It is useless knowledge if not shared the world.

  • Hi,

    First of all, thanks a lot providing support for very old box. I have a wetek play 1, running LE 9.0. I am looking for TVH build that contains this fix.

    / - Diff - Tvheadend

    Is it possible for you to compile with this fix? If not, and I understand it, could you point where should I look for compiling just the TVH with the fixes I am after? I have windows but can run Linux/unix in Vm. Please treat me noob thanks.

  • Hi, Installed LE10 beta 3 with TVH 4.2 on my AMD PC. Installed fine and setup channels etc. Left a channel on for about 5 hours . Stopped it and turned off the TV. I have a HDMi CDC adapter which I forgot to change settings so when I turned off the TV it tried to shut down the PC. Thats where things went bad. I use the old PlayStation 3 USB dual tuner. The tuner would not work (no device listed in TVHeadend) and there were kernel messages on startup. I fully powered down the PC and disconnected the mains for while. Still no go, I thought the Tuner had fried, installed 9.2.6 all is OK again.

    Just reporting my experience. I will reinstall LE10 again and disable the CDC power off and see if it is ok this time.

  • Hello CvH,

    using your build "HTS Tvheadend 4.3-1906 ~ LibreELEC Tvh-addon v9.2.0.444" on a Raspi 3B+ I am experiencing a maybe trivial problem.

    Setup of TVH for Astra Satellite went fine, I detected muxes and a lot of services and mapped them to channels. I could watch TV in the Configuration/DVB inputs/Services tab by pressing the play button. EPG also populates fine.

    However, in Configuration/EPG_Channels/Channels absolutely no channels appear. I also cannot add anyone.

    I assume in this tab I would have to map channels to channels numbers or I could select a subset of all channels for my EPG. But no chance to add or select anything. This tab is and stays completely empty.

    Anybody can give me a push what is going wrong?

    Thank you!

  • Hi,

    I have installed LE 9.95.3 (Generic x86) on a spare ssd, but my TBS 6281 dual dvb/t/t2/c card isn't fully recognised. Dmesg shows two elements: SI 2168 and SAA 716x. When checking my LE 9.2.6 installation with the same card fitted, dmesg shows an additional item, an SI 2157. Both installs have the crazy cats TBS drivers installed. TVH in LE 9.2.6 shows the tuner, but not in 9.95.3. Is there some way I can fix this, or do I need to wait for a later version.

    Thank you

  • I'm using the hdhomerun prime and dual as my tuners for tvheadend. I noticed after updating the firmware for both the hdhomerun prime and dual to 20210624 there is a lot of pixilation issues while using tvheadend. Is there an easy way to update the tvheadend libhdhomerun_20210624 for tvheadend4.3-1938-22.02.2021 to see if it resolves my issue?


  • Thanks for the info CvH. I realized after rebooting everything (the hdhomerun and tvheadend server) the pixalization now only happens during the playback of recorded shows. I ended up reinstalling tvheadend and deleting all the folders from the recordings and it seems to have resolved the issue.

    Thanks again.

  • Hi,

    today I built the most actual version of tvheadend 4.3 - just changed PKG_VERSION in with 23754f9a63dad8540214d549b4baec2464e5d33a with PKG_SHA256 commented. Everything ok, but if I install it in LE10.0 it does not start and the service.log shows:

    /storage/.kodi/addons/service.tvheadend43/bin/tvheadend: error while loading shared libraries: cannot open shared object file: No such file or directory

    Trying to --disable-libx265 did not help.

    Does anyone have an idea?

    edit: tested it on a x86_64 machine

  • Hello! :) I have a Wetek Play with LE 9.2.8 unofficial by dtech . I know it's an unofficial version but it's much better than the official 9.0.2 and I'd like to use the latest tvheadend builds linked here on it but I've issues with them (certainly, not linked to them but to my setup) and I'd like to undestand if there is a solution for them. I've tried to install Generic-service.tvheadend42-4.3-1906 and I get this:

    /storage/.kodi/addons/service.tvheadend42/bin/tvheadend: line 1:ELF: not found
    /storage/.kodi/addons/service.tvheadend42/bin/tvheadend: line 1: syntax error: unexpected word (expecting ")")

    which to me seems something related to using executables for the wrong architecture (I know building a WP version for 9.2 is a nonsense given there isn't official 9.2 for it and I'm not asking for that) but shouldn't the generic build work everywhere? Too optimistic, I know!

    If, on the other hand, I try WeTek_Play-service.tvheadend42-4.3-1774, I get a different error:

    tvheadend: error while loading shared libraries: cannot open shared object file: No such file or directory

    which is related to the fact that the addon is for the wrong LE version. Given that compiling a build suitable for my WP requires setting up a whole toolchain and I'd like to avoid it if possible, it there a way to adapt the 9.0 version just changing/adding something inside the package? Still too optimistic, isn't it? ;)

    Thanks in advance for your advices. :)

  • I have also a WP1 running, but haven't updated to 9.2.8. Didn't even know it exists ;)

    Maybe you can ask dtech if he compiles the latest tvheadend for the WP1 with 9.2.8?

    Generic build is not for WP1


  • I have also a WP1 running, but haven't updated to 9.2.8. Didn't even know it exists ;)

    Maybe you can ask dtech if he compiles the latest tvheadend for the WP1 with 9.2.8?

    Generic build is not for WP1


    Hi and thanks for your follow-up. :) I apologize because I know it is an OT so I would be as brief as I can. If you want to try it, you find it here but please pay attention to use the .img.gz and the workaround described here otherwise updating from official 9.0.2 would be impossible. There is another little 'piece' that needs to be noted which, instead, benni0815 gives for granted: the /flash partition needs to be remounted rw otherwise you wouldn't be able to create the necessary script which, as every script, also needs to have the executable attribute added.

    Going back on topic, I'm certain dtech would be glad to do it if asked but he has other and more important things and projects to attend to and I'd like to sort it out by myself if I can otherwise I would go on with using the much older tvheadend server v4.2 already included in the official LE 9.2 repositories. Have a nice day! :)