Thoradia Add-ons

  • I'm also on RPi4.


    What version of LE were you on before you upgraded the nightly and broke Transmission?


    I can't help much more. I would suggest you install the broken Transmission from Thoradia to get all the dependencies, then install this over top of the version that it provides.


    I started with a working version, then upgraded the nightly which caused Transmission to stop working. I rebuilt it and installed that, then it started working again.


    Just one clarification that this is for RPi4 only.

  • What version of LE were you on before you upgraded the nightly and broke Transmission?

    I can't say for sure. I tend to install the latest nightly every few weeks. It was a 9.80 nightly though, before getting the latest 10.0 one that contained the breaking library change.

  • I tried to add the service.thoradia.9.2.0.23.zip repo to CoreELEC 19 it has a python issue, then I was able to install service.thoradia-9.80.6.25.zip but it says could not connect to repository (yes, I restarted everything).

  • I’ve manually installed what I need from service.thoradia-9.80.6.25.zip and it’s all working well but NzbHydra seems to be missing. Will this be re-added? Thanks.

  • Hello thoradia ,


    Thanks for the repo, it has been really helpful :) .


    I have been problems with lidarr lately. Every basic error ("couldn't download media cover", "the operation has timed out", for example) ends with an application crash. Although libreelec eventually restarts lidarr again, this keeps happening, flooding me with logs and wearing off my sd card, until eventually lidarr just stops restarting.


    I chatted with lidarr developers over discord and they told me to switch from the mono core to the NET one. I manually downloaded a new lidarr version, ran it with both cores, and this problem (crashing after a seemingly normal error) does not occur [1].


    I wanted to know if there are plans to change the core lidarr uses in Thoradia... I saw that it was already changed for Radarr at least


    [1] I don't get why it doesn't occur when executing the downloaded version with the Mono core, but well... if it helps, here are a couple of pastebins with my crash issue: [1] [2]

    Edited 2 times, last by petemir ().

  • Hi,

    I am running Radarr with Bazarr along with using Transmission as my download client. I wanted to use a different drive for my downloads but Transmission errors out with "Error: Read-only file system"(and is transferred down to Radarr). In what way should I modify the filesystem without ruining it completely?(like I did once with Ubuntu by letting everything run on sudo level)


    Looking at the permissions of files in the drive, it doesn't seem to be an issue of permissions. The permissions are the same as the ones for the transmission folders where it originally downloaded stuff... I know Radarr can access the drive because it moved a movie that I previously donwloaded from my primary drive to the secondary one. Radarr also gives this error: "Local download client Transmission places downloads in /media/disk/transmission but this is not a valid libreelec path. Review your download client settings."

    Edited once, last by Hypadrive ().

  • Hey folks, I know it probably takes a lot of work to keep this stuff running and I know you probably get this question a lot, but do you have any plans to make the repository work on LE 10.0? I can't find any info on that subject. It's the only version of LE I can run aside from the nightlies, and I'd love to be able to take advantage of this repository.


    Edit: working with ARM

  • Hi mrtrev and mklod , would you be able to help re-upload this? I've been trying to get transmission to work but have not succeeded so far.

    Edited once, last by b0nz0 ().