RPi4 testbuild with HDR support

  • HDR and HDCP are completely independent - RPi doesn't even have a certified trust path, so no widevine, HDCP etc.


    so long,


    Hias

    Hi HiassofT


    my fault, i ask this not about Pi4. My AVR (Denon X4100) has HDMI 2.0 but only HDCP 1.4.

    If i go from PI --> AVR --> TV i get no HDR.

    If i go from PI --> TV i get HDR.


    Is it not possible with HDCP 1.4 to get HDR?


    I tried a HDCP Converter, but this doesnt work too. :(

  • Unfortunately no JohnWayne111


    That is a reason i love the new RPi4. My old receiver will take the HD Formats from one HDMI and my HDR-capable projector from the other.


    Regards


  • If your AVR has HDMI 2.0 support but only supports HDCP 1.4 (and not HDCP 2.2) then that could mean it was one of the first gen UHD AVRs that had HDMI 1.4 inputs and outputs in hardware terms but that got very basic HDMI 2.0 support added (in the same way nVidia added HDMI 2.0 support to their HDMI 1.4 Graphics cards and Sony added HDMI 2.0 to existing HDMI 1.4 UHD TVs via a software upgrade)


    The way they did this was to add support for just the 4:2:0 HDMI 2.0 mode for 2160p50 and 2160p60 modes - as HDMI 1.4b already supported 2160p23.976-30 at 8-bit in SDR using 4:4:4/RGB and 12-bit using 4:2:2 (though this mode may not have been supported).


    Using the 4:2:0 subsampling introduced with HDMI 2.0 allowed HDMI 2.0 4:2:0 2160p50 and 60 modes to fit into the hardware restrictions of an HDMI 1.4b connection (i.e. you could add HDMI 2.0 basic compatibility using HDMI 1.4b hardware). AIUI this was 8-bit SDR only, and that may also have been true of the HDMI 1.4b 2160p30 and below support also supported. (i.e. you get UHD support at all frame rates in 8-bit, but you don't get HDR support as that would require 10 or 12-bit support - which may not be implemented)


    The Pi 4B doesn't support 4:2:0 HDMI output as I understand it (as it would require both vertical and horizontal subsampling of chroma - and the Pi can only really do horizontal (?)


    This may also mean your AVR is not HDR compatible ("passthrough" in AVRs isn't helpful in that regard)


    The lack of HDCP 2.2 support is a strong suggestion that your AVR is one of those early HDMI 1.4 models that got a partial upgrade to HDMI 2.0 - though I may be wrong.

    Edited once, last by noggin ().

  • Sadly seem so...

    "HDCP 2.2 is specifically designed for 4K Ultra HD (4K) content, as well as movies and TV shows available with High Dynamic Range (4K HDR)."


    from: Roku

  • Hi noggin


    could be possible. It is a Denon X4100 Receiver.

  • I used to have a Denon AVR-X4100W receiver, and I can confirm, that HDR was not possible through it. Sorry.

    I had to replace it with an AVC-4700H, now HDR works well.

  • OK - have installed the latest nightly LibreELEC-RPi4.arm-9.80-nightly-20210220-f768c9b downloaded this morning.


    Running in 1080p mode (to allow >30fps content to be output) my 2160p50/59.94 files largely play - and HDR10 Rec 2020 stuff is played with a PQ ST.2084 EOTF (aka HDR10 HDR) but the output is 8 bit RGB and it looks as if it is being flagged as Rec 709 gamut (so colours are less vibrant as they are using the narrower primaries).


    Content I have that flags 1000, 4000 and 10000 nit mastering displays correctly sends this metadata (as confirmed by my HD Fury Vertex)


    I'm playing the content from a Samsung Evo+ 64GB uSD card and I'd say I'm getting some dropped frames on p50 and p59.94 content - though whether this is throttling because of high bitrate on the storage or on the HEVC decode and scale down to 1080p I can't say.


    I've yet to see any YCbCr 4:2:2 output at any bit depth - I don't know if there is a config.txt or LibreElec setting (or something I can type in at command line level via SSH) to enable YCbCr 4:2:2 output?


    HLG content appears to correctly trigger an HLG EOTF (i.e. ARIB B-67 EOTF) - though AIUI BBC iPlayer 1080p SDR and 720p-2160p HDR streams (iPlayer uses HLG for HDR) may now be DRMed preventing playback on non-certified devices.


    I can force my TV into Rec 2020 gamut and that makes things look quite a lot better - though I can't say whether Rec 709 or Rec 2020 YCbCr->RGB matrices are being used (the differences are quite small between the two)


    I can also only play a couple of files before playback stops working (I get left in the GUI with a play icon top of frame with the name of the file being played, but no video and have to reboot)

  • Unfortunately no JohnWayne111


    That is a reason i love the new RPi4. My old receiver will take the HD Formats from one HDMI and my HDR-capable projector from the other.


    Regards

    Quite, the dual HDMI's are certainly useful on the RPi4...

    Nearly there folks, it's all good news so far.

  • I have been trying to get HDR to work with this build and my media room setup.


    RPi4 <-> Denon AVR-X2600H <-> Optoma CinemaX P2


    HDR is not activating when playing any HDR media. In the logs below I attempted to play the Samsung Wonderland 2 HDR video.


    I have also connected the RPi4 directly to the Optoma with the same results.


    EDID: http://ix.io/2R71

    Logs: http://ix.io/2R7d

  • It looks you are not using the correct build, when you should use HiassofT build LibreELEC-RPi4.arm-9.80-devel-20210210171544-68ac68f.tar

    The info bellow its from your logs.


    Code
    LibreELEC (community): nightly-20210226-e12ff43
  • mrlindstrom HDR output on RPi4 isn't fully feature complete yet and most likely your Optoma doesn't like that.


    It will take a while until all the missing bits and pieces are implemented in kodi and the video driver.


    BTW: testing with nightly images is fine, all neccessary changes in my testbuilds are included.


    so long,


    Hias

  • It's impressive to see hdr stuff finally, but anyone else noticed that in this build (can't say about others) animes with embedded subtitles wont display it?

  • Today I tried the following build on my raspberry:


    LibreELEC-RPi4.arm-10.0-nightly-20210306-f4e99c3.img


    I connected the rasbperry's hdmi 0 output to my tv, hdmi 1 output to my old receiver which is not a 4k, so hdmi 1.4.


    HDR works perfectly, but despite that in the audio setup menu, the hdmi audio output of the receiver, no sound is heard.


    IMG-20210307-134641.jpg

    Edited 2 times, last by ginogio65 ().


  • What HDMI port in your receiver is the audio only hdmi cable connected to? I have a similar situation. My soundbar focuses on vc4-hdmi0 (connected directly to the TV) and thus display 'TV'. I have to manually set it to a HDMI output so the audio plays too (vc4-hdmi1)

    Also, are you sure you are audio your receiver can handle? Do you have passthrough enabled?