[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Could anyone here confirm if they can get a 5ghz wifi connection? I can only see 2.4ghz networks.

    5Ghz works fine on my Minix Neo U1. I know 5Ghz has a shorter range than the 2.4Ghz spectrum. Maybe move your media player closer to the router and see if it picks up

  • Hello,


    1.) Thank you for your work.


    2.) I experienced a average CPU load on S905x / Khadas VIM Pro of about 30 % KODI load.

    Running OSMC on Rasperry Pi 2 I have about 15%.

    I am having the same configuration on both.

    It seems that the Amlogic part is not fully HW decoding/playing... instead of the Broadcom part at Raspberry...

    So many parts needs to be made by the CPU taking performance...

    Is there a chance to benefit more from HW ?

    It is visible soon as the Kodi Home screen with active debuggin is enabled.

    No Video is beeing played...


    3.) After a while on playing back different videos and at different possition, I experienced a stuttering and de-sync of Audio...

    The logfile is saying only, that the CVideoPlayerAudio Process stream stalled.


    Part of the logfile attached...


    Thank you and kind regards

    Tester

  • Some parts of decoding have to be done "in software" or else you would experience a/v desync.


    Don't compare RPi to Amlogic. RPi Foundation developers actively contribute to Kodi constantly squeezing more and more from this platform. On the other hand, everything Amlogic-related in Kodi has been developed by community developers who often had to reverse engineer Amlogic decoding pipeline.

  • Don't compare RPi to Amlogic. RPi Foundation developers actively contribute to Kodi constantly squeezing more and more from this platform. On the other hand, everything Amlogic-related in Kodi has been developed by community developers who often had to reverse engineer Amlogic decoding pipeline.

    Well that's disappointing to read.

    I bought this board, because of wanting more power for and within Kodi.

    If this power is used as CPU Load because of lacking support of Amlogic,

    to have "not really much more power" instead of getting this power on the road...


    Amlogic should think about these companys building TV boxes and I think these are their main customer of their chips.

    If these boxes have less performance than a rpi2 but advertising them as Hardware monsters...

    without getting this power in OS/applications..


    The boxes are senseless, damned to be bricked after the customer experienced the difference to a rpi it...

  • Witch versions of NFS this builds support?


    NFSv4?

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • If these boxes have less performance than a rpi2 but advertising them as Hardware monsters...


    without getting this power in OS/applications..

    Very early into Krypton. It will get better.

    Jarvis is my every day LE. That has been developed over a longer time with huge performance improvements from day 1.

    Patience and Krypton will improve.:idea:

  • 5Ghz works fine on my Minix Neo U1. I know 5Ghz has a shorter range than the 2.4Ghz spectrum. Maybe move your media player closer to the router and see if it picks up

    It’s within 10 feet of the router. Very weird. It should also be able to pick up the neighbors wifi but again 2.4ghz only. The router is an Asus ac66-u.

  • It’s within 10 feet of the router. Very weird. It should also be able to pick up the neighbors wifi but again 2.4ghz only. The router is an Asus ac66-u.

    Ok, so I lowered the channel number on the router for the 5Ghz wifi and it works.

  • I have a T95N device and flashed it with this firmware. But since then and subsequently on any later update the system freezes completely once or twice a day. That is somewhat acceptable, although pretty annoying, if it is fixed at some time later. This device is only used to watch TV in the bedroom, so it is not too much trouble.


    However, i start to believe this is nothing that will get fixed accidentally and would like trying to help to find the underlying issue. I suspect it could have to do with the device tree missing some restricted memory region or something alike. The freezing appears to happen totally randomly but normally not very soon after bootup.

    Try the temperature sensor disabled version .

    I did that already previously but will try again and report back :)

    Hello again ;)


    Sorry for reporting back that late. I now tried the temperature sensor disabled version for some time and could not observe any difference in behavior. It is still freezing regularly. It responds via ICMP but nothing else, I found an issue at the hts.pvr kodi plugin tracker that is very likely describing the same exact problem i am observing. I will take a look inside and see if i can find some pins for a serial connection. Maybe it is possible to get more information out of it via this channel. Any ideas that helps debugging this further are welcome.

  • @kszaq Thank you for your work on the project for S905/S905X Chipsets,

    I must say I'm Really happy, I have Philips 4K TV and was really pissed off cuz of no DTS-HD and TrueHD support, so I just bought cheap MXQ PRO 4K 905X (1/8gb) unit and put the LibreELEC 8.0.2d on it and it play all my movies files flawessly,

    It play 4K HDR with DTS-HD and TrueHD files via DLNA without any issues, its fantastic, and at a same time sad that modern 4k tv can't bitstream lossless audio without external device.


    Now as everything works fine, I want to make the UI looks nice but have problem getting artworks,thumbnails and others, I see no options for it.

    On my Windows 10 Store version of Kodi it all setup the artworks automaticly, Am I missing something. Can you provide me information how to make it on LibreELEC?


    EDIT: I see why I can get Artworks/Thambnails etc. Its possible when getting files from internal/external device as it ask if its movies/tv shows but when getting Upnp device over ethernet it just adds without asking for media type.

  • Hi @kszaq,


    I've been trying to build an image in a Debian Stretch docker container, but the compilation of `kodi:host` fails with the following error:


    The gcc version in the sysroot basically doesn't support this -mthumb option, which is weird because I could compile images of previous versions just fine.


    What environment do you build your images in, and have you tried doing a clean build before releasing images for the current version?


    Thanks.

  • What environment do you build your images in, and have you tried doing a clean build before releasing images for the current version?

    I always make a clean build for release builds, building on CentOS.

  • Hello,


    Great Job kszaq for your builds.


    One question : It's possible to enable the spdif output in a next build ( to send the 5,1 flow to an amplifier) ?

    Thanks.

  • Is it possible to use this release on the odroid C2 when i come from 8.0.2 (official libreelec) and use tar update method?


    edit: no you can´t (result was the libreelec-screen...forever...)

    PS: of course i made a backup ;)

  • If this power is used as CPU Load because of lacking support of Amlogic,


    I was watching a movie last night for the first time on a s905. It was 1080p. I was watching top on a laptop just to keep an eye on it every once in a while. CPU never jumped past 30% and was averaging less than 15%. Load was 0 on all cores the whole time. I'm curious what settings you are using. I think the main thing you want is to make sure audio is passed through to your AV receiver and that you aren't doing any upscaling/downscaling of the video or upmixing/downmixing of the audio.


    I am migrating from an RPI B 2 as well and testing for performance. I'm curious what video you were testing and what your settings are.