[8.0.2e] LibreELEC 8.0 for S905/S905X


  • I also have issues with S905 box standby, I have chosen to disable standby for the box from the CEC settings:


    System settings -> Input -> Peripherals -> CEC Adapter -> When TV is switched off to Ignore


    You can change the value to shutdown as well, but for me that causes communication error and AVR stops receiving sound from devices and TV sound is switched on.


    There are also settings for commands to the other devices the box sends when powering down.


    I also have drilled some holes to the top cover of the box to increase air flow, before I had up to 61C temperatures during idle, now idle temperature is 51C.

  • I also used to get occasional buffering using SMB as source source. I changed the source to NFS and haven't noticed it since. No changes needed to the Windows system, just edit the existing kodi source and browse back to the folder via Network File System. Worth a try ;)


    I've been getting buffering with SMB too. I haven't had any chance to do any investigation into it. I don't think I can use NFS shares as my "server" is running Windows 10 Home which I don't think supports it.


    I should add I've only experienced this buffering on the beta 8.0.0 builds and not any of the older ones. Also using wired gigabit ethernet and not wifi.

    Devices: Mecool KI Pro S905D & Beelink MiniMX III 2G/16G S905.

    Edited once, last by Hans Gruber ().

  • My device is MXQ Plus.


    Thanks for the tip, I have a Pulse 8 adapter in storage somewhere. That was one expensive piece of (tiny) hardware.


    New firmware did not solve my issue :( hope Nexbox fixs this asap.


  • New firmware did not solve my issue :( hope Nexbox fixs this asap.


    I think I also had the same problem with Raspberry Pi B with OpenElec maybe 2 years ago, I think I disabled sleep back then as well.


  • Unfortunately with my S905x box i have no cec adaptor listed in the peripherals settings menu. That why u was asking if there was a file I could edit relating to cec...


    Sent from my HTC 2PS6200 using Tapatalk

  • I did a clean install of 8.0.0c and set things up. 8.0 runs faster, everything seems to work well and the audio sync is now fixed for me. Sync issues continue with 7.03.012 when I boot to that version of LE.
    Thanks Kszaq, great work. Another coffee on the way.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • I hope its ok to post in this thread. I have been trying to boot my mxq pro 4k off of a usb stick with no luck. I followed the guide. mabe I missed something. I'm kinda new android other then I a few roots here and there. I used the toothpick method and all it does is bring me to a backup/restore type of menue but nothing about booting from usb. also i used LibreELEC-S905.ALL.aarch64-8.0.1.img and replaced the dbt file gxbb_p200_1G_mxq_pro_4k renamed to dbt.img pasted it inside the main folder and it replaced the one in there. also at first i was trying to use a usb stick but when it would load the android restore it would show errors at the bottem but when i used the sd card the errors were gone. but still not sure how to boot from it. these are the files put on the sd card SYSTEM, syslinux, KERNEL and a folder named EFI.
    [hr]

    Edited once, last by beeasy79 ().


  • I hope its ok to post in this thread. I have been trying to boot my mxq pro 4k off of a usb stick with no luck. I followed the guide. mabe I missed something. I'm kinda new android other then I a few roots here and there. I used the toothpick method and all it does is bring me to a backup/restore type of menue but nothing about booting from usb. also i used LibreELEC-S905.ALL.aarch64-8.0.1.img and replaced the dbt file gxbb_p200_1G_mxq_pro_4k renamed to dbt.img pasted it inside the main folder and it replaced the one in there. also at first i was trying to use a usb stick but when it would load the android restore it would show errors at the bottem but when i used the sd card the errors were gone. but still not sure how to boot from it. these are the files put on the sd card SYSTEM, syslinux, KERNEL and a folder named EFI.
    [hr]


    Did you use Rufus or similar tool for transferring the image to the USB-stick?


    Also only one of the USB-ports is bootable, in my box it's the single one in back.


    It should boot straight into the LibreElec installation without showing restore screen.

  • Edited once, last by beeasy79 ().


  • whats the advantage with the temp disabled version?


    Used only if box freezes when powering on.
    Mainly occurs with S905 Chip Boxes but seems to have disappeared on a lot of those boxes after 7.0.012g version.
    Read #1

  • Used only if box freezes when powering on.
    Mainly occurs with S905 Chip Boxes but seems to have disappeared on a lot of those boxes after 7.0.012g version.


    so what i got then is LibreELEC-S905.arm-8.0-8.0.0c.img and gxbb_p200_1G_mxq_pro_4k.dtb and for tools to use i have Win32DiskImager-0.9.5-install or LibreELEC.USB-SD.Creator.Win32 or rufus and i also found this tutorial


  • I don't think I can use NFS shares as my "server" is running Windows 10 Home which I don't think supports


    Correct, Windows 10 Pro and Enterprise do have native support, but not home edition (although free 3rd party versions of both server and client can be found using Google)


  • so what i got then is LibreELEC-S905.arm-8.0-8.0.0c.img and gxbb_p200_1G_mxq_pro_4k.dtb and for tools to use i have Win32DiskImager-0.9.5-install or LibreELEC.USB-SD.Creator.Win32 or rufus and i also found this tutorial


    Sorry i use a Mac OS so i will let others help you with this.


  • Sorry i use a Mac OS so i will let others help you with this.


    LOL - Not much point in posting then :rolleyes:

    Edited once, last by Poida ().

  • Hello...


    I had a Mini M8S II box and now i have a Tanix TX5 Pro TV box...


    I had freezes and Kodi restarts with Mini M8S II and i also have now with Tanix TX5 Pro...


    Setup is typical LibreELEC 8.0.0c with as few addons as i can...


    I have tested both versions, with or without thermal sensor without any luck...


    The only thing i have noticed with Krypton is that now the box does not freeze anymore, only Kodi is restarting and also this issue is not so frequent as before...


    Does anyone have any idea why this is happening?


    Best regards...


  • I hope its ok to post in this thread. I have been trying to boot my mxq pro 4k off of a usb stick with no luck. I followed the guide. mabe I missed something. I'm kinda new android other then I a few roots here and there. I used the toothpick method and all it does is bring me to a backup/restore type of menue but nothing about booting from usb. also i used LibreELEC-S905.ALL.aarch64-8.0.1.img and replaced the dbt file gxbb_p200_1G_mxq_pro_4k renamed to dbt.img pasted it inside the main folder and it replaced the one in there. also at first i was trying to use a usb stick but when it would load the android restore it would show errors at the bottem but when i used the sd card the errors were gone. but still not sure how to boot from it. these are the files put on the sd card SYSTEM, syslinux, KERNEL and a folder named EFI.
    [hr]


    "renamed to dbt.img ....." Is this a typo? File must be called dtb.img and not dbt.img.