[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Franco - I had a similar query regarding default frame rate. As it should be 50Hz for European users (who use TV), rather than 60Hz. See post #509 for details.


    The "fix" is to modify the u-boot settings by telnet/ssh into the box and issuing the following:

    Code
    1. fw_setenv hdmimode 1080p50hz; fw_setenv outputmode 1080p50hz


    Thank you!!!!!!!!!!!!
    but.. yes it boot at 50hz but every time I change channel it go at 60hz and after to 50hz, may be can be this?
    pipe://ffmpeg -loglevel fatal -i xx.ts -c copy -flags +global_header -strict -2 -metadata service_provider="Provaider" -metadata service_name="Service" -f mpegts pipe:1


    now I want to try this instead.
    pipe://ffmpeg -loglevel fatal -re -i xx.ts -c copy -acodec copy -metadata service_provider="Provaider" -metadata service_name="Service" -f mpegts pipe:1

  • I'm having 'no volume' issues with my Beelink MXlll ll 2g/16g(edit: It was a kodi setting issue not a libreelec issue):


    System>Settings(Expert level)>Audio output>Output configuration>Fixed(change from default).


    Things seem to be working fine but will do more testing now that the issue has been solved.
    Thanks for your efforts!

  • Hi kszaq, I finally upgraded to 8.0, works much better as 7.x I must say.


    Still experiencing that annoying HDMI-CEC bug. When my A95X is off, it seems to be disrupting my HDMI-CEC devices. My amplifier is sometimes not turning on anymore by the TV and the most annoying part is that my HDMI-ARC stops working completely. With the adapter turned off and a HDMI killer it's all back to normal.
    Everything works fine in Kodi/LibreELEC, but as soon as the device is turned off everything goes bonkers.


    Any idea what I can do about this? I do not have alot of knowledge of this device. Is it possible to upgrade the firmware of the HDMI-CEC adapter?


    Hope you can help out!


    Thanks in advanced.


    Edit: This seems to be my problem: The Hub is breaking my ARC - WeTek Community Forum
    Probably the uboot of my a95x is breaking my hdmi-arc/cec? This is probably something that needs to be solved by the manufacturer and can't be solved by you, I guess?

    Edited once, last by Xitro01 ().


  • Still experiencing that annoying HDMI-CEC bug. When my A95X is off, it seems to be disrupting my HDMI-CEC devices. My amplifier is sometimes not turning on anymore by the TV and the most annoying part is that my HDMI-ARC stops working completely. With the adapter turned off and a HDMI killer it's all back to normal.
    Everything works fine in Kodi/LibreELEC, but as soon as the device is turned off everything goes bonkers.


    Any idea what I can do about this? I do not have alot of knowledge of this device. Is it possible to upgrade the firmware of the HDMI-CEC adapter?


    Hope you can help out!


    I repeat one more time: CEC behaviour when the box is off is defined in the box firmware, not LE. You have to reach out to box manufacturer to fix this in bootloader.

  • Thank you!!!!!!!!!!!!
    but.. yes it boot at 50hz but every time I change channel it go at 60hz and after to 50hz, may be can be this?
    pipe://ffmpeg -loglevel fatal -i xx.ts -c copy -flags +global_header -strict -2 -metadata service_provider="Provaider" -metadata service_name="Service" -f mpegts pipe:1


    now I want to try this instead.
    pipe://ffmpeg -loglevel fatal -re -i xx.ts -c copy -acodec copy -metadata service_provider="Provaider" -metadata service_name="Service" -f mpegts pipe:1


    Still the same, I can't understand if it's tvheadend or libreelec/kodi or ffmpeg that produce the problem.
    For what I know ffmep it's needed only when tvheadend scan the services the first time.
    Some idea's?
    Please.

  • I repeat one more time: CEC behaviour when the box is off is defined in the box firmware, not LE. You have to reach out to box manufacturer to fix this in bootloader.


    Will do, thank you!


  • I solved this by disabling CEC sleeping, the box runs 24/7.


  • Says who, no s905x chipset has 1GB ethernet in it AFAIK. Only 100mbs/. It's the specs of the chip.


    You just ruined my day! :(

    Beelink MXIII II 2/16GB - kszaq [8.2.2.2] LibreELEC 8.2 for S905/S905X

  • Can anybody point me in the right direction of getting docker working please?
    At one point I thought it was built into libreelec but when I try 'docker info' I get 'not found'
    Thanks!

  • Hello all! Does anyone uses this build with AV - CVBS Output? Is it enabled or is it possible to enable? I have this old tv with no hdmi and need a solution for AV Output.
    If anyone as any info on this subject it would be appreciated...
    Thanks in advance.


  • DEcosse, so you type exactly this "rm -rf ~/.kodi/userdata/Database/Addons27.db" , either before or after placing the img file into the update folder then reboot ? If I chose to go back to 7.0.3.12x, can I just remove the img file from the update folder and reboot again?


    Thanks


    frem
    Are you using a Windows PC?
    You might find it easier to use Cyberduck if you're not sure about commands


    Cyberduck | Libre FTP, SFTP, WebDAV, S3, Backblaze B2 & OpenStack Swift browser for Mac and Windows


    Cyberduck is a Windows Explorer type interface and gives you a 'directory' based interface;
    it is VERY intuitive to use, especially for those not so comfortable working with Linux commands.


    Select the SSH protocol to your box's local IP address and enter the root/libreelec access
    once you connect the first thing to do is click on the 'view' tab and select 'show hidden files
    You need to do that to expose the 'update folder' and the .kodi folder


    Then you can navigate to the Addons27.db file (>kodi -> userdata -> database -> and just highlight the file & delete it (as you would if you were in a regular Windows Explorer directory)


    Then navigate back and open the 'Update' folder, and use the 'upload' icon at the top of the screen & select the image file from your windows directory
    You should see it in the upload folder if you navigate 'back' to the /storage list.
    Even if you inadvertently upload it to /storage, you can 'move' it into the update folder by just dragging & dropping within the window!


    You can either go back to the module & reboot from there, or simply from Cyberduck - from 'go' menu select 'send command' and type 'reboot' and click 'send'


    For the second part of your question, placing the new image file in the update folder and rebooting will execute the actual upgrade.
    Once it has completed the upgrade it will reboot itself and if you were to reconnect by SSH into the box, you would find the update folder is now empty.
    You cannot revert backwards once you have upgraded so you may want to save your original config if necessary.
    In actuality you won't see much difference I suspect operationally other than the K17 differences, so if you have already experienced K17 on your other box, you should probably have no need to revert.


    Footnote - even though you deleted that file, your addons from 16 will all migrate.

    Edited once, last by DEcosse ().


  • Can anybody point me in the right direction of getting docker working please?
    At one point I thought it was built into libreelec but when I try 'docker info' I get 'not found'
    Thanks!


    Docker is available as addon to install. Go to "service" in LibreELEC repo to install it first.


  • Thanks so much. I just went through the motions, as you suggested and it all went perfectly. I also added the 7.0.3.012j file to the update folder on my other box, which was running 7.0.3.012c and that went just as you said, without a hitch. The j version is no different than the c version for me. Now, I have two choices how to update my boxes. You are a star :) I may update the 7.0 box to 8.0 in a few days... Do you believe there is much difference in the two? So far I don't really see any..