[8.0.2e] LibreELEC 8.0 for S905/S905X


  • Yes I have noticed that because I have owner of nexbox a95x this is only in libreelec 8.0 build only because of amlogic decoder bug...if u use spmc and enable amcodec acceleration in spmc.u will.also notice that this video masking.
    .

    Edited once, last by rajawaqas ().

  • Yes I have noticed that because I have owner of nexbox a95x this is only in libreelec 8.0 build only because of amlogic decoder bug...if u use spmc and enable amcodec acceleration in spmc.u will.also notice that this video masking.
    .


    Cheers, thanks. I thought I was going mad. Software deciding seems to play fine so will leave it like that for now.


  • I'm still getting juddery playback on 60fps videos with these Krypton builds which playback totally fine on Jarvis. I'm watching a video now between the 2 builds which is actually 59.940fps and completely smooth on Jarvis and as soon as I flash to Krypton becomes really juddery. Could that be connected to the fractional frame rate issue? I can provide a sample video if needed but it's quite large and ripped from Youtube.


    I tested your sample file with Jarvis .012g and you are right: there is almost no judder (perhaps a "hiccup" or two) and the picture seems more crisp.


    I think I'll switch back to Jarvis...

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

    Edited once, last by minimoe ().


  • HDMI-CEC is working on android (M18 with Mbox name on the TV), but not with the latest LE builds. Can you send your LE settings for me?


    I attached a screenshot of my CEC setting but I believe it's not the cause of your problem.


    On my Toshiba TV, it was 'MBOX' in the past (many builds back) but it is now shown 'Kodi'. Also if you don't find it on your TV CEC settings, reboot of your Beelink M18 with your TV turned on should help. You need to let your TV recognize your Beelink M18.


    As far as I know, there's been an update to the CEC code in the latest build.


  • what dtb did you use? Is your device a S905 or S905x? 1GB or 2GB? if it is a S905 and 1GB then did you try this dtb?


    experimental


  • I attached a screenshot of my CEC setting but I believe it's not the cause of your problem.


    On my Toshiba TV, it was 'MBOX' in the past (many builds back) but it is now shown 'Kodi'. Also if you don't find it on your TV CEC settings, reboot of your Beelink M18 with your TV turned on should help. You need to let your TV recognize your Beelink M18.


    As far as I know, there's been an update to the CEC code in the latest build.


    Thanks! I tried everything, but sadly it's not working, only with earlier builds & under android. :(

  • Thanks! I tried everything, but sadly it's not working, only with earlier builds & under android. :(


    Not sure kszaq include the following in his beta6 build, I found it on wrxtasy's Odroid C2 latest build description.
    - @popcornmix's improved CEC adapter - user adjustable remote response times - backports from Kodi 18


    The CEC Adapter version was bumped from v4.0.1 to v4.0.2 in beta6 though.

  • Hi


    I am trying your 7.95.beta6 (2017-02-11), the audio on movies and TV series only plays Dolby Prologic.
    I cannot get digital audio, in the previous beta the digital audio formats played ok. I have a Tronsmart S95 Vega Telos


    Thanks for all you work!!


    Henk Westra
    Netherlands

  • kszaq sorry to bother you with this, I am trying to build beta6 from source and I get an error on peripheral.joystick


    make[2]: *** [CMakeFiles/peripheral.joystick.dir/build.make:711: CMakeFiles/peripheral.joystick.dir/src/storage/DeviceConfiguration.cpp.o] Error 1
    make[1]: *** [CMakeFiles/Makefile2:100: CMakeFiles/peripheral.joystick.dir/all] Error 2
    make: *** [Makefile:128: all] Error 2


    full log is here
    LibreELEC.tv/build.LibreELEC-S905.arm-8.0-devel/peripheral.joystick-eeb6fec/src/ - Pastebin.com


    past builds worked fine.


    any idea what might be going on? thanks!


  • do you have 'sync playback to display' enabled?

    Edited once, last by spoony100 ().

  • kszaq, I modded your installtointernal in way to also backup/restore original android partitions.
    This backups all android partitions as compressed image
    in /storage/backup by type "ba" instead "yes" and restore them with:


    installtointernal path/to/android/partition/backup


    a bit raw, but it works.

  • what dtb did you use? Is your device a S905 or S905x? 1GB or 2GB? if it is a S905 and 1GB then did you try this dtb?


    experimental


    Thanks for this one, i tried this one before, but no USB or wifi with this DTB (ETH and remote working).
    I was able to install to NAND, but when i power on, the screen remains black.
    still able to boot on the SD card


  • Sorry for wrong first answer.
    Explanation is very simple. In previous version was all live streaming decoded to PCM. e.g. DD 5.1 -> 5.1 Multichannel PCM.
    If you set in Setting -> Audio -> Channels: 2.0 and allow passthrough then 5.1 Multichannel is encoded to DD 5.1 to be able pass it to SPDIF. It looks like passthrough. But changing channel configuration 2.0 to another you get PCM Stereo.
    New build has true passthrough independent on channel configuration. If you prefer old behavior you can set it by allowing 'Sync playback to display'".


  • Hello...


    I finally found the problem...


    The issue was with the use of HDMI passthrough in Tanix TX5 Pro... I tested with Jarvis and Krypton and i had the same results... With Mini M8S II and Jarvis version this issue did not exist...


    For some reason TX5 Pro needs to be connected directly with an optical cable from SPDIF and then everything is alright...


    What puzzled me is that the issue was happening only with AC3 and that DTS was fine...


    One more note, i had this issue some years ago with XBOX360, so most probably this is something with my amplifier...


    Thank you all for your help...

  • Are you planning to work on SUSPEND?
    Everything else works fine for me but booting takes quite a bit of time (slow SD in my case) so suspend would be awesome!
    Bqeel M9CMax is what i am using