[7.0.3.3d] LibreELEC 7.0 for S805

  • Okay, just wanted to watch another stream again.
    Same problem like before.
    When I was testing right after your tipp, everything was fine...


    I will wait for the next build, then take a look again.


    Was something in the logs?

    Device1: Wetek Hub: LibreElec by kszaq 8.1.3
    Device2: FireTV Stick + SMPC 16.4.2
    Device3: MK808B+: LibreELEC 7.0.2.4 (kszaq)

  • kszaq , yes the last log. ok no worries, im out of town this week anyway maybe they will get back to you, i really appreciate your help. Maybe ill just send you a box... LOL


    Frank

  • A new build for you to test, a bit experimental one. I'm now leaving for 4-5 days, I hope you can get me some feedback by the time I am back.


    WARNING: NAND users are strongly advised to backup their LE settings to an external drive in case new NAND driver fails! If the new release doesn't boot, here's what you can do to revert to 7.0.1.1 without wiping data:

    • prepare SD card for NAND installation
    • delete factory_update_param.aml from SD card
    • boot to recovery using "tootpick" method
    • flash the ZIP file from SD card


    7.0.1.2 7.0.1.2


    Commits from 7.0.1.1 to 7.0.1.2: Comparing 7.0.1.1...7.0.1.2 · kszaq/LibreELEC.tv · GitHub
    Kernel commits from 7.0.1.1 to 7.0.1.2: Comparing 9bf155dcbb...9d4e014 · kszaq/linux · GitHub


    Changelog:

    • added SSV6051Q WiFi driver (not usable yet)
    • updated NAND driver to latest Amlogic release
    • turned off CEC debugging by default
    • updated m201d device tree to closely match stock
    • added a bunch of new Kodi patches for testing from Wrxtasy's Odroid build, Koying's SPMC, Popcornmix RPi build and Christian Troy's WeTek tree:

      • fixes CPU usage reporting for turned off cores
      • simplified display mode handling
      • added High Quality GLES scalers
      • added YADIF 2x deinterlacing for SW-decoded videos
      • added a setting for configuring CEC button repeats
      • added a patch to speed up thumbnail loading
      • added a patch to lower stuttering when opening menu while playing video
      • added a proper fix for skin settings not being saved
      • added a caching patch when video and audio are starving



    Known issues:

    • V3_1 board cannot wake up from suspend/power off by pressing remote power button (u-boot bug)
    • 29.97 progressive videos may stutter
    • sometimes CEC may not work
    • power LED on not officially supported boxes may not work as intended (too many boards to support them with a single build)
    • no HD-Audio passthrough and multichannel audio output
    • DVB support is experimental, some USB DVB tuners don't work at all

  • Nice, thank you kszaq:)!

  • Updated and video playback does seem much better. Will give more detailed feedback in a few more days after more testing / viewing.


    Cheers K, and all the LE team, improvements do seem to be moving faster with LE.

    Running:
    S805 - MXQ.arm 7.0.3.1 from Nand on all black MXQ, board number: 'AM_MXQ_A 20150825'

  • Updated...everything running great. I did notice the CEC settings for repeat and timeout. Very nice.

    MK808b Plus stick running LibreElec 7 with Retroarch 1.3.6 running as an addon

  • MK808B+ updated and no problems or lost settings.


    Fresh installation + south park addon out of the official kodi repo -> audio stutters
    After changing a few settings in the system->audio tab the stutters are gone. (I have to look which exact settings that was)


    Changing any of the sync hz with tv etc haven't worked. V-Sync either.
    Changing the synv with tv setting, were I can change a time to wait, helped a litte, but the sound was gone for a period and then was okay. (Hope you can understand what I mean)



    So, the only settings I really needed to chagen were inside the audio settings.

    Device1: Wetek Hub: LibreElec by kszaq 8.1.3
    Device2: FireTV Stick + SMPC 16.4.2
    Device3: MK808B+: LibreELEC 7.0.2.4 (kszaq)

  • I have one of these builds running on a box and I have added the correct remote.conf (thanks to kszaqs excellent help ).
    Does anyone know how to package that build as an img file again and send it to someone to install as first time with the remote control working?


    I also am trying to get the tuner drivers, so when/if I get them working I would also be packaging those.


    Do I need to do it from a PC, or can I use the SDCard build with the info in it?

  • Hi, I updated my MK808B Plus to 7.0.1.2. All seems okay so far, except the Shutdown seems to hang. Suspend works, but CEC doesn't seem to be happy after a Suspend. I remember this happening with a previous OpenElec build too.


    I have reverted to 7.0.0.1 (which I was using before), and it's working again.

    LibreELEC running on MK808B Plus from NAND

    Edited once, last by nigelg ().


  • I have one of these builds running on a box and I have added the correct remote.conf (thanks to kszaqs excellent help ).
    Does anyone know how to package that build as an img file again and send it to someone to install as first time with the remote control working?


    I also am trying to get the tuner drivers, so when/if I get them working I would also be packaging those.


    Do I need to do it from a PC, or can I use the SDCard build with the info in it?


    Read what you have written and see if anyone reading your post can work out what build version you are using and what box you are using ????
    Please create a signature with all details and then people with the same box and LE Version will help you.


  • Read what you have written and see if anyone reading your post can work out what build version you are using and what box you are using ????
    Please create a signature with all details and then people with the same box and LE Version will help you.


    I have read it and I didn't see it as relevant as I am only looking how to repackage it as an img.
    I thought that there may be a way to do it from LE, as I am using an ancient PC with very little space on it. But it may be able to handle something like writing an img file from SD.
    I am using LibreELEC-S805.MXQ.arm-7.0.0.2 build on an S805 box and the only thing changed\added is my remote.conf file.

  • I have read it and I didn't see it as relevant as I am only looking how to repackage it as an img.
    I thought that there may be a way to do it from LE, as I am using an ancient PC with very little space on it. But it may be able to handle something like writing an img file from SD.
    I am using LibreELEC-S805.MXQ.arm-7.0.0.2 build on an S805 box and the only thing changed\added is my remote.conf file.


    I use RPI Baker but i am on a Mac. Can backup as image file. Sorry i dont use pc
    I believe you can create a backup with the remote.conf already installed and it will be in the backup.
    When you restore from previous backup (the backup with the remote.conf) it will be working.
    Cant help any further.

  • Hello to everyone, i ask for somebody has configure the remote control for MXQ Box? the black one??? i use the Config file from Andriod firmware but some buttons are missing. If you have all config file please share with us.... Thanks


  • Hello to everyone, i ask for somebody has configure the remote control for MXQ Box? the black one??? i use the Config file from Andriod firmware but some buttons are missing. If you have all config file please share with us.... Thanks


    I know you are new here but you will see in first post that it is custom and should be a requirement for everyone to make a signature in this forum settings with their box type, in your case All Black MXQ and also your Board Identification inside your box if possible.
    You should put the Version of LibreELEC you have flashed (HD18Q or ARM ).
    Also are you running nand or external SD version.
    I will give you an example (regarding remotes) with my All Black MXQ (see signature below) it works with the ARM Version. I have another All Black MXQ that works with the HD18Q Version.
    The all black MXQ's are all different inside and all have different versions of Android pre installed.

  • I have read it and I didn't see it as relevant as I am only looking how to repackage it as an img.
    I thought that there may be a way to do it from LE, as I am using an ancient PC with very little space on it. But it may be able to handle something like writing an img file from SD.
    I am using LibreELEC-S805.MXQ.arm-7.0.0.2 build on an S805 box and the only thing changed\added is my remote.conf file.


    I don't know for sure but if you are running off SD card I'm pretty sure that with win32diskimager you can either read from the SD or write to it. Try taking out your SD card and read image from it then write that image to another SD. Nothing to loose by trying that?


    Sent from my SM-G900F using Tapatalk

  • I have read it and I didn't see it as relevant as I am only looking how to repackage it as an img.
    I thought that there may be a way to do it from LE, as I am using an ancient PC with very little space on it. But it may be able to handle something like writing an img file from SD.
    I am using LibreELEC-S805.MXQ.arm-7.0.0.2 build on an S805 box and the only thing changed\added is my remote.conf file.


    The good way to do something like you are asking is: clone the code from github, add your remote changes and also your DVB modules and recompile libreELEC.
    The WRONG way but should works by the way: take your SD card with your modified libreELEC system, put it in a PC with a SD reader and clone it with things like dd if=/dev/sdb(your SD) of=/home/yourname/cloned.img bs=4M than you can write it to another SD card: for booting it you should also modify uboot (if the box in which you are going to put the cloned sd is new) with the aml_autoscript. There are a lot of downsides like this if you have a 32GB sd card the resulting image would be 32GB also if your "destination" sd is 32GB and the source sd card is 8GB you will see only 8GB ....

    Edited once, last by anthontex ().

  • ... I remember, that the is a bugfix for remote-control Problems with the black MXQ-Boxes in kaszaqs “S805-OpenELEC Tread“ at freaktab, which I used almost one year ago, to fix this Problems. This should work with LibreELEC, too.


    Greetings
    Mark


    Gesendet von meinem H60-L04 mit Tapatalk