[S812] MIII Plus 2Gb\16Gb eMMC

  • This works great as designed for my living room Tronsmart MXIII-plus.


    But I may need to keep SPMC 16.4.2 around on my bedroom setup for a number of reasons mostly dealing with an unorthodox sound setup.

    OK ignore this. I figured out a much better way to get the alarm sounds I want. (you probably were already ignoring it anyway) :-p


    But now I have another REAL issue, that I think should be fixable.


    First my hardware.


    Tronsmart. MXIII-PLUS with Cortex-A9 Amlogic S812 Quad-core CPU and Octa-core Mali-450 GPU.


    The latest and greatest BALBES Libreelec runs well on this in my living room. But I have a problem with the screen in my bedroom.

    The screen is a Westinghouse SK-26H735S (yes old screen but still serviceable)


    The problem is that old screen, really really REALLY does not do EDID well and does not like the default startup mode that the latest and greatest version of BALBES Libreelec uses.


    The screen hands me about 5 or so "Invalid mode" splash screens until KODI finally comes up and since I have the correct mode in KODI I finally get a picture.


    Is there anyway I could setup a xorg.conf for the Mali-450 and force a resolution?


    All the pages I have read out there, are only to setup an xorg.conf when you have nvidia hardware.


    Thanks for any help anyone can give me.

  • I have just tested Minix\20170609 it will not boot from SD card says filesystem corruption has been detected

    it was the same if i tried update TAR but it does boot from USB

    Do I understand correctly that the latest version (20170609) you checked, does not start with SD card and USB stick ?


    How to check "activate the media-boot" ?

    Rough estimate, if the connected external drive (which uses multiboot) TV box does not start the internal firmware, so multiboot is enabled. Accurate assessment - show the output of the command "fw_printenv".


    Same problem here with Balbes latest builds for LAN1000. Since the builds after 20170418 they don't boot anymore from SD-card.

    Have you tried to use a USB device ? Have you tried to use the image MXIII_Plus ?


    On all these verion I've got the same issue regarding performance behavior (High Cpu usage, video stuttering) which I do not have

    Whenever possible, I try to look at your logs.


    However, wifi is not available anymore.

    On the previous images it worked ?

    on the last S812lan1000, S812/filesystem/usr/lib/modules-load.d/am_net8218.conf is missing.


    if this module is not loaded, the MINIX X8-H users didn't get LAN.

    I will check this information.


    OK ignore this.

    You wrote, that you already found the solution earlier.


    Is there anyway I could setup a xorg.conf for the Mali-450 and force a resolution?

    You can create your option settings and to gather with him a new way SYSTEM (it's Packed with root system).



    To all

    update image MXIII_Plus 20170614

  • USB works but the benefit for me is that I don't have to always remove the USB mouse when I boot from sdcard.

    Any ideas why the sd card gives the corruption error on the last few builds?


    Cheers

  • You can create your option settings and to gather with him a new way SYSTEM (it's Packed with root system).



    To all

    update image MXIII_Plus 20170614


    Just tried 20170614 on both my livingroom and bedroom Tronsmarts. Working great as usual, except for the "Invalid format" Libreelec splash screen issue on my bedroom setup I described before. I think you were saying that that is just the way its built into SYSTEM. I am going to keep looking though. There has got to be some way to fix that, maybe through modlines or something else. I am not sure how to go about "building option settings" All I am familiar with is the old school linux xorg.conf

  • Hi datrh


    Great to see that you're modifying the builds of balbes150 to get additional drivers in.

    Many X8-H Plus owners are desperate to get Wi-Fi working, and, contrary to the X8-H, the Plus has the AP 6335 Wi-Fi module.

    Maybe you can also add the driver for the AP 6335?


    The Broadcom drivers are outdated and don't work, but this page may help:

    WIFI module AP6335(bcm4339) get stuck on androi... | NXP Community


    I'm especially referring to this part in the answer:



    Good luck and thanks to you and balbes150 for all the great work and for not giving up!

  • Assembled using corrected patch Demetris test image. Visitors can try (version Test_20170614)

    Many thanks for your efforts and help with yours and with Demetris images.


    I have an M8S tv box (clone) - 2G ram, 8G rom, 100M ethrenet, BCM4330X wifi


    I could successfully boot and install your LibreELEC-S812.LAN_100.arm-17.3.img.gz on an SDram and USB stick, however, this (and also previous builds) couldnt run tvheadend42. I could install and use only tvheadend4 and have faced some DVB sudio decodin issues.


    I have tried LibreELEC-S812.Test.arm-17.3_20170614.img.gz on a USB stick on the same tv box and could install it on a USB stick. The first problem which I have faced is that there was no LibreELEC repository available and I couldnt install and test tvheadend42 and an HTSP PVR client.


    Later this week, I will try and test this image also o another ENY M8S tv box I own - 2G ram, 8G rom, 100M ethernet, AP6330 wifi. In the past I couldnt install any of yours or Demetris images onto an SDram with this TV box (some have been stucj with the M8S logo and some have reported a corrupted file system).

  • Just tried 20170614 on both my livingroom and bedroom Tronsmarts. Working great as usual, except for the "Invalid format" Libreelec splash screen issue on my bedroom setup I described before. I think you were saying that that is just the way its built into SYSTEM. I am going to keep looking though. There has got to be some way to fix that, maybe through modlines or something else. I am not sure how to go about "building option settings" All I am familiar with is the old school linux xorg.conf

    If I understand correctly Your problem.


    You can try to specify a different value for the first system startup in the file s805_autoscript. The list of available options here.

    LibreELEC.tv/platform_init at Amlogic-Krypton · 150balbes/LibreELEC.tv · GitHub


    For this you need to download a text file

    LibreELEC.tv/s805_autoscript.src at Amlogic-Krypton · 150balbes/LibreELEC.tv · GitHub


    To edit a line

    LibreELEC.tv/s805_autoscript.src at Amlogic-Krypton · 150balbes/LibreELEC.tv · GitHub


    add a parameter with the desired screen resolution (e.g. 480)


    setenv bootrootfs " boot=LABEL=LIBREELEC disk=LABEL=LIBREELEC_DISK BOOT_IMAGE=kernel.img hdmitx=cecf hdmimode=480"


    After that you need to put the text file working binary file. This requires mkimage utility (I think you are familiar with Linux and know how to find it).


    mkimage -A arm -O linux -T script -C none -d s805_autoscript.src s805_autoscript


    Details on the Assembly is there.

    GitHub - 150balbes/Amlogic_s905: SRC for Amlogic S905 (Tronsmart Vega S95 Telos Meta Pro) etc.


    And then there is collection of different files to run different systems, where you can find different examples.

    Amlogic_s905/script at master · 150balbes/Amlogic_s905 · GitHub

  • Many thanks for your efforts and help with yours and with Demetris images.


    I have an M8S tv box (clone) - 2G ram, 8G rom, 100M ethrenet, BCM4330X wifi


    I could successfully boot and install your LibreELEC-S812.LAN_100.arm-17.3.img.gz on an SDram and USB stick, however, this (and also previous builds) couldnt run tvheadend42. I could install and use only tvheadend4 and have faced some DVB sudio decodin issues.


    I have tried LibreELEC-S812.Test.arm-17.3_20170614.img.gz on a USB stick on the same tv box and could install it on a USB stick. The first problem which I have faced is that there was no LibreELEC repository available and I couldnt install and test tvheadend42 and an HTSP PVR client.


    Later this week, I will try and test this image also o another ENY M8S tv box I own - 2G ram, 8G rom, 100M ethernet, AP6330 wifi. In the past I couldnt install any of yours or Demetris images onto an SDram with this TV box (some have been stucj with the M8S logo and some have reported a corrupted file system).

    Please note. We Dimetris is different multi-boot. To start the image you need to use the system multi-boot, which goes along with the image. If you want to use images of Dimetris, you need to activate the multi-boot its image Dimetris. If you want to try my images, you need to re-activate multi-upload of my image. I suggested Dimetris go to a single system multi-boot were compatible.

  • Firstly thank your for your work and open mind, (with Demetris collabo)


    But I have no luck I couldn't success to install my M8S with your image

    I tried LibreELEC-S812.LAN_100.arm-17.3_20170614.img and LibreELEC-S812.Test.arm-17.3_20170614.img

    both of all. When I use .update folder in installed Demetri's image 'File system corrupted' error display

    and I tried record SD and USB memory with rufus,


    When SD inserts : M8S logo blinking contiues, and not change

    when USB inserts : into android recovery and that's all


    Although I couldn't succeed but I have to say thank you very much balbes150 :)


  • 1. Write the image to SD card

    2. Upgrade multi-boot (using a toothpick or Android app). When you activate the multi-boot method of a toothpick - do not hold down the button long after the appearance of the screen saver button to let go.

    3. If the system fails to boot from SD card (within 10 minutes). Record the same image on the USB flash drive. Turn off the TV box. Unplug the TV box all USB device. Connect the USB flash drive. Turn on the power (buttons NOT push). 4. If the system does not start from USB stick. Try new image (write to USB) and instrucktion step 3.


    Pay attention, this procedure is suitable only for those images that are on my website. For images Dimetris need to use a different start order and check (he described in his topic).

  • 1. Write the image to SD card

    2. Upgrade multi-boot (using a toothpick or Android app). When you activate the multi-boot method of a toothpick - do not hold down the button long after the appearance of the screen saver button to let go.

    3. If the system fails to boot from SD card (within 10 minutes). Record the same image on the USB flash drive. Turn off the TV box. Unplug the TV box all USB device. Connect the USB flash drive. Turn on the power (buttons NOT push). 4. If the system does not start from USB stick. Try new image (write to USB) and instrucktion step 3.


    Pay attention, this procedure is suitable only for those images that are on my website. For images Dimetris need to use a different start order and check (he described in his topic).

    Of course I did that your explain exactly

    I've used your image also in the past

    But I couldn't get success what a pity I am


  • OK I built a new s805_autoscript, but I am not exactly sure how to get it back into the correct position on the box.


    Do I need to "chmod a+w /flash"?


    That sounds uber-dangerous.

  • OK I built a new s805_autoscript, but I am not exactly sure how to get it back into the correct position on the box.


    Do I need to "chmod a+w /flash"?

    The script to be on the first partition (FAT). It is not required to establish rights. You can save the primary version on the PC or rename it, and copy your new version. This Not dangerous . If you have doubts, show the contents of the new script.

  • The script to be on the first partition (FAT). It is not required to establish rights. You can save the primary version on the PC or rename it, and copy your new version. This Not dangerous . If you have doubts, show the contents of the new script.

    The following did not fix it...


    setenv bootrootfs " boot=LABEL=LIBREELEC disk=LABEL=LIBREELEC_DISK BOOT_IMAGE=kernel.img hdmitx=cecf hdmimode=720p"


    I noticed that one has a "p" on it where the others don't.


    I know that 720p is the correct mode for that screen.


    BTW, this really is only a minor annoyance so if I never get it fixed, its not a big deal.


    HMMM. I just noticed. I wonder if I should remove hdmitx=cecf

  • Hi,


    can a Minix X8H-plus user try the wifi with this one : ?26t4whbkfbddvh7 ?

    I've added extra wifi firmwares.


    I've tested this build on my X8-H and it haven't broken something : everything works as usual. (except 4K (but the X8-H has limited support/no support) and X265 (not supported by the X8-H))



    Again : it's a tar file.

    to update your box, the ARCH has to be S812.arm. if it's not the case, you have to use the .nocompat trick.


    All credits to balbes150

  • Hi,


    can a Minix X8H-plus user try the wifi with this one :LibreELEC-S812.LAN1000updX8HP.arm-17

    LibreELEC-S812.LAN1000updX8HP.arm-17.3



    I've added extra wifi firmwares.


    I've tested this build on my X8-H and it haven't broken something : everything works as usual. (except 4K (but the X8-H has limited support/no support) and X265 (not supported by the X8-H))



    Again : it's a tar file.

    to update your box, the ARCH has to be S812.arm. if it's not the case, you have to use the .nocompat trick.


    All credits to balbes150


    edit :: wifi still not working new tar with wifi

    datrh · GitHub

    my github :

    LE9-Kodi18.6 => this is the one to use

    Edited 3 times, last by datrh ().