[S812] MIII Plus 2Gb\16Gb eMMC


  • 1. Updated test image for Minix (20170514).
    2. Question to those who uses the image MXIII_Plus, please compare how it will work the way LAN1000. Is there a difference in behavior. I want to leave one of these options. I have both work the same.


    Hi bables150,
    With LibreELEC-S812.MXIII_Plus.arm-8.0.2.img.gz 13.05.2017 05:24 using ethernet port, Kodi Speedtest add-on benchmarks @ ~108/10 which is about same speed at desktop computer. Somewhere I have a app to test LAN speed between devices on network which I'll try to find and test out as well.

  • bables150 if and when I get a chance I may attempt to build myself with that one working dts/dtb file...is your build process much different than that of the wiki?


  • 1. Updated test image for Minix (20170514).
    2. Question to those who uses the image MXIII_Plus, please compare how it will work the way LAN1000. Is there a difference in behavior. I want to leave one of these options. I have both work the same.


    2- Minix X8-H Plus with MXIII_Plus was getting random system lockups, LAN1000 for last 6 hours no freezes and no lockups. Strong and steady


    Thanks for the hard work on these builds.

  • I place the .tar file in the Update folder of the LAN1000 of the 13.05.2017 build to update, but then, after getting a nice LibreElec splash screen and readable status updates on the boot-up of Linux, the screen goes black and nothing happens. Kodi never comes up.


    Anyone else have that problem? I don't use multiboot, just flash into internal memory.


    My device is a Minix X8-H Plus.

  • This works great as designed for my living room Tronsmart MXIII-plus.


    But I may need to keep SPMC 16.4.2 around on my bedroom setup for a number of reasons mostly dealing with an unorthodox sound setup.


    First off, is it possible to SPECIFICALLY TURN ON the TOSLINK output of the device and TURN OFF the HDMI sound.


    If I do not specifically TURN OFF the HDMI sound, because of the way I have things setup, I will get a double "echo" sound on everything.


    Second, (I know I have asked this before) I know that Libreelec uses a custom linux kernel with alsa sound. (I am fairly familiar with fedora and other linux's) Is it possible that KODI is setup to use alsa DMIX? If that is the case, then it should be possible to play a sound using aplay (which is part of the alsa pacakage) and not interfere with a playing sound stream from KODI. I am interested in using cron+aplay to setup an alarm sound, that does not interfere with a playing stream on KODI. (both sounds going at the same time). Otherwise, I wonder if there would be a way to send a raw sound directly to a /dev device. (I am not sure if this would interfere with KODI or not though.


    My current setup in my bedroom, has the toslink of the tv and the toslink of the Tronsmart running through converter boxes to a mini mixer. The reason I have it setup this way is that no matter what device I am using, an alarm (set using the standard android clock) will sound. If I update SPMC to anything past 16.4.2, then SPMC starts using the latest sound API on android thus making it stop when an alarm kicks in. (I am assuming that krypton will cause me the same problem). This is why I am exploring different options to get around this.


    I am asking here because this is supposedly "official" unofficial build for S812's :P


    What is making me doubt I can use the toslink device at all is...

    Code
    LibreELEC:~ # aplay --list-devices
    **** List of PLAYBACK Hardware Devices ****
    card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: AML PCM dummy_codec-0
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF PCM dit-hifi-1
      Subdevices: 1/1
      Subdevice #0: subdevice #0

    Edited once, last by kingsombra ().

  • So I've finally found the factory images for my device, which is a bcm4335 S812. The cyx_m8s_v8.6_bcm4355 (path=) images are the proper ones, it is slow going but I am currently pulling the latest I could find down from baidu pan.


    That said, here is the 100% proper dts/dtb for this device (m8m2_bcm4335_n200C_1G) - I bought it and it said it has 2G ram, I think it iusually shows up as 1.6GB ram or so...yay China.


    MEGA


    If anything changes with the newer img file I found, I'll put those up once done downloading.

    Edited once, last by ilikenwf ().

  • balbes150


    Is there something changed in the compilation of your versions since your 20170414 builds. Those I can write happily to sd-card and boot from is. With the newer versions 20170418 and 20170513 I get the corrupted file system error. I thought to be smart and update the 20170414 build wit the update tar of 20170513, but guess what ... when rebooting i got the corrupted file ssytem error again. Didn't try form usb, but as it worked with the older versions I wonder why not with the newer versions.

  • I finally found out what Broadcom chip the Minix X8-H Plus has. Thing is, the X8-H Plus is one of the few with 802.11ac.


    The chipset is: Broadcom AP6335 (802.11ac).


    Maybe that is the reason that most of balbes150's builds don't support Wi-Fi on the Minix X8-H Plus?

    Does this info help make it work?

  • So I've successfully built an LE image several times, but it just bootloops with only the S812 logo screen splash, while @balbes150 's builds at least boot the kernel and hang at the filesystem error...


    What am I doing wrong? I'm using his repo, and making as so:


    Code
    PROJECT=S812 DEVICE=M8S ARCH=arm make image
    • Official Post

    An updated version of the image MXIII_Plus 20170206. Pay attention, changed the numbering of the images. Changed the script activate the multi-boot and system start up. The new script allow you to start the system in the presence of simultaneously connected multiple USB. For new scripts, you must re-activate the multi-boot using the new script aml_autoscript and use the new script s805_autoscript. These scripts can be used with old images. Updated the script activate the multi-boot boot.src Minix Neo H8.

  • Are you saying I can use the MXIII_Plus build in a Minix Neo X8-H Plus?

    The Minix also has S812 and gigabit network, but I believe the MXIII_Plus has the AP6330, am I right? Is it safe to try?

  • @balbes150 Thanks for the new build.


    I have tested it on MINIX X8-H Plus and identified a number of issues


    * WIFI won't work anymore after upgrade (No Wifi network is visible in connections)


    * Machine is slow

    * Most links (Openload, exashare) won't work anymore.


    I have used the tar image and upgraded by moving file to upgrade folder on the box.


    When I rolled back to previous 8.0.2 version everything was working fine


    Should we also update s805_autoscript to resolve above issues ?


    Thanks again for all your work and efforts

  • balbes150 so, I've built your latest 17.3 and now have gotten it to partially work with my bcm4335 S812 M8S. I am using a patch that adds the dts file from the stock android.


    Steps:

    1. Rename s805_autoscript to aml_autoscript
    2. Manually mount /dev/mmcblk0p1 and then mount SYSTEM to sysroot (how do I automate this? I'm not new to Linux but am new to LE), exit, and then boot

    Playback and wired networking appear to be working perfectly, wireless networks did not appear in the setup menu but the interface appears to be working, which is strange...


    I also need to get the remote.conf from my stock android as the volume buttons don't currently work as well.


    Video and audio quality appear to be be better (much better) than they were in Android. The strange thing is that these boxes' dts files say they are 1G devices, but then the android kernel shows 2GB at boot - think it may be some kind of Chinese knockoff thing there? My only other guess is that perhaps half of that is saved for vram?


    Help me get the boot mounts setup and I can put in a pull request. :D
    Work in progress: this seems to add proper working support for the bcm4335 m8s, mostly,… · ilikenwf/[email protected] · GitHub


    Also, hypothetically, if I wanted to get the retroarch stuff working, is it just pulling that stuff into the build, or does it go deeper than that?


    Thanks for all your work!

    Edited once, last by ilikenwf ().

  • @balbes150 Thanks for the new build.


    I have tested it on MINIX X8-H Plus and identified a number of issues


    When I rolled back to previous 8.0.2 version everything was working fine


    xbmcking are you saying that you have an LE 8.0.2 build which has Wi-Fi working on the X8-H Plus? Which one are you using?

    I would be so happy if I can get mine to work, even with 8.0.2!


    I'm also using the .tar file to update, as I don't need multiboot or running from USB or SD, I'm just working from internal, which is fine.

    Don't need Android anyhow and find it all too complex otherwise...


    I just updated my Minix X8-H Plus to the LibreELEC-S812.MXIII_Plus.arm-17.3.tar and guess what... that works! Great work, thanks balbes150!


    But still no Wi-Fi working, no 4K and no x265 playback.


    Don't really care about 4K and I've actually never seen x265 work on any build, so... if we'd just get Wi-Fi working, then that would be the perfect build!

    Edited 2 times, last by Arcee ().

    • Official Post

    If you used my GIT, you do not need to rename the script s805_autoscript. Leave it as it is. Activate the multi-boot and the system should normally be run by itself. Pay attention, the activation may be performed once and necessary SD card. Ie You need one time to record your image on the SD card. Use the update mode from Andoid or method of a toothpick. Once you upgrade bootloader, you can use to embed LE any USB flash drive or SD card.