Test LibreELEC images with KODI-19 for S9xxx

  • Followed Erbas's instructions, but new problem erupted. When I insert the microSD card, and depress the "reset" button, my box boots into TWRP. Same thing if I type "reboot update" from a terminal emulator.


    I am using Alvatech's ATV ROM, which has a builtin TWRP. Just did a clean install yesterday.


    [ROM] Beelink GT-King ALVATECH Android TV - ATV (9.0 Pie) S922X - FreakTab

    Dear clarkss12,


    I'm using beelinks official firmware, if it doesn't boot to a sd/usb image just use "switch os" reboot option under android then it works for all third party firmwares.

  • Dear clarkss12,


    I'm using beelinks official firmware, if it doesn't boot to a sd/usb image just use "switch os" reboot option under android then it works for all third party firmwares.

    I am running Alvatech's latest ATV ROM and it has the "switch" option for the power options. However, it still reboots to TWRP. Have not installed the factory version yet........

  • I downloaded and installed the LibreELEC-AMLG12.arm-9.80-nightly-20200119-635fa1e-box.img.gz file that I got from the link you posted. However, a lot of the device trees are missing, including for the "King".

  • Swapped OS on my Beelink GT King, that does not contain TWRP. Booted right away into LibreELEC from Android using a terminal emulator app and typing "reboot update".


    It boots and goes into the setup screen, but can't get an internet connection. The Ethernet connection does not connect, gets some strange IP address. The WiFi will not pick up an IP address at all........


    Thanks Balbes150 for working on these Amlogic devices..........

  • I have some crazy hickups.
    Last working version for a few of my boxes is the 9.02 release and I can't understand, why it won't boot to everything after that.
    Only blackscreen, no boot at all.
    Is there something I have missed? AML 905X and 905W boxes, both of them won't boot with the same SD card, which worked with an older release.

  • good evening, a greeting with affection to all users of the forum, unfortunately I have very little time available and I cannot read all the pages of the 3rd, I have the Minix NEO U9-H 4K Amlogic S912-H Octa-core Cortex A53 HDMI 2.0 4K 2GB/16Gb

    I wanted to know is there a build of libreelec / kodi 18.x with 4k support, remote controll, samba, etc, stable or at least without too many defects? thanks so much .

  • Hi to all.


    Can someone please explain how to install these images? I have a Mini M8S II 2 / 16GB (S905X) device and I download both the "amlgx.img.gz" and "amlg12.img.gz" latest versions. After installing with LibreELEC.USB-SD.Creator.Win32, LibreELEC does not turn on from the card, only the original android. I also uploaded the appropriate (I hope) dtb file from the folder and changed its name to dtb.img.

    Am I doing something wrong or will this version just not work with my device.


    I am asking for advice.

  • ..to use these images properly,

    you need to change the name of used dtb file(fitting to your hardware) in FDT line in uEnv.txt (no copy & rename).


    After inserting sd card you need to start your box with pressed reset-pin(mostly inside of av port, pressed with small plastic stick or toothpick..). Then LE should resize partition and reboot to le (and start basic setup).


    If system doesn't boot try other dtbs delivered with the image..I don't know your board, but with a s905x p212 should be a good try..also use a mouse and or keyboard until you setup your remote..

  • хммм, когда вы заявляете более ранние версии LibreELEC (сколько лет?) и ссылаетесь на ukmark62 ранее, что вы рекомендуете для проверки текущего статуса и исправления?


    Также, чтобы установить и затем поддерживать возможность загрузки между LibreELEC, установленным на SD (последняя версия, например, 20190716), в Android, работающем на EMMC, и наоборот [user = '4'] chewitt [/ user] упомянул, что не планируется поддерживать мультизагрузку функция в официальной версии LibreELEC, так как бы пользователи KVIM2, такие как я, могли обойти это запланированное ограничение. (т.е. через будущий аддон LibreELEC)

  • Hi

    I am running the following image on my Wechip V5 S905X based box and am getting an error during startup

    Code
    1. LibreELEC-AML.arm-9.80-devel-20200206170348-569f834-amlgx.img.gz

    Error relates to cpufreq and asks to check the status using the following command

    Code
    1. systemctl status cpufreq.service

    Upon checking this is the output

    I navigated to /sys/devices/system/cpu/cpufreq and didn't see a ondemand directory

    Is the issue due to missing directory in the squashfs or is it a typo as there are 2 slashes in the path after ondemand

    Please advise on what I should do get this issue fixed. Thanks balbes150

    Kodi 18.5 x64 Windows | LibreELEC 8.2.3 MX-III 2GB S802 by Demetris | LibreELEC 9.8 WeChip V5 S905X by balbes150

    Edited once, last by gujal ().

  • Tests done on a KI Pro. (S905D) balbes150

    Image: LibreELEC-ARM-ALL.aarch64-9.80-devel-20200214154744-569f834-amlgx.


    I edited the uEnv file, to.

    FDT = / dtb / amlogic / meson-gxl-s905d-p230.dtb

    Could not boot, or start with android, or go to android recovery screen.


    With meson-gxl-s905d-p230.dtb renamed to dtb.img = not boot

    Previously there was a dtb for KI Pro in the dtb / amlogic folder, this dtb no longer exists. (It is possible to put it back)


    Just an observation.

    The nightly images are working well with KI pro, renamed uEnv.

    FDT = / dtb / amlogic / meson-gxl-s905d-p230.dtb

    LibreELEC-AMLGX.arm-9.80-nightly-20200214-70b69eb-box

    It is useless knowledge if not shared the world.

    Edited 2 times, last by erbas ().

  • Hi


    you need press jumper in under box

  • Added versions of aarch64 images for testing.

    Fantastic.

    Runs fine on a WeChip V5 (s905X 2GB RAM) from 16GB SD Card

    Plays H.264 videos with Prime Hardware acceleration, (occasional lock to green screen, but manageable)

    HEVC only SW Decoder so realistically cant do beyond 720p

    IR Remote works fine

    Bluetooth works fine

    Wifi works fine in both 2.4GHz and 5 GHz

    no more cpufreq related errors on startup


    Some things that need looking into:

    1. HDMI CEC doesnt work

    2. Cryptodome library missing in the build so addons that rely on cryptodome refuse to start

    3. inputstream.ffmpegdirect is missing in the build


    Minor annoyances, would be nice if it can be fixed

    4. occasional hang on finishing playback of videos in addons such as youtube and dailymotion

    5. If left on idle without using for may be 30 minutes, display goes blank and never recovers, have to powercycle


    Overall great image to play with, Thanks balbes150

    Kodi 18.5 x64 Windows | LibreELEC 8.2.3 MX-III 2GB S802 by Demetris | LibreELEC 9.8 WeChip V5 S905X by balbes150

    Edited once, last by gujal ().

  • Hi


    you need press jumper in under box

    Thank you more for this process already known to centuries old friend.

    No boot !!

    The image is not bootable.

    See my comment clearly the LibreELEC night images are working perfectly.

    It is useless knowledge if not shared the world.

  • Thank you more for this process already known to centuries old friend.

    No boot !!

    The image is not bootable.

    See my comment clearly the LibreELEC night images are working perfectly.

    i have wetek play 2 is boot work fine

  • Please Help, image 20200214

    eMMC fitur : Install to eMMC not working

    i try with tar file, not compatible file

    try fast forward or back forward, it' hang up and green screen