[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • Hello,


    i would just have a simple question :


    -> I have an Odroid C2 with Libreelec 8.2 by kszaq ([8.2.3.1] LibreELEC 8.2 for S905/S905X)


    uname -a :

    LibreELEC (community): 8.2.3.1-C2 (S905.arm)

    Linux 3.14.29 #2 SMP Mon Jan 22 10:57:10 CET 2018 aarch64 GNU/Linux


    Does that mean i could not upgrade to the wrxtasy "8.2.4.2 Testbuild" for C2 because i'm on aarch64 ? (it's a kszaq build)


    Thanks a lot.

    Regards,

  • if the box stays overnight, I get a 1/4 screen show up after waking up the box. Only a reboot can fix it. Any one has the same problem?

    I have the same problem and have to reboot my box too. Does anyone know how to fix it?

  • I have the same problem and have to reboot my box too. Does anyone know how to fix it?

    I had the quarter screen problem whenever I powered up my box when the TV was switched off.


    I created a custom EDID from this thread and it fixed it.


    Although your problem is a little different, I suspect that the causes may be similar, so worth a try.

  • Hello All.

    First of all hats off to all the developers who are putting their time and hard work in to this project.


    I have installed a "LibreELEC 8.2.4.2-S905Test" file on a AmLogic 905X box few days ago to test it. I have an older AVR unit which can only decodes Dolby Digital and DTS 5-1 bit-streams. I am planning to rip my Blu-Rays into DTS-HD + Core ,so I decided to test the pass through functionality of the Kody 17.6 which came with LibreELEC 8.2.4. I selected 2 speaker set-up and enabled Passthrough with Dolby Digital and DTS capable receivers selected. 'Sync to display has been' disabled. I can passthourgh Dolby Digital without any issue but I tried 3 different video files with dts audio but I could not passthrough DTS stream.


    I have exactly same issue with Kody v17.6 on Android 7.1 on same 905X box.


    I have an older Linux box (XIOS-DS) from 2012 and I played back same files on it. I have noticed it can passthough DTS (as welll as DTS Core from a DTS-HD stream) without issue with same AVR and TV set-up.


    I am have uploaded screenshots of my Kodi set-up and log files. since I do not have permissions to attach files yet: https://drive.google.com/drive/folders/1l4pagt3yjadoz4bu8d-_navdeq4ryq8u?usp=sharing


    Any help would be appreciated on what can I not passthough DTS audio?

  • I'm running kszaq's 8.4.3.1 latest S905X release. May I ask how 'testy' the testing version for S905X is?

    * s905x, 2/8GB, Coreelec 9.2.1
    * RPi3, LE 9.2.0, GPIO IR
    * Server, kodi-headless, MySQL, VDR, NFS-Server (& much more)

  • Hey everyone. I'm running (wrxtasy-kszaq) 8.2.4.2-C2, and I'm having problems running my ambilight setup using hyperion. Whenever I try to run it, I get the error:

    Code
    /storage/hyperion/bin/hyperiond.sh: line 2: /storage/.kodi/addons/service.hyperion/bin/hyperiond: not found

    Even though the file exists, is executable and write/readable for everyone, same as for the entire directory.


    I've done some googling and I think the problem is due to hyperion being a 32 bit executable and this build not supporting 32 bit executables. I've tried several things, including installing the addon through the repository as found in this thread. However, nothing seems to work. I can go back to an official LibreELEC build where everything worked in the past, but that stutters during video playback.


    I don't really know where to go next. Do any of you have a solution?

  • Hi Guys,


    Couple of interesting points. I'm running a bunch of docker containers in addition to kodi on my 2g S912 device. All works great but RAM can be limited. Most surprisingly kodi seems to be caching quite aggressively, so that even when i have nominally 200 mb free playback freezes etc. Reading around the default cache size is mentioned to only be 20 mb, with 3x that necessary to work. Based upon that I should have loads of free space. Is this information still current?


    Secondly, I looked at moving over data to the eMMC so attempted to follow instructions from kazaq. But to my surprise not /dev/data listed under blkid. Given this, and unsurprisingly, "reboot to android" no longer works. Puzzled as to what has happened as this was working in the past. I noticed on https://drive.google.com/drive/folders/1l-mpeuqpwianygnleqr_vcefn99fvk70 list of new dtb's for oclock gpu. I haven't replaced my dtb since first setting up librelec some time ago, somewhere around the first Wrxtasy builds. Is this the root of this?


    Interested to hear thoughts.


    Cheers,

    B

  • Dear all,


    Thanks a lot for your great work.

    Probably is a bit irrelevant with the topic,after i have created the librelec sd card with the reboot update command from the terminal emulator how i may reboot to emmc again?After i shutdown from th Kodi there is that option but in the next reboot it starts again from Sd card,what is the command in the terminal emulator?


    Thanks for your support and understanding,

  • Hello, i have the same issue than diplomatic with the ssv6051 driver .I have the tv box Mecool m8s pro W. I can't use the command ifconfig wlan0 up, and WIFI doesn't work. How can i fix this problem? Maybe i have to upload the s905W dtb from Android. How could i decompile that dtb?


    Thanks, your work is really amazing

  • Just got a Vorke Z6 Plus in this week and works super! I especially got it in anticipation of the TV dying soon, but until I can play with 4K and HDR I'm focusing on audio.


    Passthrough works for almost everything including TrueHD and sounds great. But I can't get Atmos passed through. My receiver is a Denon x3400h.


    Since TrueHD works I figure Atmos should too.


    Can someone confirm it works for them? I'm running the latest: LibreELEC-S912.arm-8.2.5.1-444-1000nits.

    Edited once, last by Whiskey24 ().

  • Can someone confirm it works for them? I'm running the latest: LibreELEC-S912.arm-8.2.5.1-444-1000nits.

    I have a different box (U9-H), but can confirm Atmos and DTS:X are working fine for me to my X6300H with that same build. Did you change the settings to allow passthrough and specify what codecs can be passed through and all that? I guess so actually if you're getting TrueHD, so next I suppose I'd check the source file to make sure it has Atmos? And then maybe check to make sure you're on the right audio track?

  • Thanks Hyacin, good to know it should be working. I am testing with Dolby Atmos trailers from Dolby.com and TheDigitalTheater.com, so I'm pretty sure the file has got Atmos.


    I'll dig a bit deeper. It is prep work at this stage as I'm still at 5.1 (so I guess there is a slight chance that the receiver will not report Atmos on an input signal in a 5.1 setup, but that would be really stupid). I should be Atmos capable soon though, I'm poised to hit the buy button on a pair of Kef R50s, but haven't found the right "explanation" for the expense yet ;)

  • Hi

    Im running latest build of wrxtasy (8.2.5) for my S905X device. I noticed that there are problems with 7.1 sound formats with Dolby Digital+. Only 4.0 (4x raw) is displayed. See also pictures.

    Since many Marvel productions are available in German 7.1 DD+ i don't know if it's just a problem with correct display at Kodi, or if there are real problems there.


    Display with my AVR is however correctly displayed with 7.1. And sound seems to be correct aswell. All settings and hooks are correct.

  • This will improve brightness of problematic dark looking 4K HDR Bluray Rips:


    LibreELEC-S912.arm-8.2.5.1-444-1000nits.tar


    LibreELEC-S912.arm-8.2.5.1-444-1000nits.tar

    Can anyone that is using this version comment on whether 4k video pass through works for you? I flashed the update and now my 4k files only pass through audio which is weird. 4k pass through worked before this update, after updating 1080p files still play as expected, just seems to be a 4k video issue.


    Update: I re-flashed the older LibreELEC-S912.arm-8.2.5-Chroma.422.10bit.img and 4k pass through works again so it does seem to be an issue I am having with the 444-1000nits update unfortunately.

    Edited once, last by natebizzle: Update ().

  • Hi guys,

    I have a netflix subscription and would like to install the netflix kodinerds addon to watch netflix on my S905 box.

    Thing is, I'm stuck when trying to install the addon with a dependency error for script.module.pycrytptodome

    Same problem on 8.2.4 and 8.2.5

    I wonder if there's a workaround or if there's a working addon somewhere.


    Thanks for any help

  • Can anyone that is using this version comment on whether 4k video pass through works for you? I flashed the update and now my 4k files only pass through audio which is weird. 4k pass through worked before this update, after updating 1080p files still play as expected, just seems to be a 4k video issue.


    Update: I re-flashed the older LibreELEC-S912.arm-8.2.5-Chroma.422.10bit.img and 4k pass through works again so it does seem to be an issue I am having with the 444-1000nits update unfortunately.

    4K/HDR works fine for me with that image. U9-H. I'm not entirely sure what you mean by "passthrough", but 8.2.5.1 444-1000nits is working as perfectly for me as 8.2.5 422 10-bit was working before it.


    Edit: Typo

    Edited once, last by Hyacin ().