[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • Any idea why?

    Are you sure you did not forget to change the Audio setting in the System Settings from the usual HDMI output to the special Pulse Bluetooth output option, else of course you will get no bluetooth audio output and the audio will remain as before on your TV or AVR.


    Can confirm Bluetooth audio works fine for me on my Bluetooth earpods with LE 8.2.5.1 on teh TX9 Pro S912 box.

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Are you sure you did not forget to change the Audio setting in the System Settings from the usual HDMI output to the special Pulse Bluetooth output option, else of course you will get no bluetooth audio output and the audio will remain as before on your TV or AVR.


    Can confirm Bluetooth audio works fine for me on my Bluetooth earpods with LE 8.2.5.1 on teh TX9 Pro S912 box.

    Yes I did change it to pulse. But I am not talking about not getting audio from headphone. I am one step before that : I can't pair the Bluetooth headphones...

  • What about codecinfo? is it working?

    For me I think it's not, when I press O only the audio is showing correct , everything else is reported as unknown...

    No codec, no color space etc...


    Is there any way to be sure when I play a file that is playing in the best possible quality?



    Thank you.


  • Just installed [8.2.4.1] LibreELEC Kodi Krypton on my old s905 MiniMX box today. Very impressed everything working smoothly. Thanks to all involved on this version.



  • If they are Bluetooth Low-Energy devices the current LE kernel doesn't support BLE and this PR (which was never merged) is required:


    kernel-backports: add package to support BLE devices by chewitt · Pull Request #2562 · LibreELEC/LibreELEC.tv · GitHub

    My bluetooth headphoens are in ear pods from QSY so they are certainly low energy as they are run form their internal small rechargeable batteries. Not bad headphones but sorely lacking in volume as I do prefer loud especially for good rock music, but fine for normal movie and TV mainly speech audio. No problem pairing at all with 8.2.5.1 either.


    Sorry to see you are still having problems knfevg but regret little more to suggest. Does Bluetooth show enabled in the Services option screen above the Bluetooth settings screen ?? Or will it not enable the Bluetooth sevice at all ?? If not then it is either the wrong device tree or your bluetooth hardware in your box is faulty I would reckon. Does it work no problem with 8.2.3.1 if so then you know the hardware is fine and it most likely is you have not got the right device tree.

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Hi, Just a quick question.

    Looking at buying a Tanix TX3 Max with its built in Bluetooth.


    Does anyone know if a Fire TV remote would work with this?

    I ask as I have read conflicting information in general in regards to how Bluetooth works.


    Thank You

  • if the box stays overnight, I get a 1/4 screen show up after waking up the box. Only a reboot can fix it. Any one has the same problem?

  • Facing some issues with

    • M8S PRO L

    after installing the latest version of LibreELEC , LE 8.2.4.1 – S912:


    I have copied the gxm_q201_3g.dtb and renamed to dtb.img

    (mine is 3GB,100Mbps, https://kszaq.libreelec.tv/s912/8.2/device_trees/100mbit_ethernet/) and I got a successful boot for LibreElec


    I have two issues.


    1. The OSMC remote worked for a while, then it stopped working, SO I copied the remote.conf from http://wrxtasy.libreelec.tv/mecool/

    Post that remote is working..


    2. But Im having another serious issue here.


    While playing a 4K BD content the video and audio got stuck/freeze multiple times. After that I need to power off and on the box.


    Here are the setting I did as per release notes.

    1. Set GPU clock rate to 792MHz --> Yes

    2. Enable switching Chroma and Bit depth output to 444,10bit for 4K HDR10 viewing. -->No

    3. Force RGB output -->No

    4. Mute HDMI audio output (when using SPDIF)--> No


    Can you help me here?

  • "Tanix TX3 Mini" update success.


    Updated from 8.2.3.1 to 8.2.5 with "LibreELEC-S905.arm-8.2.5-Chroma.422.10bit.tar" (release date 2018-09-01 13:22)


    First impression GOOD

    Boot is aprox 10 seconds longer but since TX3 is running 24/7, doesn't really matter :-)

    Tried a couple of HD - SD files and streams with and without subtitles - ALL OK

  • "Tried a couple of HD - SD files and streams with and without subtitles - ALL OK"

    The problem is with external subs, from smb source, and .rar subtittles. For S905 still haven't 'fixed' build. For S912 has, but I can't see feedbacks, that report fixing.

  • Guys, Do you guys have an Idea how to flash the sd card with "S912.arm.8.2.5.1-444-1000nits.tar" file?


    .tar is only for update.

    You can flash an image file first run the image and do the update placing .tar file in update folder and reboot

  • Maybe it's running too hot? You could try to disable the 792mhz gpu (over)clock setting, if that solves the problem you could eventually add a fan if you still want the 792mhz setting enabled.

  • I've installed version 8.2.5.1 on Yoka KB2 (AML912/2gb/32gb) and MeCool BB2 Pro (AML912/3gb/16gb) and it works very well.

    Only on MeCool BB2 Pro the "ok" button don't work....