feedback for test build LibreELEC-RK3328

  • Kwiboo

    I see mpeg2 interlaced videos show ff-mpeg2 drmprime but jump to 100% CPU for one core.

    Must it not be rkmpp that supports it now?

    Is there a way to improve it?


    Sample videos, tried last one.

    Index of /~fritsch

  • I made an account just to give feedback for HDR support


    Tested on a ROCK64 2GB


    Pros:

    HDR “works” (need to manually set frame rate ( auto = off ))


    Videos play smooth (when manually setting frame rate to match the video)



    Cons:

    I get random green static / lines in the main UI when set to 4k @ 60hz. Might be my cable, I’ll have to buy another as I only have the one available. 30 and 24Hz work fine, no green lines.


    Frame rate switching = auto ... choppy / frozen video playback


    Frame rate switching = off ... manually set ... after playing an HDR video and returning to the main menu, the output is still in “HDR”, causing the image to be over boosted .



    It’s nice to finally have HDR playback “working”. In time I’m sure it will be highly reliable.

    Keep up the excellent work :)

  • I think with a new HDMI 2.0 cable all your problems will be solved.

    Frame-rate switching needs to be on start/stop for HDR to work, not off.

  • I think with a new HDMI 2.0 cable all your problems will be solved.

    Frame-rate switching needs to be on start/stop for HDR to work, not off.

    the cable works fine with HDR with RKMP on Android.

    I will get another cable and retry though. Thanks

  • I get random green static / lines in the main UI when set to 4k @ 60hz.

    I have noticed this also, it is the "console" framebuffer (boot logo) that is still active behind Kodi gui and taking up memory bandwidth, ensure you set GUI Limit (Expert settings mode) to 1080p and reboot or if you start/stop a video the video/console layer will be disabled and the green lines disappears.

    I see mpeg2 interlaced videos show ff-mpeg2 drmprime

    I forgot to include the patch thats enables rkmpp mpeg2 hwaccel in ffmpeg :)

  • I have noticed this also, it is the "console" framebuffer (boot logo) that is still active behind Kodi gui and taking up memory bandwidth, ensure you set GUI Limit (Expert settings mode) to 1080p and reboot or if you start/stop a video the video/console layer will be disabled and the green lines disappears.

    I forgot to include the patch thats enables rkmpp mpeg2 hwaccel in ffmpeg :)

    Hi Kwiboo, tried to test the release....but there are no pvr-clients available. As stated before :-), would be great if I could test the new release for live-tv (interlace...and so on).


    Is there any chance to install hts-tvheadend cleint addon from another source.?. The one mentioned in this thread here wont install because of (version) dependencies. any hints ?


    the current nightly have the same problem...i fear tvheadsend is currently not available for RK-based boxes at the (beta) repository....:-(


    regards

    arel

  • Hi Bylderup...where did you get the hts-tvheadend client ? cant find it anywhere...


    I´d like to test livetv with kwiboo´s new release (on my mvr9) :-)


    regard

    arel

  • hi arel


    I do own a TV box with Amlogic chip also and latest CE 8.90.4 on SD Card.

    So I have copied manually the addon from there in the addon folder of the MVR9 box.

    After restarting the device I had to activate the addon. Working fine.

    I hope this attachment is allowed. Unzip my attachment and copy this in the .kodi/addons folder


    pvr.hts.zip


    edit:


    I do my testings always not only with the pure build but with some popular addons also.


    Fyi :


    I have noticed, that live tv channels (Tvheadend Client) with h264, 1440x1080 have problems with in german "Laufschrift" I think the english word is ticker tape. Can´t be read because it´s flickering sideways. Letters are washed out. TV has 1980x1080i 50Hz Resolution.


    And another thing, Marcel Veldts Spotify Addon is starting fine, but Audio sounds like defective walkman in the dustbin.


    Amazon VOD 720p is ok.







    Edited once, last by bylderup ().

  • I think with a new HDMI 2.0 cable all your problems will be solved.

    Frame-rate switching needs to be on start/stop for HDR to work, not off.



    I bought a new cable today but all these same issues persist.


    Cable is rated for HDMI 2.0 18gbs. Works on my 4k screen from my Mac at 60hz 4:4:4 chroma 30 bit color


    To test I am using movies obtained from various sources, not reference files. Movies tested are The LEGO Movie, Tomb Raider (2018), Hidden Figures, and Earth One Amazing Day.

    All are 4k HEVC HDR10 mkv files.


  • Hi Bylderup...where did you get the hts-tvheadend client ? cant find it anywhere...

    Install From ZIP

    pvr.hts-4.3.0.4 (1).zip

  • TV Sharp Aquos Quatron 1920 x 1080 TV

    Rock64 / 4gb

    Fresh SD Card Install LibreELEC-RK3328.arm-9.0-devel-201807011300-d46baa3-rock64.img

    Issues with adjust display refresh rate using 1080p 50Hz GUI Resolution.

    Refresh rate setting Start/Stop. Delay set to none.

    I have Whitelisted 1920 x 1080p 60 / 59.94 / 50 / 24 / 23.98 Hz

    TVHeadend Client 4.3.04 installed via zip due to dependancy issues from LE Repo install not possible.


    TV Channels are all 50 Hz in my country and choosing play i get a Refresh rate change from GUI 50Hz to 50Hz Playback .

    I then Disabled 1920 x 1080p 50Hz in Whitelist.

    I played a channel and again i got a Refresh Rate Change to 50 Hz.

    Whilst playing this channel i switched channel via navigation on remote and i got a Refresh change to the Dreaded Black Screen.

    I re-activated 50Hz in Whitelist and repeated change channel with navigation and refresh rate changed to 50Hz with no issue. BLACK Screen

    Kwiboo

    EDIT: I Just discovered that navigating from HD Channels to HD Channels whilst playing Does NOT Change Refresh Rate and No Black Screen. The same no black screen SD Channel To SD Channel navigating.

    Black Screen only happens when navigating to another channel during playback which is not the same Definition as the one that is playing. Can only change SD to SD Channel or HD to HD Channel during Playback of Live TV.

    Audio Drops every 3 minutes still happening with my movie library files but this has always been the case with all images including Ray's old builds.

    Still kept 9.0-devel-20180606204626-0267cea-rock64 on another SD Card which is still better for my use.






    Edited 2 times, last by kostaman: Corrected Black Screen Behaviour ().

  • Hi Bylderup,

    thanks a lot for the addon ! ...by the way i also test live-tv based on "german TV standards :-)" (50hz, 1080).


    the idea to take the addons from another build is not bad :-), especially when it is also "ARM" based and the addon has no dependency to the VPU chip...which is the case for hts-client.


    So know I can do some wider tests...! will give Feedback here !


    regards

    arel

  • I'd be grateful if you could provide ZIPs for inputstream.adaptive/rtmp, too. Then my everyday use cases were covered.

    Try These. Sorry not at my box. Should work.

    inputstream.adaptive-2.2.23.0.zip

    inputstream.rtmp-2.0.3.2.zip

  • Try These. Sorry not at my box. Should work.

    Yes, they work. Tanks, man. Same blackscreen issues for me. At least, restarting Kodi via ssh instead of rebooting is sufficient to revive the screen.

  • Hi Kwiboo: Here are some things I experienced with your latest release on my rock64:

    1. For me CEC Support doesn't work with (rock64). The message says CEC is connected but the Remote doesn't work. I switched (clean install) from an old Raybuntu-Release, CEC worked flawlessly there.

    2. My USB-Keyboard only woks, if I reconnect it after Kodi finished launching.

    3. Videoplayer: All tested files below 4k resolution play but the player crashes/hangs after skipping forward.

    4. Videoplayer: 4k HDR movies don't even start... some freeze Kodi immediately after selecting them, others show the "working wheel" but nothing happens. No Problems here with s905x or C2 here.

    All Video-Modes are whitelisted.

  • cozmo. I have a rock64 2gb board and a 55" 4K TCL TV.

    I use CEC with my TV on the latest test release. I did notice that it didn't take effect until after I rebooted. Also it does not work within a few seconds of the system going to sleep. However if I waited a little bit, the TV would turn on.

    I have not noticed any USB keyboard issues.

    I have not seen issues with hanging videos when skipping.

    My 4K HDR videos seem to play fine. I had to force the TV to HDMI 2.0 for the HDR to work however.

    I also see the green flickering horizontal lines previously reported in the GUI when it is running at 4K res.


    You might try this fix someone reported with similar issues.

    Physical keyboard unresponsive after upgrade


    Does anyone know how to remap the browser backward buttons on a Logitech mouse?

    I used to be able to use them to go to the previous menu. Now they do not function at all.

    I had seen a fix about this on a older kodi 15->16 upgrade, but for the life of me I can't find that post anymore.

    The gui keymap utility does not work for me on these mouse buttons.

    For reference, these thumb buttons.

    logitech_m510_front.jpg'''


    I finally pieced together enough of the mouse keymap to get a working back button.

    Here it is if anyone else wants to try.

    You might need to try numbers 5-9 for the click id depending on your mouse, and some people might prefer

    This would have been so much easier if the Kodi mouse keymap Wiki had something other than "Further action required"

    Code
    1. <keymap>
    2. <global>
    3. <mouse>
    4. <click id="6">Back</click>
    5. </mouse>
    6. </global>
    7. </keymap>

    -Written by a team of angry monkeys.

    Edited 3 times, last by wizardknight ().

  • Oh, and if anyone else is using an MCE type remote, they are not enabled by default on this build.

    Stick my script in your backup folder, and run it to fix this minor annoyance.

    The script will create two files and enable the basic button functions for you. A reboot is necessary.

    Of course if it turns your system into Skynet or deletes all your data I take no responsibility.