[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • I'm not sure if this is related to the video freezing after playback has stopped issue but in 8.90.5 whenever I play a file ripped from a DVD, Kodi crashes. It doesn't matter the format or codec used on the file. The same files played in 8.90.3 and 8.90.4. I tried taking a different raw avi file and the dvd file and encoded them both using the same codec, bitrate and frame rate. The DVD file is the only one that crashes. The only difference I noticed between the files after encoding them is the DVD has the NTSC standard listed in it's video information. I've attached the log file and the kodi crash log file too.


    Kodi log file 8.90.5


    Kodi crash log file 8.90.5

  • GDPR-2, as I see you are going to set disable deinterlacing by default.

    From my tests for S912 it's not a good idea. Flickering is visible for non-moving objects like channel label and etc... For SD channels it's visible more. For HD channels too for sport content.

    For me disable deinterlacing looks better on specific 1080i IPTV channels only, that has problem with colors.

    I think this is dependent upon your TV as some TV's handle the deinterlacing better than relying on the box to do it.

    I will keep the option to re-enable it via Kodi.

  • GDPR-2 is the ShaderToy issue a problem with these later builds that you can fix or must we wait until the developer updates the add-on?

    I guess it's the latter then?? 8o

  • I guess it's the latter then?? 8o

    Sorry I missed your question, I don't know I'm afraid, I don't use this addon but I do compile the latest versions of all the addons each time I do a new release and visualization.shadertoy was last updated on 1st Feb.

  • a new release and visualization.shadertoy was last updated on 1st Feb.

    Yeah, if that's the latest version in LE repo then the problem still exists for me. @HeresJohnny tells me that he has Shadertoy working correctly with 8.90.5 but hasn't disclosed which version of ShaderToy or the skin he has it working correctly with as yet

  • compile error from source

    Edited once, last by kunxiang ().

  • I've just got my first S912 box (have a few S805, S905X, S905W already), how do I know if I need the Q200 or Q201 device tree?


    Thanks

  • I think Q200 is 2GB RAM 1GB network Q201 is 2GB RAM & 100MB network

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • You can check in Google you device model and network speed for it.

    You can boot to android and check speed to your router (if it has 1GB ports)

    And choose q200 for 1Gb or q201 for 100MB

    It works with Q200 (although not the LCD screen, not a major loss). This link on Freaktab says Q200 & Q201 are both Gigabit so I'm not sure the difference.

    Official list of Amlogic reference boards - FreakTab.com


    Ok so I have the DTB and have opened it in Notepad++, it says gxm_s912m82_2g is this a new device? DTB attached, be good if we could get the LCD working, it's a Kingbox K3 made by leelbox, wifi and Bluetooth work with Q200, I've not tested the lan yet.

  • Sorry I missed your question, I don't know I'm afraid, I don't use this addon but I do compile the latest versions of all the addons each time I do a new release and visualization.shadertoy was last updated on 1st Feb.

    Last time I tried no visualization was working for me on HTPC (only tried goom and projectM), so I do not think this is a problem of shadertoy or the architecture.

  • Last time I tried no visualization was working for me on HTPC (only tried goom and projectM), so I do not think this is a problem of shadertoy or the architecture.

    Waveform works for me. The standard bar-chart visualization doesn't have the point option working.

    There is no visualization when playing Radio - but there is when playing Music.


    Shoog

  • Sorry for the late reply. Shadertoy 1.1.8.2 with Estuary Mod v2 2.9.6. I've just tested again. Shadertoy doesn't seem to retain the preset I select. The default preset ""2D LED Spectrum" doesn't show anything indeed. But if I set it to "Sound Sinus Wave" for example, I get effects. As soon as I stop playback, though, the preset resets itself to default. Maybe there's a write permission issue of some kind or the settings dialogue is malformed since the add-on settings dialogue is empty. No freezing, though.

    T6 (2GB/16GB, S905x, Android 7.1.1, CoreElec - living on the bleeding edge)