[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • Hi, I tried to downgrade to 8.2.0.1 by copying the file to UPDATE folder, like when I do updates, but After restart when the process starts, it just gives me an error and device boots back to version 9.0. Any other way how can I force the downgrade? thanks for any help. Thanks

    did you use .tar or .img.gz?

  • Seems like DASH playback is broken in devel build. Or is it removed (recent leia changes?) in favor for inputstream.adaptive?

  • GDPR-2 , I am testing Your buld (now new dev release) on my wetek play2 and works really nice :) Usually I am using Leia GDPR-1 build . Is possible to map all buttons on remote on Your libreelec version like on Raybuntu leia for wp2?

    Regards

    You can copy the remote.conf from /etc/amremote/ from your GDPR-1 build (currently rbleia15) in /storage/.config/. It works well for me. Customizing with keymappings is easy.

    For example:

    <key id="61576">Home Button</key>

    <key id="61595">TV Button</key>

    <key id="61596">* Button</key>

    <key id="61656">Recent AppsButton</key>

    <key id="61952">Apps Button</key>

    <key id="61672">TXT Button</key>


    my mapping:

    <keymap>

    <global>

    <keyboard>

    <power>ActivateWindow(shutdownmenu)</power>

    <key id="61576">ActivateWindow(Home)</key>

    <key id="61596">info</key>

    <key id="61596" mod="longpress">PlayerProcessInfo</key>

    <key id="61654">ContextMenu</key>

    <key id="61654" mod="longpress">Menu</key>

    <key id="61656">Fullscreen</key>

    <key id="61672">ActivateWindow(TVGuide)</key>

    <red mod="longpress">ActivateWindow(TVGuide)</red>

    <green>ActivateWindow(Favourites)</green>

    <green mod="longpress">OSD</green>

    <yellow>runscript(/storage/.kodi/addons/service.vpn.manager/infopopup.py)</yellow>

    <yellow mod="longpress">runscript(/storage/.kodi/addons/service.vpn.manager/table.py)</yellow>

    <blue>ToggleDebug</blue>

    <blue mod="longpress">PlayerDebug</blue>

    </keyboard>

    </global>

    </keymap>


    GDPR-2 : the last dev build (LibreELEC-S905.arm-9.0-devel-20171112113747-r27335-g0f05d91.tar) with patches from afl1 works very smooth and without micro stutter with german dvb-t2 (hevc/[email protected]) on my play2.


    Regards

    Edited once, last by jokkmac ().

  • GDPR-2   afl1   johngalt et al. You all seem to be hoarding a lot of LibreELEC changes and mostly KODI patches (almost 50). Would you all please consider contributing to LibreELEC and Kodi by creating PR's.

    LibreELEC.tv/CONTRIBUTING.md at master · LibreELEC/LibreELEC.tv · GitHub

    That way we can all work together on a common ground and make even better community builds.

    I know that a lot of those KODI patches are actually some little hacks or tweaks to change defaults but some of them seem to be fixing playback on AML and those should really be upstreamed to KODI.

    I've started to upstream everything I have too and it's a lot of fun and it makes maintaining easier :).


    Ultimately we should also upstream the S905/S912 projects.

  • Which dtb do I need for the Docooler M9S Pro 8GB?

    Edit: Seems to work with gxbb_p200_1G_100M_RealtekWiFi.dtb


    Does it work via SD only or also via USB-Stick?

    Edit: Seems to work only with SD.


    For the record: This TWRP images works when put on the SD-card: TWRP_MiniMX.img

    Edited once, last by docooler ().

  • There is no 64-bit libwidevine library, only 32-bit, which is why future LE 9.0 releases have switched to the same split 64-bit kernel, 32-bit userspace arrangement as Android. Please also note that Google's license for libwidevine means it is not redistributable without signing formal agreements that result large liabilities for the signing entity. Community or personal LE releases that ignore the license and embed libwidevine for convenience will be suspended from this forum if we become aware they are doing so, because we do not want the legal attention that may result from their release here. There is a Kodi helper add-on for inputstream.adaptive that provides the libwidevine library via a user-initiated process. If it hasn't appeared in the Kodi repo yet, it will do soon - it's inclusion was agreed by Kodi developers at the recent Prague DevCon.

    I happen to have an ubuntu 'artful' chroot on my 'bleeding edge' gentoo kvim2 box and it seems chromium-browser ubuntu package does have a 64-bit libwidevine library couple:

    So I will want to use these (in particular libpcre may be missing) in LE soon just for sake of trial.

    Keep you informed!


    update


    The ubuntu 'artful' shared libraries when included load just fine.

    But I see another, I guess addon specific, problem:

    Code
    1. 07:06:54.669 T:548472168464   ERROR: Previous line repeats 1 times.
    2. 07:06:54.669 T:548472168464  NOTICE: VideoPlayer::OpenFile: http://localhost:43898/manifest?id=80182440
    3. 07:06:54.670 T:548195717312  NOTICE: Creating InputStream
    4. 07:06:58.738 T:548195717312   ERROR: AddOnLog: InputStream Adaptive: License update not successful (no keys)
    5. 07:06:58.739 T:548195717312   ERROR: AddOnLog: InputStream Adaptive: Initialize failed (SingleSampleDecrypter)
    6. 07:06:58.741 T:548195717312   ERROR: CVideoPlayer::OpenInputStream - error opening [http://localhost:43898/manifest?id=80182440]
    7. 07:06:58.741 T:548195717312  NOTICE: CVideoPlayer::OnExit()


    not a big issue for me as I hardly ever use Netflix (my wife does) but , at least, I have hope (for personal usage) it may eventually work in 64-bit LE ...

    I can move discussion to Netflix addon thread perhaps.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

    Edited once, last by Nofan Tasi ().

  • no, it doesn't make any difference, it makes ALL the difference as only .tar can be used for updating.

    Shure ?

    I used .img.gz many times :)

  • To little space to unpack img.gz or a bug in a specific build. Normally updating with img.gz should work just fine.