[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • The thing that conclusively proves the SoC type is under the heatsink, but the sticker that's visible indicates S905W.

    the heatsink is glued ... impossible to remove.


    But 'Usb burning tool' manage to connect.

    This is definetly an S905(x/w) device.

  • I am trying to extract the DTB file, but I get some issues ...


    with ADB, I copied boot.img with :

    dd if=/dev/block/boot of=/sdcard/boot.img


    but the split with a 0 byte for ‘second’ (which should contain the dtb if I am right) :


    ./split_bootimg.pl /storage_main/tmp/boot.img


    Page size: 2048 (0x00000800)

    Kernel size: 7110087 (0x006c7dc7)

    Ramdisk size: 1315813 (0x001413e5)

    Second size: 0 (0x00000000)

    Board name:

    Command line: buildvariant=userdebug

    Writing boot.img-kernel … complete.

    Writing boot.img-ramdisk.gz … complete.



    so ... I am stuck …


    EDIT 2 :


    here is the pastebin of dmesg

    [ [email protected]] Initializing cgroup subsys cpu [ [email protected]] Initializing c - Pastebin.com


    EDIT 3:


    damned ! I finally managed to extract the dts file !

    I found the infos here :

    [S905] Device trees
    [S905] Device trees


    it's a multi DTB.

    here is the start :

    Code
    model = "Amlogic";
    compatible = "amlogic, Gxbb";
    amlogic-dt-id = "gxl_p212_1g";
    interrupt-parent = <0x1>;


    p212 ... lol.



    EDIT 4:


    still not booting with the extracted DTB !!!


    here is everything I extracted :


    https://koxx3.fr.eu.org:8086/s905w/

    any help please ?

    Edited 4 times, last by Koxx ().

  • I am trying to extract the DTB file, but I get some issues ...

    Can I ask you why you're extracting it? The dtb file from Android doesn't work on Libreelec.

    Did you use a s905x device tree? I have a s905w Soc as well, and using this dtb for the s905x, everything works good.

  • Can I ask you why you're extracting it? The dtb file from Android doesn't work on Libreelec.

    Did you use a s905x device tree? I have a s905w Soc as well, and using this dtb for the s905x, everything works good.

    I clearly missed that point !

    I'll try with your dtb, but I think there is something else than DTB. I can't understand why any of the ~20 dtb files I tried (from various sources can't work).

  • Hello,

    I'm running 8.2.3.1 on K1 Plus. I have installed new USB DVB-T2 tuner with Si2168 chip on it. Unfortunately driver si2168.c had a bug which is included in the 4months old crazycat driver pack but it is reported that it is fixed now.


    Can I download somewhere newer driver pack for K1 Plus (gxbb_p200_k1_plus) or do I have to build it on my own? Or would somebody here be so kind and build it for me please?


    Thank you, Martin

  • Been away for a while, can someone explain why kszaq has stopped supporting these builds, is there another build we should install etc?

  • is there another build we should install etc?

    Why ?

    There is a fork from kszaq`s builds - pre alpha and not stable

    This version runs stable and it´s perfect for daily use

  • Why ?

    There is a fork from kszaq`s builds - pre alpha and not stable

    This version runs stable and it´s perfect for daily use

    This version (8.2.3.1) is perfect unless you don't need to patch like me some bug in media package:-( And here would some help and new maintenance releases be benefitial.


    Martin

  • This version (8.2.3.1) is perfect unless you don't need to patch like me some bug in media package:-( And here would some help and new maintenance releases be benefitial.

    Be patient or NOTICE: Please use https://discourse.coreelec.org for CoreELEC support

  • Hi, I have not been here for a long time because everything worked well for me. Yesterday I rebooted the box, I do not know why and I have this effect Somewhere I saw two lines to enter in the terminal but I can not find it and fix the problem. Will you help?


    KII Pro / Wiwa Dream Player TV - LibreElec testing...

  • Hi, I have not been here for a long time because everything worked well for me. Yesterday I rebooted the box, I do not know why and I have this effect Somewhere I saw two lines to enter in the terminal but I can not find it and fix the problem. Will you help?


    Isn’t your tv just set in 3D mode and splitting the image vertically?

  • no, my TV does not even have 3d support. I used to have the same problem and this forum is the solution, but unfortunately I can not know this thread :(

    KII Pro / Wiwa Dream Player TV - LibreElec testing...

  • Yesterday I rebooted the box, I do not know why and I have this effect

    That looks like a Crap HDMI Cable or Connection.

  • The hdmi cable I was checking is ok.

    When I turn on a movie or tv program via yatse, the picture is good. The problem is with Kodi and its appearance.

    KII Pro / Wiwa Dream Player TV - LibreElec testing...

  • The problem is with Kodi and its appearance.

    Settings / System / Display

    Resolution ????

    Refresh Rate ????