[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Announcement: Krypton builds are now discontinued.

    Okay, great. :)


    What happens to Autoupdate? More precisely, will Autoupdate suspended, till Leia has reached at least beta stage, or should it set to manual update?

  • kszaq


    I know that S905W is not supported as in tanix tx3 mini but there is a request of many users over at the librelec tanix forum for making the front LCD work in Libreelec. It works in android but it's stuck displaying "boot" in Libreelec. Adamg has got it working in Leia, is it possible that the driver can be backported to current Krypton Libreelec releases?


    Thanks a lot

  • I'll keep slugging away at it but if anyone can save my pain,

    Might be of interest to you and others.

    I have my TX7 on all the time. I woke up this morning and i turned the box off to connect another box.

    The TX7 was using 8.2.2.2 whilst switched on overnight.

    When i turned it back on , it found the new 8.2.2.3 image and proceeded to update.

    So it looks like the update downloaded without a reboot or power off.

    I was surprised but there must be a check for update without powering on

    or maybe the new update push caused the update whilst box was on ??

  • Might be of interest to you and others.

    Thanks for that glimmer of hope but no, the issue with auto-update remains exactly the same. (Must be harder to fix than it seems ;) )

  • Yeah I was getting the same problem as Menion with the auto update stating there was an update but never downloading. After checking the log file it seems the LibreElec config addon is timing out trying to connect to the auto update server.

    More specifically, this is the error which eventually throughs a urllib2 404 error.

    ERROR: Traceback (most recent call last):

    File "/home/kszaq/ocz/le-master/build.LibreELEC-S905.arm-8.2-devel/LibreELEC-settings-12c5f24/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 284


    followed by:

    File "/usr/lib/python2.7/urllib2.py", line 556, in http_error_default

    HTTPError: HTTP Error 404: Not Found


    I can post the full pastebin log file if anyone wants to take a look at but after reading it looks like the auto update may be suspended until the transition to the Leia builds are complete.



  • it seems the LibreElec config addon is timing out trying to connect to the auto update server.

    That rings true. Perhaps a longer time-out or multiple checks will be added eventually

    it looks like the auto update may be suspended until the transition to the Leia builds are complete.

    It looks that way, we'll just have to wait for now. Thanks for posting your findings :thumbup:

  • Sorry my stupid Macbook crashed before I could finish editing my post. I did notice the download URL from my log file has a space before the ".tar" in the file name. Maybe urllib2 is encoding the space then calling the url? I've been working on the PSVue addon and urllib2 and requests have been a thorn for me every time! Hahaha.


    ERROR: ## LibreELEC Addon ## oe::download_file(https://sx05.eu/s905/8.2/8.2.2.3/LibreELEC-S905.arm-8.2-8.2.2.3-temp_sensor_disabled .tar, /storage/.kodi/temp/update_file) ## ERROR: (HTTPError())

  • So it looks like the update downloaded without a reboot or power off.

    I was surprised but there must be a check for update without powering on

    or maybe the new update push caused the update whilst box was on ??

    You might be right. I have the update .tar in my .update folder. The creation time and date of the file is 7.1.2018-02.05am. That's about 7 hours after the last reboot.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Is there an alternative way to update a build installed on internal as for some reason I’m unable to connect via my laptop via ssh or file manager to drop the file in

  • wow, I wonder how much room for improvement there is still left.. that system to ram loading is amazing. My 1gb box feels way faster.

    But I also wanted to overclock gpu, doing so doesn't persist a reboot. I tried putting it in some file recommended, but it also didn't work.

    An entry in LE settings to overclock would be really nice, to amke it easier.

  • Is there a difference in (felt) performance between installing LE internal compared to a fast SD card?

    Device is a S905x device with 2 GB of RAM.

    Currently I have it installed on a Samsung EVO+ SD card and I wonder if I should install it internal.

    Would it feel "snappier"?


    Btw: Thank you very much for all the work which is done here!

  • I didn't notice a difference on my beelink S905

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • I installed it from the same make of card to internal and noticed the difference more than anything on the box booting up, actual running did feel quicker but could have just been the placebo affect. I installed to internal after reading up on SD card performance compared to running internal and people to say performance all round is quicker running from internal.......

  • What kind of speed do we need on a SD card? I still have some buffering with this build on my Mini MX iii ii 2/16 GB. Will a faster card eliminate the buffering? The buffering occurs with SD and HD video streams, but not on my NAS.



    TIA


  • Currently I have it installed on a Samsung EVO+ SD card and I wonder if I should install it internal.

    Would it feel "snappier"?

    It´s a nice fairy tail ....

    Have a look -> [HOWTO] Boot from SD card, use internal memory for data

  • wow, I wonder how much room for improvement there is still left.. that system to ram loading is amazing. My 1gb box feels way faster.

    But I also wanted to overclock gpu, doing so doesn't persist a reboot. I tried putting it in some file recommended, but it also didn't work.

    An entry in LE settings to overclock would be really nice, to amke it easier.

    Hi


    you can try to add this in /storage/.config/autostart.sh :


    echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

    echo 5 > /sys/class/mpgpu/cur_freq


    But check the temperature of your box ;)

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND