[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Latest devel build is up.

    Whose, yours or kszaq's ?

  • Speaking of boxes/chipsets to avoid... I have 11 different Amlogic boxes in s8/s9 series and I try to purchase fairly popular models.


    The first somewhat popular model I've purchased with odd hardware is MECOOL's s905x version.


    They lable this the "HM8", it's a standard 1g/8g eMMC but it uses a straonge "Sci" WiFi Chip (Chinese brand: sci-inc.com.cn )


    It also won't mount any partitions local to the device with the 3.0.2 TWRP that works on other s905x boxes.


    Here's a phone and one close-up of the WiFi (not legible, but best I could get with my phone).


    Anyone else have any experience with this / any special dtb or something as a workaround?

  • Anyone else have any experience with this / any special dtb or something as a workaround?

    Read #1

    Supported internal WiFi chips: Broadcom (all), Realtek (all) and Qualcomm QCA9377. Other chips, e.g. 9082xs, SSV6051 are not supported because there is no driver source code available.

  • I only purchase the Tanix TX3 Pro, I have had a consistent batch of the same device internals regardless of where I order from for some time now.

    It's small, stylish and cheap, can't go wrong.

  • You can buy a supported wifi module (for example this), remove the original and solder the new one.

    Upo001 post it to another forum:

    172413_2017-10-04_17-13-36.thumb.jpg

    He succesfully changed the wifi modules in at least two box (Tannix and Mecool).

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu


  • I figured out why my ethernet wired stop to work. I'm going to send what I figured out!


    WARNING GRAPHIC IMAGE!!


    MELTED CABLE! (The wires were together and short-circuited, so pay attention on your boxes about)



    So I try to fix:






    but I think that my ethernet module is partially melted.




    Now my ethernet is working some times.. (Realy, some time yes some times no!!) oh china box!


    Pelican, do you think that it is possible to change this module? Do you know which can I buy or how can I know that?

  • It's small, stylish and cheap, can't go wrong.

    Providing you don't need 4K above 30Hz, of course ;) (Ah! the PRO S905X, no Bluetooth)

    Edited 3 times, last by Poida ().

  • Hi,


    Sorry if this has been answered before but I'm having a hard time getting my Mecool M8S PRO+ (2GB RAM / 16GB flash, S905X) to boot off SD/USB. Following the install instructions it seems none of the applicable (no reset button) methods seem to work. Every time there is a storage medium with the LE image present it hangs on the Mecool logo.


    I have an older S905 box as well with the appropriate build, that worked with the a dummy .zip file update method and boots LE just fine off USB. While I don't expect the S905X to boot that image I would expect it to proceed past the Mecool logo nevertheless so I'm unsure whether it's the image, SD/USB, or the boot method.


    Now to clarify I don't have Rufus available (running it under Wine has been hit/miss in the past) so I have dd'd the image instead, it seems to come up fine but I'm not sure whether there is some Rufus magic involved and whether the image is OK for just the usual dd. After dd'ing I can see the partitions just fine. The image for the S905 worked fine with dd though.


    Any ideas would be appreciated.


    Thanks

  • Any ideas would be appreciated.

    Maybe read Link #1

    Open a NEW thread

    I figured out why my ethernet wired stop to work.

    Open a new thread. This is noise

    Speaking of boxes/chipsets to avoid..

    More noise. Open a thread if you want to post something unrelated to this build.

    Just wanted to chime in on the above ASIX ax88178 chipset.

    Noise


    Use Etcher for burning your microSD card. Maybe this video will help.


    Come on Guys this is getting worse.

    Pages of Noise in this thread.

    And if replied to by members it just grows into more pages of posts that have nothing to do with reporting on issues with the build version.:cursing:

  • Every time there is a storage medium with the LE image present it hangs on the Mecool logo

    Wrong dtb.img ? That seems to be what usually causes this (judging from the previous posts on this issue) :rolleyes:

  • From OP . . .

    If you forgot to use a new device tree or used wrong one and your device doesn't boot:

    • don't panic!

    if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB

    Go and read the instructions again.

    This thread is for discussing kszaq's LE builds, your issue is not with these builds. Raise it in a more appropriate thread. /shrug

  • Perhaps we should all make a better effort (myself included) to make the first reply to an issue more pointed, when it does not belong in this thread. Some do. More need to.


    Some users just don't know any better, and need some simple guidance.

    Some users just don't care, and need repeated, but patient, guidance.


    For every post, there should be few options for initial replies in this thread. Feel free to adlib the sh*t out of this list and repost, as needed. It's merely an example:


    - Already answered


    Easily found (no direct links, they just encourage more not looking before posting)


    Obscure to find (direct link and request to add to OP if important and obscure enough to take time to direct link)


    - Doesn't belong here (advise to pursue other new, or existing thread)


    - Actually applies directly to kszaq build (proceed normally, in this thread)


    Above all, be patient. Most people, even knowledgeable ones at times, aren't sure if an issue is related to this build or not. Often, this is the only build they run on any device they own, and don't have the means to try anything using another build first. So, patiently, reply to these posts, with an "I don't have this issue with this build" or "I know this issue is LibreELEC / Kodi / add-on related" type of answer.


    Please, for the developers sanity...

    - Beelink M18 / S905 / 2GB / 16GB / 1Gbit
    - Stock Android 5.1.1 on 16GB Internal
    - LibreELEC 8.2.x [kszaq] on 32GB Samsung Evo+ microSD

  • PS: Perhaps this would be a good time to add Etcher (etcher.io) to the HowTo here: [HOWTO + FAQ] Install community builds on S905/S905X/S912 device


    It works extremely well, is extremely easy to use, and is extremely cross platform. This may cut down quite a bit on questions about how to initially write the image to flash media from Windows, possibly even Linux and MacOS as well.


    Yes, this is a request :*

    - Beelink M18 / S905 / 2GB / 16GB / 1Gbit
    - Stock Android 5.1.1 on 16GB Internal
    - LibreELEC 8.2.x [kszaq] on 32GB Samsung Evo+ microSD